aboutsummaryrefslogtreecommitdiff
path: root/games/powwow
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-11-15 21:48:51 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-11-15 21:48:51 +0000
commitcf3519b6b6eac1ae15c3aed276612a6e503e0ad3 (patch)
treec205aae6b8ee52fc22781ccdb6b5016afe555c3d /games/powwow
parent9d8843348db510843e56a713dcb05119f012b149 (diff)
downloadports-cf3519b6b6eac1ae15c3aed276612a6e503e0ad3.tar.gz
ports-cf3519b6b6eac1ae15c3aed276612a6e503e0ad3.zip
Notes
Diffstat (limited to 'games/powwow')
-rw-r--r--games/powwow/Makefile37
-rw-r--r--games/powwow/distinfo2
-rw-r--r--games/powwow/files/patch-Makefile12
-rw-r--r--games/powwow/files/patch-follow.c20
-rw-r--r--games/powwow/files/patch-make_it18
-rw-r--r--games/powwow/pkg-descr9
-rw-r--r--games/powwow/pkg-plist4
7 files changed, 102 insertions, 0 deletions
diff --git a/games/powwow/Makefile b/games/powwow/Makefile
new file mode 100644
index 000000000000..3ef1e7af066c
--- /dev/null
+++ b/games/powwow/Makefile
@@ -0,0 +1,37 @@
+# Ports collection Makefile for: powwow
+# Date created: 15 Nov 2004
+# Whom: Juraj Lutter <otis@sk.freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= powwow
+PORTVERSION= 1.2.4
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SUNSITE} \
+ ftp://Linuz.sns.it/pub/Linux/max/powwow/ \
+ ftp://ftp.wilbury.sk/pub/FreeBSD/local/distfiles/
+MASTER_SITE_SUBDIR= games/muds
+
+MAINTAINER= otis@freebsd.sk
+COMMENT= Client to play MUDs
+
+USE_REINPLACE= yes
+
+MAN6= powwow.6
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/defines.h \
+ ${WRKSRC}/list.c ${WRKSRC}/main.c ${WRKSRC}/cmd2.c
+
+do-build:
+ cd ${WRKSRC} && POWWOW_DIR="${DATADIR}" ./make_it
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/powwow ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/powwow.6 ${PREFIX}/man/man6
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/powwow.doc ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/powwow.help ${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/games/powwow/distinfo b/games/powwow/distinfo
new file mode 100644
index 000000000000..a1719a948447
--- /dev/null
+++ b/games/powwow/distinfo
@@ -0,0 +1,2 @@
+MD5 (powwow-1.2.4.tar.gz) = b77f4c16c5bf2b36b6ebd2ddfdc37c38
+SIZE (powwow-1.2.4.tar.gz) = 169825
diff --git a/games/powwow/files/patch-Makefile b/games/powwow/files/patch-Makefile
new file mode 100644
index 000000000000..ed0f0ca07713
--- /dev/null
+++ b/games/powwow/files/patch-Makefile
@@ -0,0 +1,12 @@
+--- Makefile.orig Sat Dec 5 00:17:38 1998
++++ Makefile Wed Feb 13 15:56:45 2002
+@@ -61,8 +61,7 @@
+ @echo "WARNING: if you are coming from a 1.0.x version,"
+ @echo "re-read Changelog and powwow.doc as many things have changed."
+ @echo "In particular, syntax and effects of #prompt and #isprompt changed in 1.1.7"
+- @echo "Press ENTER to continue..."
+- @read dummy
++ @echo
+
+ strip: $(NAME)
+ strip $(NAME)
diff --git a/games/powwow/files/patch-follow.c b/games/powwow/files/patch-follow.c
new file mode 100644
index 000000000000..ec52f03b699b
--- /dev/null
+++ b/games/powwow/files/patch-follow.c
@@ -0,0 +1,20 @@
+--- follow.c.orig Wed Feb 13 15:59:06 2002
++++ follow.c Wed Feb 13 15:59:46 2002
+@@ -96,7 +96,7 @@
+ ioctl(0, TIOCGLTC, &ltcsave);
+ ttyb = ttybsave;
+ ttyb.sg_flags = (ttyb.sg_flags|O_CBREAK) & ~O_ECHO;
+- ioctl(tty_read_fd, TIOCSETP, &ttyb);
++ ioctl(0, TIOCSETP, &ttyb);
+ ltc = ltcsave;
+ ltc.t_suspc = -1;
+ ioctl(0, TIOCSLTC, &ltc);
+@@ -127,7 +127,7 @@
+ #endif /* USE_SGTTY */
+ }
+
+-void main(int argc, char *argv[]) {
++int main(int argc, char *argv[]) {
+ FILE *f;
+ char c = 0, buf[512];
+ int d;
diff --git a/games/powwow/files/patch-make_it b/games/powwow/files/patch-make_it
new file mode 100644
index 000000000000..d936b7fb5395
--- /dev/null
+++ b/games/powwow/files/patch-make_it
@@ -0,0 +1,18 @@
+--- make_it.orig Thu Jan 13 22:50:01 2000
++++ make_it Wed Feb 13 16:21:44 2002
+@@ -50,7 +50,14 @@
+ CC='gcc'
+ CF='-O2 -fomit-frame-pointer -DUSE_RANDOM -DUSE_VT100 -DLINES=25'
+ LF='';;
+-
++ NetBSD|FreeBSD|Darwin)
++ echo "Making Powwow for $OS"
++ CC='gcc'
++ CF='-O2 -pipe -DUSE_SGTTY -DBSD_LIKE -DUSE_RANDOM -DUSE_REGEXP'
++ if [ ! -z "$POWWOW_DIR" ]; then
++ CF="$CF -DPOWWOW_DIR=\\\"$POWWOW_DIR\\\""
++ fi
++ ;;
+ *)
+ echo 'UNSUPPORTED OS!!! Trying with defaults.';;
+ esac
diff --git a/games/powwow/pkg-descr b/games/powwow/pkg-descr
new file mode 100644
index 000000000000..4885435f4510
--- /dev/null
+++ b/games/powwow/pkg-descr
@@ -0,0 +1,9 @@
+powwow is a client program, which replaces telnet for the lazy
+mudder who wants some (only some?) extra features.
+It is primarily designed for DikuMUDs, but nothing prevents its use
+for other types of muds. powwow is based on another client, cancan,
+and cancan was originally inspired by tintin (yet another client)
+by Peter Unold (pjunold@daimi.aau.dk), but is entirely re-written.
+powwow also implements the MUME remote editing protocol, which
+enables you to edit texts on the mud using your own favourite
+editor, several texts at once if you have a windowing terminal.
diff --git a/games/powwow/pkg-plist b/games/powwow/pkg-plist
new file mode 100644
index 000000000000..36e203626a2c
--- /dev/null
+++ b/games/powwow/pkg-plist
@@ -0,0 +1,4 @@
+bin/powwow
+%%DATADIR%%/powwow.doc
+%%DATADIR%%/powwow.help
+@dirrm %%DATADIR%%