aboutsummaryrefslogtreecommitdiff
path: root/games/ppracer
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-01-16 15:46:26 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-01-16 15:46:26 +0000
commit85d8420fa49a94e00b0c1bbc59f2581bdf31b5b8 (patch)
tree62afb05b6939417c87c75591ccf1680e198916f5 /games/ppracer
parent0101c45d3d01305f92585c47f014ad1939e65fe9 (diff)
downloadports-85d8420fa49a94e00b0c1bbc59f2581bdf31b5b8.tar.gz
ports-85d8420fa49a94e00b0c1bbc59f2581bdf31b5b8.zip
Notes
Diffstat (limited to 'games/ppracer')
-rw-r--r--games/ppracer/Makefile35
-rw-r--r--games/ppracer/files/patch-src-squirrel-squirrel.h11
-rw-r--r--games/ppracer/files/patch-src__squirrel__squtils.h (renamed from games/ppracer/files/patch-src-squirrel-squtils.h)4
-rw-r--r--games/ppracer/pkg-descr18
4 files changed, 35 insertions, 33 deletions
diff --git a/games/ppracer/Makefile b/games/ppracer/Makefile
index b6a44ffb46ca..91a2a307f6ac 100644
--- a/games/ppracer/Makefile
+++ b/games/ppracer/Makefile
@@ -5,26 +5,39 @@ PORTNAME= ppracer
DISTVERSION= 0.5alpha
PORTREVISION= 7
CATEGORIES= games
-MASTER_SITES= BERLIOS
+MASTER_SITES= BERLIOS \
+ SF/${PORTNAME}.berlios/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= nemysis@FreeBSD.org
COMMENT= 3D downhill racing game... kind of like TuxRacer Improved
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- freetype:${PORTSDIR}/print/freetype2
+LICENSE= GPLv2
+
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
+ libfreetype.so:${PORTSDIR}/print/freetype2
USE_BZIP2= yes
-USES= gmake pkgconfig dos2unix
+USES= gmake pkgconfig dos2unix desktop-file-utils
+DOS2UNIX_REGEX= .*\.(c|cpp|h)
USE_SDL= mixer sdl
USE_GL= gl
-GNU_CONFIGURE= yes
-DOS2UNIX_REGEX= .*\.(c|cpp|h)
USE_XORG= x11 xi xext xmu xt
+GNU_CONFIGURE= yes
+CFLAGS+= -w
+
+PORTDOCS= AUTHORS ChangeLog ChangeLog-pre0.3.9 ChangeLog-tuxracer
+
+OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
post-patch:
- @${REINPLACE_CMD} -e 's,/usr/X11R6,${LOCALBASE},g' \
- -e 's,libpng12,libpng15,g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's,RacingMode::,,' ${WRKSRC}/src/racingmode.h
+ @${REINPLACE_CMD} -e 's|/usr/X11R6|${LOCALBASE}|g' \
+ -e 's|libpng12|libpng15|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|RacingMode::||' ${WRKSRC}/src/racingmode.h
+ @${REINPLACE_CMD} -e 's|int SQHash|long SQHash|' \
+ ${WRKSRC}/src/squirrel/squirrel.h
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/games/ppracer/files/patch-src-squirrel-squirrel.h b/games/ppracer/files/patch-src-squirrel-squirrel.h
deleted file mode 100644
index 4bafa55bcde4..000000000000
--- a/games/ppracer/files/patch-src-squirrel-squirrel.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/squirrel/squirrel.h.orig 2007-08-12 19:46:49.000000000 +0200
-+++ src/squirrel/squirrel.h 2007-08-12 19:47:31.000000000 +0200
-@@ -44,7 +44,7 @@
- typedef int SQInt32; //must be 32 bits(also on 64bits processors)
- typedef void* SQUserPointer;
- typedef unsigned int SQUnsignedInteger;
--typedef unsigned int SQHash; //should be the same size of a pointer
-+typedef unsigned long SQHash; //should be the same size of a pointer
- typedef SQUnsignedInteger SQBool;
- typedef SQInteger SQRESULT;
-
diff --git a/games/ppracer/files/patch-src-squirrel-squtils.h b/games/ppracer/files/patch-src__squirrel__squtils.h
index b6342ec5f725..daf2e2b5a172 100644
--- a/games/ppracer/files/patch-src-squirrel-squtils.h
+++ b/games/ppracer/files/patch-src__squirrel__squtils.h
@@ -1,5 +1,5 @@
---- src/squirrel/squtils.h.orig 2013-08-28 21:59:50.137272814 +0400
-+++ src/squirrel/squtils.h 2013-08-28 22:00:43.376227477 +0400
+--- ./src/squirrel/squtils.h.orig 2014-01-16 15:30:36.000000000 +0100
++++ ./src/squirrel/squtils.h 2014-01-16 15:30:36.000000000 +0100
@@ -2,6 +2,10 @@
#ifndef _SQUTILS_H_
#define _SQUTILS_H_
diff --git a/games/ppracer/pkg-descr b/games/ppracer/pkg-descr
index 1eaa5c1f2332..f39a658f5543 100644
--- a/games/ppracer/pkg-descr
+++ b/games/ppracer/pkg-descr
@@ -1,13 +1,13 @@
-PlanetPenguin Racer is an OpenGL racing game featuring Tux, the
-Linux mascot. The goal of the game is to slide down a snow- and
-ice-covered mountain as quickly as possible. It is based on the
-GPL version of TuxRacer.
+PlanetPenguin Racer is an OpenGL racing game featuring Tux, the Linux mascot.
+The goal of the game is to slide down a snow- and ice-covered mountain as
+quickly as possible. The goal of the game is to slide down a snow- and
+ice-covered mountain as quickly as possible. It is based on the GPL version
+of TuxRacer 0.6.1.
Differences from TuxRacer include:
- * Course progress bar
- * Themes
- * New terrain types (lava, etc.)
- * Actively developed!
+ * Course progress bar
+ * Themes
+ * New terrain types (lava, etc.)
-WWW: http://developer.berlios.de/projects/ppracer/
+WWW: https://sourceforge.net/projects/ppracer.berlios/