aboutsummaryrefslogtreecommitdiff
path: root/games/prboom
diff options
context:
space:
mode:
authorSimon Barner <barner@FreeBSD.org>2005-11-17 11:56:16 +0000
committerSimon Barner <barner@FreeBSD.org>2005-11-17 11:56:16 +0000
commit3abc395aaf8d6cf16eb191940301ecefcaaec973 (patch)
tree500887be4be1a707d14b35b55a2011774711863b /games/prboom
parentd6b0fe210228088d71cc61ab349fef0467ec2168 (diff)
downloadports-3abc395aaf8d6cf16eb191940301ecefcaaec973.tar.gz
ports-3abc395aaf8d6cf16eb191940301ecefcaaec973.zip
Notes
Diffstat (limited to 'games/prboom')
-rw-r--r--games/prboom/Makefile24
-rw-r--r--games/prboom/distinfo1
-rw-r--r--games/prboom/pkg-plist13
3 files changed, 22 insertions, 16 deletions
diff --git a/games/prboom/Makefile b/games/prboom/Makefile
index cca1750430c1..71626fb8161a 100644
--- a/games/prboom/Makefile
+++ b/games/prboom/Makefile
@@ -16,30 +16,36 @@ COMMENT= A multiplayer-capable and modified version of ID's classic doom game
LIB_DEPENDS= smpeg.1:${PORTSDIR}/multimedia/smpeg
-USE_SDL= mixer net sdl
USE_GMAKE= yes
+USE_SDL= mixer net sdl
+
GNU_CONFIGURE= yes
CONFIGURE_ENV= CFLAGS+="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS+=--disable-cpu-opt
+OPTIONS= GL "Enable OpenGL support" off
+
MAN5= boom.cfg.5
MAN6= prboom.6 prboom-game-server.6
+DATADIR= ${DMDIR}
+
+.include "${.CURDIR}/../doom-data/Makefile.include"
+
+.include <bsd.port.pre.mk>
+
.if defined(WITH_GL)
CONFIGURE_ARGS+=--enable-gl
-USE_GL= yes
+USE_GL= yes
.endif
-.include <bsd.port.pre.mk>
-
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/prboom
- ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/prboom
- ${INSTALL_DATA} ${WRKSRC}/doc/README.compat ${PREFIX}/share/doc/prboom
- ${INSTALL_DATA} ${WRKSRC}/doc/README.demos ${PREFIX}/share/doc/prboom
- ${INSTALL_DATA} ${WRKSRC}/doc/boom.txt ${PREFIX}/share/doc/prboom
+ ${MKDIR} ${DOCSDIR}
+. for f in README doc/README.compat doc/README.demos doc/boom.txt
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
.endif
.include <bsd.port.post.mk>
diff --git a/games/prboom/distinfo b/games/prboom/distinfo
index 66d61c66e890..525b4a5884ee 100644
--- a/games/prboom/distinfo
+++ b/games/prboom/distinfo
@@ -1,2 +1,3 @@
MD5 (prboom-2.2.6.tar.gz) = ef0abe0aad017514857552434b5c6aaa
+SHA256 (prboom-2.2.6.tar.gz) = 200d3c50b082ae46be8c014bb576b4e2d23b1704508fd528c47e3e2b3b04759e
SIZE (prboom-2.2.6.tar.gz) = 1047612
diff --git a/games/prboom/pkg-plist b/games/prboom/pkg-plist
index 0665b1160af6..8f063d02752b 100644
--- a/games/prboom/pkg-plist
+++ b/games/prboom/pkg-plist
@@ -1,9 +1,8 @@
bin/prboom
bin/prboom-game-server
-share/doom/prboom.wad
-@dirrm share/doom
-%%PORTDOCS%%share/doc/prboom/README
-%%PORTDOCS%%share/doc/prboom/README.compat
-%%PORTDOCS%%share/doc/prboom/README.demos
-%%PORTDOCS%%share/doc/prboom/boom.txt
-%%PORTDOCS%%@dirrm share/doc/prboom
+%%DATADIR%%/prboom.wad
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/README.compat
+%%PORTDOCS%%%%DOCSDIR%%/README.demos
+%%PORTDOCS%%%%DOCSDIR%%/boom.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%