aboutsummaryrefslogtreecommitdiff
path: root/games/pvpgn/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-09-04 12:18:18 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-09-04 12:18:18 +0000
commit6acd6844db613b90a089b40cc1c882d4bceaf35b (patch)
treebedf62dc84f317a82e0b744125099d90a8a2338e /games/pvpgn/Makefile
parentb98c462e47438d13a33073d0ad685272d406cf16 (diff)
downloadports-6acd6844db613b90a089b40cc1c882d4bceaf35b.tar.gz
ports-6acd6844db613b90a089b40cc1c882d4bceaf35b.zip
Notes
Diffstat (limited to 'games/pvpgn/Makefile')
-rw-r--r--games/pvpgn/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/games/pvpgn/Makefile b/games/pvpgn/Makefile
index a2bd4a015039..18cba516c91e 100644
--- a/games/pvpgn/Makefile
+++ b/games/pvpgn/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pvpgn
-PORTVERSION= 1.7.7
+PORTVERSION= 1.7.8
CATEGORIES= games
MASTER_SITES= http://download.berlios.de/pvpgn/
DISTFILES= ${EXTRACT_ONLY} pvpgn-support-1.0.tar.gz
@@ -43,7 +43,8 @@ MAN5= bnetd.conf.5 bntext.5
OPTIONS= MYSQL "Include MySQL user accounts support" off \
PGSQL "Include PostgreSQL user accounts support" off \
- SQLITE3 "Include SQLite3 user accounts support" off
+ SQLITE3 "Include SQLite3 user accounts support" off \
+ D2 "Enable Diablo II server (D2CS/D2DBS)" on
.include <bsd.port.pre.mk>
@@ -62,6 +63,13 @@ CONFIGURE_ARGS+=--with-sqlite3
LIB_DEPENDS+= sqlite3.8:${PORTSDIR}/databases/sqlite3
.endif
+.if defined(WITHOUT_D2)
+CONFIGURE_ARGS+= --disable-d2cs --disable-d2dbs
+PLIST_SUB+= WITH_D2="@comment "
+.else
+PLIST_SUB+= WITH_D2=""
+.endif
+
## support files
SUPPORT_SUFFX= .tar.gz