aboutsummaryrefslogtreecommitdiff
path: root/games/pvpgn
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2014-10-11 23:33:52 +0000
committerJason E. Hale <jhale@FreeBSD.org>2014-10-11 23:33:52 +0000
commit81902b1eca77753787957d7cfb58e70d6635c976 (patch)
treedd88357fa3a9cfbb1fcb54f974052e2c42333eff /games/pvpgn
parent30216fb40ca2c5dcbf4f66d109ed599f65d70436 (diff)
downloadports-81902b1eca77753787957d7cfb58e70d6635c976.tar.gz
ports-81902b1eca77753787957d7cfb58e70d6635c976.zip
Notes
Diffstat (limited to 'games/pvpgn')
-rw-r--r--games/pvpgn/Makefile38
-rw-r--r--games/pvpgn/pkg-plist29
2 files changed, 16 insertions, 51 deletions
diff --git a/games/pvpgn/Makefile b/games/pvpgn/Makefile
index 67bcf589296d..04decb86c37a 100644
--- a/games/pvpgn/Makefile
+++ b/games/pvpgn/Makefile
@@ -5,8 +5,7 @@ PORTNAME= pvpgn
PORTVERSION= 1.8.5
PORTREVISION= 1
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_BERLIOS}
-MASTER_SITE_SUBDIR= pvpgn
+MASTER_SITES= BERLIOS
DISTFILES= ${EXTRACT_ONLY} pvpgn-support-1.2.tar.gz
DIST_SUBDIR= pvpgn
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
@@ -38,34 +37,21 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/pvpgn \
USE_RC_SUBR= bnetd
-OPTIONS_DEFINE= MYSQL PGSQL SQLITE3 D2
-D2_DESC= Diablo II server (D2CS/D2DBS)
-
+OPTIONS_DEFINE= D2 MYSQL PGSQL SQLITE3
OPTIONS_DEFAULT= D2
+OPTIONS_SUB= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MMYSQL}
-USE_MYSQL= yes
-CONFIGURE_ARGS+=--with-mysql
-.endif
+D2_DESC= Diablo II server (D2CS/D2DBS)
+D2_CONFIGURE_ENABLE= d2cs d2dbs
-.if ${PORT_OPTIONS:MPGSQL}
-USE_PGSQL= yes
-CONFIGURE_ARGS+=--with-pgsql
-.endif
+MYSQL_USE= MYSQL=yes
+MYSQL_CONFIGURE_WITH= mysql
-.if ${PORT_OPTIONS:MSQLITE3}
-USE_SQLITE= 3
-CONFIGURE_ARGS+=--with-sqlite3
-.endif
+PGSQL_USES= pgsql
+PGSQL_CONFIGURE_WITH= pgsql
-.if ${PORT_OPTIONS:MD2}
-PLIST_SUB+= WITH_D2=""
-.else
-CONFIGURE_ARGS+= --disable-d2cs --disable-d2dbs
-PLIST_SUB+= WITH_D2="@comment "
-.endif
+SQLITE3_USE= SQLITE=3
+SQLITE3_CONFIGURE_WITH= sqlite3
## support files
@@ -91,11 +77,9 @@ post-install:
## Additional documentation
-.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in INSTALL.unix PORTS README.fdwatch README.storage bnmotd.txt
${INSTALL_DATA} ${WRKSRC}/../docs/${i} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>
diff --git a/games/pvpgn/pkg-plist b/games/pvpgn/pkg-plist
index 508af4072e0c..70ba265dc5b7 100644
--- a/games/pvpgn/pkg-plist
+++ b/games/pvpgn/pkg-plist
@@ -1,4 +1,3 @@
-@unexec %D/etc/rc.d/bnetd.sh stop > /dev/null 2>&1 || true
bin/bnbot
bin/bncdb
bin/bnchat
@@ -32,9 +31,9 @@ etc/pvpgn/bnxpcalc.conf-sample
etc/pvpgn/bnxplevel.conf-sample
etc/pvpgn/channel.conf-sample
etc/pvpgn/command_groups.conf-sample
-%%WITH_D2%%etc/pvpgn/d2cs.conf-sample
-%%WITH_D2%%etc/pvpgn/d2dbs.conf-sample
-%%WITH_D2%%etc/pvpgn/d2server.ini-sample
+%%D2%%etc/pvpgn/d2cs.conf-sample
+%%D2%%etc/pvpgn/d2dbs.conf-sample
+%%D2%%etc/pvpgn/d2server.ini-sample
etc/pvpgn/news.txt-sample
etc/pvpgn/realm.conf-sample
etc/pvpgn/sql_DB_layout.conf-sample
@@ -59,8 +58,8 @@ man/man5/bnetd.conf.5.gz
man/man5/bntext.5.gz
sbin/bnetd
sbin/bntrackd
-%%WITH_D2%%sbin/d2cs
-%%WITH_D2%%sbin/d2dbs
+%%D2%%sbin/d2cs
+%%D2%%sbin/d2dbs
%%DATADIR%%/files/IX86ver1.mpq
%%DATADIR%%/files/PMACver1.mpq
%%DATADIR%%/files/XMACver1.mpq
@@ -116,21 +115,3 @@ sbin/bntrackd
%%DATADIR%%/files/tos_RUS.txt
%%DATADIR%%/files/tos_SIN.txt
%%DATADIR%%/files/tos_USA.txt
-@dirrm %%DATADIR%%/bak/charinfo
-@dirrm %%DATADIR%%/bak/charsave
-@dirrm %%DATADIR%%/bak
-@dirrm %%DATADIR%%/bnmail
-@dirrm %%DATADIR%%/chanlogs
-@dirrm %%DATADIR%%/charinfo
-@dirrm %%DATADIR%%/charsave
-@dirrm %%DATADIR%%/clans
-@dirrm %%DATADIR%%/files
-@dirrm %%DATADIR%%/ladders
-@dirrm %%DATADIR%%/reports
-@dirrm %%DATADIR%%/status
-@dirrm %%DATADIR%%/teams
-@dirrm %%DATADIR%%/users
-@dirrm %%DATADIR%%/userscdb
-@dirrmtry %%DATADIR%%
-@dirrm etc/pvpgn
-%%PORTDOCS%%@dirrm %%DOCSDIR%%