aboutsummaryrefslogtreecommitdiff
path: root/games/pvpgn
diff options
context:
space:
mode:
authorSimon Barner <barner@FreeBSD.org>2005-05-23 16:13:41 +0000
committerSimon Barner <barner@FreeBSD.org>2005-05-23 16:13:41 +0000
commit82fe928873b1964204314f1384724f8edc1f754d (patch)
treee81236a584c26c59af7b3c3d5f0dc53549942192 /games/pvpgn
parent53fe81cdd6ac4cf2db16de07d3f209f16430a2f1 (diff)
downloadports-82fe928873b1964204314f1384724f8edc1f754d.tar.gz
ports-82fe928873b1964204314f1384724f8edc1f754d.zip
Notes
Diffstat (limited to 'games/pvpgn')
-rw-r--r--games/pvpgn/Makefile28
-rw-r--r--games/pvpgn/distinfo4
-rw-r--r--games/pvpgn/files/patch-Makefile.in6
-rw-r--r--games/pvpgn/files/patch-conf-bnetd.conf.in15
-rw-r--r--games/pvpgn/pkg-plist146
5 files changed, 97 insertions, 102 deletions
diff --git a/games/pvpgn/Makefile b/games/pvpgn/Makefile
index 948986768981..2f45fdcc65ce 100644
--- a/games/pvpgn/Makefile
+++ b/games/pvpgn/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pvpgn
-PORTVERSION= 1.7.5
+PORTVERSION= 1.7.7
CATEGORIES= games
MASTER_SITES= http://download.berlios.de/pvpgn/
DISTFILES= ${EXTRACT_ONLY} pvpgn-support-1.0.tar.gz
@@ -41,12 +41,11 @@ MAN1= bnbot.1 bnchat.1 bnetd.1 bnftp.1 bni2tga.1 bnibuild.1 \
bniextract.1 bnilist.1 bnpass.1 bnstat.1 bntrackd.1 tgainfo.1
MAN5= bnetd.conf.5 bntext.5
-.if defined(WITH_MYSQL_VER)
-WITH_MYSQL= yes
-.if ${WITH_MYSQL_VER} == 3
-WANT_MYSQL_VER= 323
-.endif
-.endif
+OPTIONS= MYSQL "Include MySQL user accounts support" off \
+ PGSQL "Include PostgreSQL user accounts support" off \
+ SQLITE3 "Include SQLite3 user accounts support" off
+
+.include <bsd.port.pre.mk>
.if defined(WITH_MYSQL)
USE_MYSQL= yes
@@ -58,19 +57,16 @@ USE_PGSQL= yes
CONFIGURE_ARGS+=--with-pgsql=${LOCALBASE}
.endif
+.if defined(WITH_SQLITE3)
+CONFIGURE_ARGS+=--with-sqlite3
+LIB_DEPENDS+= sqlite3.8:${PORTSDIR}/databases/sqlite3
+.endif
+
## support files
SUPPORT_SUFFX= .tar.gz
SUPPORT_FILES= pvpgn-support-1.0
-pre-fetch:
- @${ECHO} ""
- @${ECHO} "You may use the following build options:"
- @${ECHO} ""
- @${ECHO} " WITH_MYSQL=yes Include MySQL user account support"
- @${ECHO} " WITH_PGSQL=yes Include PostgreSQL user account support"
- @${ECHO} ""
-
post-extract:
@${MKDIR} ${WRKSRC}/${SUPPORT_FILES}
@${TAR} -C ${WRKSRC} -xzf ${DISTDIR}/${DIST_SUBDIR}/${SUPPORT_FILES}${SUPPORT_SUFFX}
@@ -101,4 +97,4 @@ post-install:
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/pvpgn/distinfo b/games/pvpgn/distinfo
index 4d340fbe0c20..ce5516aab90d 100644
--- a/games/pvpgn/distinfo
+++ b/games/pvpgn/distinfo
@@ -1,4 +1,4 @@
-MD5 (pvpgn/pvpgn-1.7.5.tar.bz2) = b38b336dc3e0ee3e6489ed28151539ed
-SIZE (pvpgn/pvpgn-1.7.5.tar.bz2) = 980076
+MD5 (pvpgn/pvpgn-1.7.7.tar.bz2) = 465e18b04ca903eca7e2973a2d557e46
+SIZE (pvpgn/pvpgn-1.7.7.tar.bz2) = 983639
MD5 (pvpgn/pvpgn-support-1.0.tar.gz) = 8ba36144ea3a7efe200536c142bb7886
SIZE (pvpgn/pvpgn-support-1.0.tar.gz) = 126047
diff --git a/games/pvpgn/files/patch-Makefile.in b/games/pvpgn/files/patch-Makefile.in
index 86b04064652e..ca2e7573c529 100644
--- a/games/pvpgn/files/patch-Makefile.in
+++ b/games/pvpgn/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig Fri Mar 4 00:03:08 2005
-+++ Makefile.in Tue Mar 8 00:58:17 2005
-@@ -667,8 +667,8 @@
+--- Makefile.in.orig Tue Apr 26 10:28:10 2005
++++ Makefile.in Fri May 20 00:47:48 2005
+@@ -669,8 +669,8 @@
${INSTALL_DIRS} ${DESTDIR}/${confdir}
@list='${CONFS}'; for p in $$list; do \
if test -f ${SRC_CONFDIR}/$$p; then \
diff --git a/games/pvpgn/files/patch-conf-bnetd.conf.in b/games/pvpgn/files/patch-conf-bnetd.conf.in
index 070601e92411..830bc955234b 100644
--- a/games/pvpgn/files/patch-conf-bnetd.conf.in
+++ b/games/pvpgn/files/patch-conf-bnetd.conf.in
@@ -1,5 +1,5 @@
---- ../conf/bnetd.conf.in.orig Tue Mar 8 00:59:58 2005
-+++ ../conf/bnetd.conf.in Tue Mar 8 01:02:16 2005
+--- ../conf/bnetd.conf.in.orig Fri May 20 00:48:15 2005
++++ ../conf/bnetd.conf.in Fri May 20 00:50:13 2005
@@ -15,8 +15,8 @@
# a leading '#'). If none are specified, the userid will not be changed. #
#----------------------------------------------------------------------------#
@@ -11,7 +11,7 @@
# effective_user = #12
# effective_group = #20
-@@ -75,14 +75,14 @@
+@@ -77,14 +77,14 @@
ipbanfile = /usr/local/etc/bnban.conf
helpfile = /usr/local/etc/bnhelp.conf
mpqfile = /usr/local/etc/autoupdate.conf
@@ -24,21 +24,20 @@
xplevelfile = /usr/local/etc/bnxplevel.conf
xpcalcfile = /usr/local/etc/bnxpcalc.conf
-#pidfile = /usr/local/var/bnetd.pid
-+pidfile = /var/run/pvpgn/bnetd.pid
++pidfile = /var/run/pvpgn/bnetd.pid
ladderdir = /usr/local/var/ladders
command_groups_file = /usr/local/etc/command_groups.conf
tournament_file = /usr/local/etc/tournament.conf
-@@ -112,8 +112,7 @@
+@@ -114,7 +114,7 @@
# warn
# error
# fatal
-loglevels = fatal,error,warn,info,debug,trace
--#loglevels = fatal,error,warn,info
+loglevels = fatal,error,warn
+ #loglevels = fatal,error,warn,info
# #
- ##############################################################################
-@@ -300,7 +299,7 @@
+@@ -302,7 +302,7 @@
# List additional game types to be counted as ladder games
# Curently allowed types: topvbot, melee, ffa, oneonone
# Example: ladder_games = "topvbot,oneonone"
diff --git a/games/pvpgn/pkg-plist b/games/pvpgn/pkg-plist
index 7c5ffb8f051c..24a0f5fd472c 100644
--- a/games/pvpgn/pkg-plist
+++ b/games/pvpgn/pkg-plist
@@ -46,78 +46,78 @@ sbin/bnetd
sbin/bntrackd
sbin/d2cs
sbin/d2dbs
-share/pvpgn/files/IX86ver1.mpq
-share/pvpgn/files/PMACver1.mpq
-share/pvpgn/files/WAR3IX86.mpq
-share/pvpgn/files/XMACver1.mpq
-share/pvpgn/files/ad000001.mng
-share/pvpgn/files/ad000001.smk
-share/pvpgn/files/ad000004.mng
-share/pvpgn/files/bnserver-D2DV.ini
-share/pvpgn/files/bnserver-D2XP.ini
-share/pvpgn/files/bnserver-WAR3.ini
-share/pvpgn/files/bnserver.ini
-share/pvpgn/files/chathelp-war3-default.txt
-share/pvpgn/files/chathelp-war3-enUS.txt
-share/pvpgn/files/chathelp-war3-frFR.txt
-share/pvpgn/files/chathelp-war3-ruRU.txt
-share/pvpgn/files/chathelp-war3-zhCN.txt
-share/pvpgn/files/icons-WAR3.bni
-share/pvpgn/files/icons.bni
-share/pvpgn/files/icons_STAR.bni
-share/pvpgn/files/matchmaking-war3-default.dat
-share/pvpgn/files/matchmaking-war3-enUS.dat
-share/pvpgn/files/newaccount-default.txt
-share/pvpgn/files/newaccount-enUS.txt
-share/pvpgn/files/newbie.save
-share/pvpgn/files/termsofservice-default.txt
-share/pvpgn/files/termsofservice-enUS.txt
-share/pvpgn/files/tos-unicode_BRA.txt
-share/pvpgn/files/tos-unicode_CHI.txt
-share/pvpgn/files/tos-unicode_DEU.txt
-share/pvpgn/files/tos-unicode_ENU.txt
-share/pvpgn/files/tos-unicode_ESP.txt
-share/pvpgn/files/tos-unicode_FRA.txt
-share/pvpgn/files/tos-unicode_HAN.txt
-share/pvpgn/files/tos-unicode_ITA.txt
-share/pvpgn/files/tos-unicode_JPN.txt
-share/pvpgn/files/tos-unicode_KOR.txt
-share/pvpgn/files/tos-unicode_POL.txt
-share/pvpgn/files/tos-unicode_POR.txt
-share/pvpgn/files/tos-unicode_RUS.txt
-share/pvpgn/files/tos-unicode_SIN.txt
-share/pvpgn/files/tos-unicode_USA.txt
-share/pvpgn/files/tos.txt
-share/pvpgn/files/tos_BRA.txt
-share/pvpgn/files/tos_CHI.txt
-share/pvpgn/files/tos_DEU.txt
-share/pvpgn/files/tos_ENU.txt
-share/pvpgn/files/tos_ESP.txt
-share/pvpgn/files/tos_FRA.txt
-share/pvpgn/files/tos_HAN.txt
-share/pvpgn/files/tos_ITA.txt
-share/pvpgn/files/tos_JPN.txt
-share/pvpgn/files/tos_KOR.txt
-share/pvpgn/files/tos_POL.txt
-share/pvpgn/files/tos_POR.txt
-share/pvpgn/files/tos_RUS.txt
-share/pvpgn/files/tos_SIN.txt
-share/pvpgn/files/tos_USA.txt
-@dirrm share/pvpgn/bak/charinfo
-@dirrm share/pvpgn/bak/charsave
-@dirrm share/pvpgn/bak
-@dirrm share/pvpgn/bnmail
-@dirrm share/pvpgn/chanlogs
-@dirrm share/pvpgn/charinfo
-@dirrm share/pvpgn/charsave
-@dirrm share/pvpgn/clans
-@dirrm share/pvpgn/files
-@dirrm share/pvpgn/ladders
-@dirrm share/pvpgn/reports
-@dirrm share/pvpgn/status
-@dirrm share/pvpgn/teams
-@dirrm share/pvpgn/users
-@dirrm share/pvpgn/userscdb
-@unexec rmdir %D/share/pvpgn 2>/dev/null || true
+%%DATADIR%%/files/IX86ver1.mpq
+%%DATADIR%%/files/PMACver1.mpq
+%%DATADIR%%/files/WAR3IX86.mpq
+%%DATADIR%%/files/XMACver1.mpq
+%%DATADIR%%/files/ad000001.mng
+%%DATADIR%%/files/ad000001.smk
+%%DATADIR%%/files/ad000004.mng
+%%DATADIR%%/files/bnserver-D2DV.ini
+%%DATADIR%%/files/bnserver-D2XP.ini
+%%DATADIR%%/files/bnserver-WAR3.ini
+%%DATADIR%%/files/bnserver.ini
+%%DATADIR%%/files/chathelp-war3-default.txt
+%%DATADIR%%/files/chathelp-war3-enUS.txt
+%%DATADIR%%/files/chathelp-war3-frFR.txt
+%%DATADIR%%/files/chathelp-war3-ruRU.txt
+%%DATADIR%%/files/chathelp-war3-zhCN.txt
+%%DATADIR%%/files/icons-WAR3.bni
+%%DATADIR%%/files/icons.bni
+%%DATADIR%%/files/icons_STAR.bni
+%%DATADIR%%/files/matchmaking-war3-default.dat
+%%DATADIR%%/files/matchmaking-war3-enUS.dat
+%%DATADIR%%/files/newaccount-default.txt
+%%DATADIR%%/files/newaccount-enUS.txt
+%%DATADIR%%/files/newbie.save
+%%DATADIR%%/files/termsofservice-default.txt
+%%DATADIR%%/files/termsofservice-enUS.txt
+%%DATADIR%%/files/tos-unicode_BRA.txt
+%%DATADIR%%/files/tos-unicode_CHI.txt
+%%DATADIR%%/files/tos-unicode_DEU.txt
+%%DATADIR%%/files/tos-unicode_ENU.txt
+%%DATADIR%%/files/tos-unicode_ESP.txt
+%%DATADIR%%/files/tos-unicode_FRA.txt
+%%DATADIR%%/files/tos-unicode_HAN.txt
+%%DATADIR%%/files/tos-unicode_ITA.txt
+%%DATADIR%%/files/tos-unicode_JPN.txt
+%%DATADIR%%/files/tos-unicode_KOR.txt
+%%DATADIR%%/files/tos-unicode_POL.txt
+%%DATADIR%%/files/tos-unicode_POR.txt
+%%DATADIR%%/files/tos-unicode_RUS.txt
+%%DATADIR%%/files/tos-unicode_SIN.txt
+%%DATADIR%%/files/tos-unicode_USA.txt
+%%DATADIR%%/files/tos.txt
+%%DATADIR%%/files/tos_BRA.txt
+%%DATADIR%%/files/tos_CHI.txt
+%%DATADIR%%/files/tos_DEU.txt
+%%DATADIR%%/files/tos_ENU.txt
+%%DATADIR%%/files/tos_ESP.txt
+%%DATADIR%%/files/tos_FRA.txt
+%%DATADIR%%/files/tos_HAN.txt
+%%DATADIR%%/files/tos_ITA.txt
+%%DATADIR%%/files/tos_JPN.txt
+%%DATADIR%%/files/tos_KOR.txt
+%%DATADIR%%/files/tos_POL.txt
+%%DATADIR%%/files/tos_POR.txt
+%%DATADIR%%/files/tos_RUS.txt
+%%DATADIR%%/files/tos_SIN.txt
+%%DATADIR%%/files/tos_USA.txt
+@dirrm %%DATADIR%%/bak/charinfo
+@dirrm %%DATADIR%%/bak/charsave
+@dirrm %%DATADIR%%/bak
+@dirrm %%DATADIR%%/bnmail
+@dirrm %%DATADIR%%/chanlogs
+@dirrm %%DATADIR%%/charinfo
+@dirrm %%DATADIR%%/charsave
+@dirrm %%DATADIR%%/clans
+@dirrm %%DATADIR%%/files
+@dirrm %%DATADIR%%/ladders
+@dirrm %%DATADIR%%/reports
+@dirrm %%DATADIR%%/status
+@dirrm %%DATADIR%%/teams
+@dirrm %%DATADIR%%/users
+@dirrm %%DATADIR%%/userscdb
+@unexec rmdir %D/%%DATADIR%% 2>/dev/null || true
@dirrm etc/pvpgn
%%PORTDOCS%%@dirrm %%DOCSDIR%%