aboutsummaryrefslogtreecommitdiff
path: root/games/py-fife
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-03-02 18:06:24 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-03-02 18:06:24 +0000
commitca1bfddb2361a930706c77ab2bd1068b859fbae5 (patch)
tree24ebebd698590dae887b46de296f63e68a40e485 /games/py-fife
parent275adb1394aac968cd8fbd08da022521bf88a6e4 (diff)
downloadports-ca1bfddb2361a930706c77ab2bd1068b859fbae5.tar.gz
ports-ca1bfddb2361a930706c77ab2bd1068b859fbae5.zip
Notes
Diffstat (limited to 'games/py-fife')
-rw-r--r--games/py-fife/Makefile28
-rw-r--r--games/py-fife/distinfo10
-rw-r--r--games/py-fife/files/patch-SConstruct15
-rw-r--r--games/py-fife/pkg-plist5
4 files changed, 26 insertions, 32 deletions
diff --git a/games/py-fife/Makefile b/games/py-fife/Makefile
index 0516036bf35d..5a97aa4e1d48 100644
--- a/games/py-fife/Makefile
+++ b/games/py-fife/Makefile
@@ -2,50 +2,52 @@
# $FreeBSD$
PORTNAME= fife
-PORTVERSION= 0.3.3r3
-PORTREVISION= 3
+PORTVERSION= 0.3.4
CATEGORIES= games
MASTER_SITES= http://sourceforge.net/projects/${PORTNAME}/files/active/src/:source \
- http://sourceforge.net/projects/${PORTNAME}/files/active/demos/:demo
+ http://sourceforge.net/projects/${PORTNAME}/files/active/demos/:demo \
+ http://sourceforge.net/projects/${PORTNAME}/files/active/tools/:tools
DISTNAME= ${PORTNAME}_${PORTVERSION}
DISTFILES+= ${DISTNAME}.tar.gz:source \
- ${DISTNAME}_demos.tar.gz:demo
+ ${DISTNAME}_demos.tar.gz:demo \
+ ${DISTNAME}_tools.tar.gz:tools
MAINTAINER= fiziologus@gmail.com
COMMENT= Flexible Isometric Free Engine
-FETCH_ARGS= -Fpr
-
BUILD_DEPENDS= ${LOCALBASE}/bin/swig:${PORTSDIR}/devel/swig13
-LIB_DEPENDS= vorbisfile.6:${PORTSDIR}/audio/libvorbis \
- guichan.2:${PORTSDIR}/devel/guichan \
+LIB_DEPENDS= vorbisfile:${PORTSDIR}/audio/libvorbis \
+ guichan:${PORTSDIR}/devel/guichan \
boost_filesystem:${PORTSDIR}/devel/boost-libs \
png15:${PORTSDIR}/graphics/png
+FETCH_ARGS= -Fpr
+
USE_SDL= sdl ttf image
USE_OPENAL= al
USE_SCONS= yes
+SCONS_ARGS= --prefix=${PREFIX} --python-prefix=${PYTHON_SITELIBDIR}
SCONS_BUILDENV= SWIG=${LOCALBASE}/bin/swig \
- CXX=${CXX} CPP=${CPP}
+ CXX=${CXX}
SCONS_TARGET= fife-python
SCONS_INSTALL_TARGET= install-python
-USE_PYTHON= yes
+USE_PYTHON= 2.7
USE_XORG= xcursor
USE_GL= gl
-USE_GNOME= pkgconfig
+USE_PKGCONFIG= build
post-patch:
- ${REINPLACE_CMD} -e 's/X11R6/local/g' ${WRKSRC}/build/openbsd4-config.py && \
+ ${REINPLACE_CMD} -e 's/X11R6/local/g; s/libpng/ligpng15/g' ${WRKSRC}/build/openbsd4-config.py && \
${MV} ${WRKSRC}/build/openbsd4-config.py ${WRKSRC}/build/${PYTHON_PLATFORM}-config.py
post-install:
${MKDIR} ${DATADIR}
- ${MV} ${WRKSRC}/tools ${DATADIR}
+ ${MV} ${WRKDIR}/tools ${DATADIR}
${MV} ${WRKDIR}/demos ${DATADIR}
${MKDIR} ${DOCSDIR}
.for FILE in README AUTHORS CHANGES COPYING
diff --git a/games/py-fife/distinfo b/games/py-fife/distinfo
index d0abe21b40d0..4e819b1778b1 100644
--- a/games/py-fife/distinfo
+++ b/games/py-fife/distinfo
@@ -1,4 +1,6 @@
-SHA256 (fife_0.3.3r3.tar.gz) = 172bd6ececa37c3e98689f5b4b00cb86bcf611bca714cf88aef91ba6d05ea16e
-SIZE (fife_0.3.3r3.tar.gz) = 4930412
-SHA256 (fife_0.3.3r3_demos.tar.gz) = 07b454c3174e686b49080292fa77d18b196941ed65dd7e3bf62b4d9b40347177
-SIZE (fife_0.3.3r3_demos.tar.gz) = 23351591
+SHA256 (fife_0.3.4.tar.gz) = 8a28d570ef8166b0b571047b8bdc482b09c05c4f9bb754f5564964b8c06dd6f7
+SIZE (fife_0.3.4.tar.gz) = 1398594
+SHA256 (fife_0.3.4_demos.tar.gz) = 4f76b921f2a8782ebaf168b24cdc2c94099084e260a61fa30a467b5edf3b5fc6
+SIZE (fife_0.3.4_demos.tar.gz) = 23355196
+SHA256 (fife_0.3.4_tools.tar.gz) = 90a3ea6c1b15ce87a535209f3f726e82fb06b518f3bbcf985b6950782227f98f
+SIZE (fife_0.3.4_tools.tar.gz) = 506204
diff --git a/games/py-fife/files/patch-SConstruct b/games/py-fife/files/patch-SConstruct
deleted file mode 100644
index 41cc5cc12555..000000000000
--- a/games/py-fife/files/patch-SConstruct
+++ /dev/null
@@ -1,15 +0,0 @@
---- SConstruct.orig 2012-05-21 16:35:59.000000000 +0400
-+++ SConstruct 2012-05-21 16:43:47.000000000 +0400
-@@ -308,6 +308,12 @@
- if os.environ.has_key('SWIG'):
- env['SWIG'] = os.environ['SWIG']
-
-+if os.environ.has_key('CXX'):
-+ env['CXX'] = os.environ['CXX']
-+
-+if os.environ.has_key('CPP'):
-+ env['CPP'] = os.environ['CPP']
-+
- haveusercxxflags = False
-
- if os.environ.has_key('CXXFLAGS'):
diff --git a/games/py-fife/pkg-plist b/games/py-fife/pkg-plist
index cea609577295..a877ef35e39b 100644
--- a/games/py-fife/pkg-plist
+++ b/games/py-fife/pkg-plist
@@ -104,11 +104,13 @@
%%DATADIR%%/demos/rio_de_hola/maps/shrine.xml
%%DATADIR%%/demos/rio_de_hola/maps/tourist_beach.xml
%%DATADIR%%/demos/rio_de_hola/maps/tourist_beach_test.xml
+%%DATADIR%%/demos/rio_de_hola/misc/black_cell.png
%%DATADIR%%/demos/rio_de_hola/misc/current_rendersetup/LICENSE
%%DATADIR%%/demos/rio_de_hola/misc/current_rendersetup/non-animated_object_rendersetup.blend
%%DATADIR%%/demos/rio_de_hola/misc/current_rendersetup/rendering_setup.blend
%%DATADIR%%/demos/rio_de_hola/misc/diamond_160x96_template_v01.blend
%%DATADIR%%/demos/rio_de_hola/misc/infotext.txt
+%%DATADIR%%/demos/rio_de_hola/misc/mask_cell.png
%%DATADIR%%/demos/rio_de_hola/misc/mask_diamond_126_96.png
%%DATADIR%%/demos/rio_de_hola/misc/rotation+location_test/facing000/045r.png
%%DATADIR%%/demos/rio_de_hola/misc/rotation+location_test/facing000/135r.png
@@ -376,6 +378,7 @@
%%DATADIR%%/tools/atlas/stable.h
%%DATADIR%%/tools/editor/fonts/FreeSans.ttf
%%DATADIR%%/tools/editor/gui/cameradialog.xml
+%%DATADIR%%/tools/editor/gui/cellview.xml
%%DATADIR%%/tools/editor/gui/eleveditor.xml
%%DATADIR%%/tools/editor/gui/error.xml
%%DATADIR%%/tools/editor/gui/filebrowser.xml
@@ -421,10 +424,12 @@
%%DATADIR%%/tools/editor/gui/selection.xml
%%DATADIR%%/tools/editor/gui/statuspanel.xml
%%DATADIR%%/tools/editor/gui/tools.xml
+%%DATADIR%%/tools/editor/lang/help_cellview.txt
%%DATADIR%%/tools/editor/lang/help_object_edit.txt
%%DATADIR%%/tools/editor/lang/infotext.txt
%%DATADIR%%/tools/editor/LICENSE
%%DATADIR%%/tools/editor/plugins/CameraEdit.py
+%%DATADIR%%/tools/editor/plugins/CellView.py
%%DATADIR%%/tools/editor/plugins/HistoryManager.py
%%DATADIR%%/tools/editor/plugins/InstanceHighlighter.py
%%DATADIR%%/tools/editor/plugins/LayerTool.py