aboutsummaryrefslogtreecommitdiff
path: root/games/py-mnemosyne/Makefile
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-01-13 03:49:42 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-01-13 03:49:42 +0000
commita3fb4779a377b8c945fb10b58506a4c9fe2e5414 (patch)
tree498088fe41ade1ee837de26117082a5d6fb78ca7 /games/py-mnemosyne/Makefile
parent7ae69497ef57a82b117b9739f2b7e78c5bf9cfd7 (diff)
downloadports-a3fb4779a377b8c945fb10b58506a4c9fe2e5414.tar.gz
ports-a3fb4779a377b8c945fb10b58506a4c9fe2e5414.zip
Notes
Diffstat (limited to 'games/py-mnemosyne/Makefile')
-rw-r--r--games/py-mnemosyne/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/games/py-mnemosyne/Makefile b/games/py-mnemosyne/Makefile
new file mode 100644
index 000000000000..584704775d21
--- /dev/null
+++ b/games/py-mnemosyne/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: py-mnemosyne
+# Date created: 11 Jan 2008
+# Whom: Beech Rintoul <beech@FreeBSD.org>
+#
+#
+# $FreeBSD$
+#
+
+PORTNAME= mnemosyne
+PORTVERSION= 1.0
+CATEGORIES= games python
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= ${PORTNAME}-proj
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= mnemosyne-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= beech@FreeBSD.org
+COMMENT= Flash-card tool which optimises your learning process
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PLIST_SUB+= PYVER=${PYTHON_VERSION}
+
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/pygame/__init__.py:${PORTSDIR}/devel/py-game
+
+post-install:
+ @${INSTALL} -d ${PREFIX}/share/applications
+ @cd ${WRKSRC} && ${CP} mnemosyne.desktop ${PREFIX}/share/applications/
+ @cd ${WRKSRC}/pixmaps && ${CP} mnemosyne.png ${PREFIX}/share/pixmaps/
+
+.include <bsd.port.mk>