aboutsummaryrefslogtreecommitdiff
path: root/games/py-poker-eval
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2006-12-14 16:00:46 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2006-12-14 16:00:46 +0000
commit01e53b475b04901e495f43ab09d0b9c8ab001722 (patch)
tree5b1a89248747a191e7400945c7285d6c0a578a8f /games/py-poker-eval
parent840ee4a79ce45d127aa1c072fe03054c30467ed9 (diff)
downloadports-01e53b475b04901e495f43ab09d0b9c8ab001722.tar.gz
ports-01e53b475b04901e495f43ab09d0b9c8ab001722.zip
Notes
Diffstat (limited to 'games/py-poker-eval')
-rw-r--r--games/py-poker-eval/Makefile33
-rw-r--r--games/py-poker-eval/distinfo3
-rw-r--r--games/py-poker-eval/files/patch-config-ltmain.sh15
-rw-r--r--games/py-poker-eval/pkg-descr8
-rw-r--r--games/py-poker-eval/pkg-plist7
5 files changed, 66 insertions, 0 deletions
diff --git a/games/py-poker-eval/Makefile b/games/py-poker-eval/Makefile
new file mode 100644
index 000000000000..03264a96b405
--- /dev/null
+++ b/games/py-poker-eval/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# Ports collection Makefile for: py-poker-eval
+# Date created: Dec 14, 2006
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= poker-eval
+PORTVERSION= 0.133
+CATEGORIES= games python
+MASTER_SITES= http://download.gna.org/pokersource/sources/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= py${PORTNAME}-${PORTVERSION:E}.0
+
+MAINTAINER= ijliao@FreeBSD.org
+COMMENT= Python adaptor for the poker-eval toolkit
+
+LIB_DEPENDS= poker-eval.1:${PORTSDIR}/games/poker-eval
+
+USE_GNOME= gnometarget pkgconfig
+USE_PYTHON= 2.3+
+GNU_CONFIGURE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|{libdir}/pkgconfig|(prefix)/libdata/pkgconfig|g' \
+ ${WRKSRC}/Makefile.in
+
+test:
+ @cd ${WRKSRC} && ${MAKE} check
+
+.include <bsd.port.mk>
diff --git a/games/py-poker-eval/distinfo b/games/py-poker-eval/distinfo
new file mode 100644
index 000000000000..089ebb6c2812
--- /dev/null
+++ b/games/py-poker-eval/distinfo
@@ -0,0 +1,3 @@
+MD5 (pypoker-eval-133.0.tar.gz) = 221ba23f829d41206b2f7181608c01a5
+SHA256 (pypoker-eval-133.0.tar.gz) = 2d84848deffe5d37353a70a6577aaf2d00008cce313d774cef65378bf29160c5
+SIZE (pypoker-eval-133.0.tar.gz) = 342305
diff --git a/games/py-poker-eval/files/patch-config-ltmain.sh b/games/py-poker-eval/files/patch-config-ltmain.sh
new file mode 100644
index 000000000000..b0aac2ffa71c
--- /dev/null
+++ b/games/py-poker-eval/files/patch-config-ltmain.sh
@@ -0,0 +1,15 @@
+--- config/ltmain.sh.orig Thu Dec 14 22:00:03 2006
++++ config/ltmain.sh Thu Dec 14 22:00:20 2006
+@@ -6003,10 +6003,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false ; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/games/py-poker-eval/pkg-descr b/games/py-poker-eval/pkg-descr
new file mode 100644
index 000000000000..01129de47211
--- /dev/null
+++ b/games/py-poker-eval/pkg-descr
@@ -0,0 +1,8 @@
+This package is python adaptor for the poker-eval toolkit for writing
+programs which simulate or analyze poker games as found at
+http://gna.org/projects/pokersource/. The python interface is
+somewhat simpler than the C API of poker-eval. It assumes that the
+caller is willing to have a higher level API and is not interested in
+a one to one mapping of the poker-eval API.
+
+WWW: http://www.pokersource.org/pypoker-eval.php
diff --git a/games/py-poker-eval/pkg-plist b/games/py-poker-eval/pkg-plist
new file mode 100644
index 000000000000..872f092b4191
--- /dev/null
+++ b/games/py-poker-eval/pkg-plist
@@ -0,0 +1,7 @@
+%%PYTHON_SITELIBDIR%%/_pokereval_2_5.a
+%%PYTHON_SITELIBDIR%%/_pokereval_2_5.so
+%%PYTHON_SITELIBDIR%%/_pokereval_2_5.so.1
+%%PYTHON_SITELIBDIR%%/pokereval.py
+%%PYTHON_SITELIBDIR%%/pokereval.pyc
+%%PYTHON_SITELIBDIR%%/pokereval.pyo
+libdata/pkgconfig/pypoker-eval.pc