aboutsummaryrefslogtreecommitdiff
path: root/games/py-pychess
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2008-07-09 12:28:54 +0000
committerNicola Vitale <nivit@FreeBSD.org>2008-07-09 12:28:54 +0000
commitd0287ad5882ea9cd5e4c1939748a09c60d06cff4 (patch)
treea76a73f84765c009de3454b82e68ec23adbe4d03 /games/py-pychess
parent3aaf42683776e00435fdb2108e26a26fdda7a396 (diff)
downloadports-d0287ad5882ea9cd5e4c1939748a09c60d06cff4.tar.gz
ports-d0287ad5882ea9cd5e4c1939748a09c60d06cff4.zip
Notes
Diffstat (limited to 'games/py-pychess')
-rw-r--r--games/py-pychess/Makefile12
-rw-r--r--games/py-pychess/distinfo6
-rw-r--r--games/py-pychess/files/patch-setup.py2
-rw-r--r--games/py-pychess/pkg-plist81
4 files changed, 53 insertions, 48 deletions
diff --git a/games/py-pychess/Makefile b/games/py-pychess/Makefile
index 17707498d4bd..a7113fe19f6a 100644
--- a/games/py-pychess/Makefile
+++ b/games/py-pychess/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= pychess
-DISTVERSION= 0.8beta4
+PORTVERSION= 0.8.2
#PORTREVISION= 0
#PORTEPOCH= 0
-PORTREVISION= 1
CATEGORIES= games
-MASTER_SITES= http://nivi.interfree.it/distfiles/${PORTNAME}/
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE} \
+ http://nivi.interfree.it/distfiles/${PORTNAME}/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= nivit@FreeBSD.org
@@ -35,15 +35,17 @@ USE_GETTEXT= yes
USE_PYTHON= yes
USE_PYDISTUTILS= yes
-REINPLACE_ARGS= -i.bak -e 's,%%PREFIX%%,${PREFIX},' -e 's,share/games/pychess,${DATADIR},'
+REINPLACE_ARGS= -i.bak -e 's,%%PREFIX%%,${PREFIX},' -e 's,share/games/pychess,${DATADIR},' -e '1s,/usr/bin/env python,&${PYTHON_VER},'
.if !defined(NO_INSTALL_MANPAGES)
MAN1= ${PORTNAME}.1
MANCOMPRESSED= yes
+.else
+MAKE_ENV+= NO_INSTALL_MANPAGES=${NO_INSTALL_MANPAGES}
.endif
post-patch:
- cd ${WRKSRC} && ${REINPLACE_CMD} ${PORTNAME} ${PYSETUP}
+ cd ${WRKSRC} && ${REINPLACE_CMD} ${PORTNAME} ${PYSETUP} lib/pychess/Utils/Move.py
.include <bsd.port.pre.mk>
diff --git a/games/py-pychess/distinfo b/games/py-pychess/distinfo
index 176fd73d4b6e..5e0ffe0cd945 100644
--- a/games/py-pychess/distinfo
+++ b/games/py-pychess/distinfo
@@ -1,3 +1,3 @@
-MD5 (pychess-0.8beta4.tar.gz) = f88e71edbe19b8199c4a910203fe819c
-SHA256 (pychess-0.8beta4.tar.gz) = 4195257b9a44700405af601f919e99b3a559745d6f4c4f47a3172a1931392ba1
-SIZE (pychess-0.8beta4.tar.gz) = 1083040
+MD5 (pychess-0.8.2.tar.gz) = 3faf48b9704d29bc7fc508c9e63b7d1a
+SHA256 (pychess-0.8.2.tar.gz) = e88a88dc59dbf34939414c63c380894ca793b7cd7077c56eb1bb872fad6bad3f
+SIZE (pychess-0.8.2.tar.gz) = 1113567
diff --git a/games/py-pychess/files/patch-setup.py b/games/py-pychess/files/patch-setup.py
index b03cda5f41b0..503476b0cec1 100644
--- a/games/py-pychess/files/patch-setup.py
+++ b/games/py-pychess/files/patch-setup.py
@@ -5,7 +5,7 @@
# Manpages
-DATA_FILES += [('share/man/man1', ['manpages/pychess.1.gz'])]
-+if not os.getenv('NO_INSTALL_MANPAGES'):
++if not os.environ.has_key('NO_INSTALL_MANPAGES'):
+ DATA_FILES += [('man/man1', ['manpages/pychess.1.gz'])]
# Language
diff --git a/games/py-pychess/pkg-plist b/games/py-pychess/pkg-plist
index 8219daeb71e0..e2af61723529 100644
--- a/games/py-pychess/pkg-plist
+++ b/games/py-pychess/pkg-plist
@@ -286,6 +286,37 @@ bin/pychess
%%PYTHON_SITELIBDIR%%/pychess/widgets/tipOfTheDay.pyc
%%PYTHON_SITELIBDIR%%/pychess/widgets/tipOfTheDay.pyo
share/applications/pychess.desktop
+share/gtksourceview-1.0/language-specs/pgn.lang
+share/icons/hicolor/24x24/apps/pychess.png
+share/icons/hicolor/scalable/apps/pychess.svg
+share/locale/az/LC_MESSAGES/pychess.mo
+share/locale/bg/LC_MESSAGES/pychess.mo
+share/locale/ca/LC_MESSAGES/pychess.mo
+share/locale/cs/LC_MESSAGES/pychess.mo
+share/locale/da/LC_MESSAGES/pychess.mo
+share/locale/de/LC_MESSAGES/pychess.mo
+share/locale/el/LC_MESSAGES/pychess.mo
+share/locale/es/LC_MESSAGES/pychess.mo
+share/locale/et/LC_MESSAGES/pychess.mo
+share/locale/eu/LC_MESSAGES/pychess.mo
+share/locale/fr/LC_MESSAGES/pychess.mo
+share/locale/gl/LC_MESSAGES/pychess.mo
+share/locale/he/LC_MESSAGES/pychess.mo
+share/locale/hi/LC_MESSAGES/pychess.mo
+share/locale/hr/LC_MESSAGES/pychess.mo
+share/locale/hu/LC_MESSAGES/pychess.mo
+share/locale/it/LC_MESSAGES/pychess.mo
+share/locale/ja/LC_MESSAGES/pychess.mo
+share/locale/nl/LC_MESSAGES/pychess.mo
+share/locale/pl/LC_MESSAGES/pychess.mo
+share/locale/pt/LC_MESSAGES/pychess.mo
+share/locale/pt_BR/LC_MESSAGES/pychess.mo
+share/locale/ro/LC_MESSAGES/pychess.mo
+share/locale/ru/LC_MESSAGES/pychess.mo
+share/locale/sv/LC_MESSAGES/pychess.mo
+share/locale/tr/LC_MESSAGES/pychess.mo
+share/locale/wa/LC_MESSAGES/pychess.mo
+share/pixmaps/pychess.svg
%%DATADIR%%/AUTHORS
%%DATADIR%%/LICENSE
%%DATADIR%%/README
@@ -539,45 +570,17 @@ share/applications/pychess.desktop
%%DATADIR%%/sidepanel/history.glade
%%DATADIR%%/sidepanel/historyPanel.py
%%DATADIR%%/sidepanel/scorePanel.py
-share/gtksourceview-1.0/language-specs/pgn.lang
-share/icons/hicolor/24x24/apps/pychess.png
-share/icons/hicolor/scalable/apps/pychess.svg
-share/locale/az/LC_MESSAGES/pychess.mo
-share/locale/ca/LC_MESSAGES/pychess.mo
-share/locale/cs/LC_MESSAGES/pychess.mo
-share/locale/da/LC_MESSAGES/pychess.mo
-share/locale/de/LC_MESSAGES/pychess.mo
-share/locale/el/LC_MESSAGES/pychess.mo
-share/locale/es/LC_MESSAGES/pychess.mo
-share/locale/et/LC_MESSAGES/pychess.mo
-share/locale/fr/LC_MESSAGES/pychess.mo
-share/locale/gl/LC_MESSAGES/pychess.mo
-share/locale/he/LC_MESSAGES/pychess.mo
-share/locale/hi/LC_MESSAGES/pychess.mo
-share/locale/hu/LC_MESSAGES/pychess.mo
-share/locale/it/LC_MESSAGES/pychess.mo
-share/locale/ja/LC_MESSAGES/pychess.mo
-share/locale/nl/LC_MESSAGES/pychess.mo
-share/locale/pl/LC_MESSAGES/pychess.mo
-share/locale/pt/LC_MESSAGES/pychess.mo
-share/locale/pt_BR/LC_MESSAGES/pychess.mo
-share/locale/ro/LC_MESSAGES/pychess.mo
-share/locale/ru/LC_MESSAGES/pychess.mo
-share/locale/sv/LC_MESSAGES/pychess.mo
-share/locale/tr/LC_MESSAGES/pychess.mo
-share/locale/wa/LC_MESSAGES/pychess.mo
-share/pixmaps/pychess.svg
-@dirrm %%PYTHON_SITELIBDIR%%/pychess/Players
-@dirrm %%PYTHON_SITELIBDIR%%/pychess/Savers
-@dirrm %%PYTHON_SITELIBDIR%%/pychess/System
-@dirrm %%PYTHON_SITELIBDIR%%/pychess/Utils/lutils
-@dirrm %%PYTHON_SITELIBDIR%%/pychess/Utils
-@dirrm %%PYTHON_SITELIBDIR%%/pychess/gfx
+@dirrm %%DATADIR%%/sidepanel
+@dirrm %%DATADIR%%/glade
+@dirrm %%DATADIR%%/flags
+@dirrm %%DATADIR%%
+@dirrm %%PYTHON_SITELIBDIR%%/pychess/widgets
@dirrm %%PYTHON_SITELIBDIR%%/pychess/ic/managers
@dirrm %%PYTHON_SITELIBDIR%%/pychess/ic
-@dirrm %%PYTHON_SITELIBDIR%%/pychess/widgets
+@dirrm %%PYTHON_SITELIBDIR%%/pychess/gfx
+@dirrm %%PYTHON_SITELIBDIR%%/pychess/Utils/lutils
+@dirrm %%PYTHON_SITELIBDIR%%/pychess/Utils
+@dirrm %%PYTHON_SITELIBDIR%%/pychess/System
+@dirrm %%PYTHON_SITELIBDIR%%/pychess/Savers
+@dirrm %%PYTHON_SITELIBDIR%%/pychess/Players
@dirrm %%PYTHON_SITELIBDIR%%/pychess
-@dirrm %%DATADIR%%/flags
-@dirrm %%DATADIR%%/glade
-@dirrm %%DATADIR%%/sidepanel
-@dirrm %%DATADIR%%