aboutsummaryrefslogtreecommitdiff
path: root/games/py-sgfsummary/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-01-27 12:29:47 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-01-27 12:29:47 +0000
commit8866de653ff66e2576081d9668356aaf0b3f75da (patch)
treeb7599f429327a1d057d6871f951d34ab21e4beba /games/py-sgfsummary/Makefile
parent1cb42a41f7552d22eaf7751a488229b697f7c6f2 (diff)
Sgfsummary reads multiple SGF (Smart Game Format) files, specifically
those recording Go/WeiQi/Baduk games, and summarizes their game information to standard output. It is a part of the Go Tools Project. PR: ports/61419 Submitted by: Leland Wang <llwang@infor.org>
Notes
Notes: svn path=/head/; revision=99264
Diffstat (limited to 'games/py-sgfsummary/Makefile')
-rw-r--r--games/py-sgfsummary/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/games/py-sgfsummary/Makefile b/games/py-sgfsummary/Makefile
new file mode 100644
index 000000000000..1445c911fc34
--- /dev/null
+++ b/games/py-sgfsummary/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: py-sgfsummary
+# Date created: January 16, 2004
+# Whom: Leland Wang <llwang@infor.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sgfsummary
+PORTVERSION= 1.0
+CATEGORIES= games python
+MASTER_SITES= http://gotools.sourceforge.net/sgfsummary/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= llwang@infor.org
+COMMENT= SGF Summarizer
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/sgflib.py:${PORTSDIR}/games/py-sgflib
+
+USE_PYTHON= yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/sgfsummary.py ${PREFIX}/bin
+
+.include <bsd.port.mk>