aboutsummaryrefslogtreecommitdiff
path: root/games/pydance
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-02-26 15:09:25 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-02-26 15:09:25 +0000
commit66a22a2748dbba4ec9e6194d5b2a2dcdda7e111a (patch)
tree87052891d8aed856f0f61bfadf4d1dd6fc828d97 /games/pydance
parenta3b8d42beedd38caf919241c41b5030d5452c60a (diff)
downloadports-66a22a2748dbba4ec9e6194d5b2a2dcdda7e111a.tar.gz
ports-66a22a2748dbba4ec9e6194d5b2a2dcdda7e111a.zip
Notes
Diffstat (limited to 'games/pydance')
-rw-r--r--games/pydance/Makefile3
-rw-r--r--games/pydance/distinfo15
-rw-r--r--games/pydance/files/patch-constants.py11
-rw-r--r--games/pydance/files/patch-dance.py20
-rw-r--r--games/pydance/pkg-message5
-rw-r--r--games/pydance/pkg-plist61
6 files changed, 59 insertions, 56 deletions
diff --git a/games/pydance/Makefile b/games/pydance/Makefile
index 1d9f6ce18b1c..98a3bd976656 100644
--- a/games/pydance/Makefile
+++ b/games/pydance/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= pydance
-PORTVERSION= 0.8.4
-PORTREVISION= 2
+PORTVERSION= 0.9.1
CATEGORIES= games
MASTER_SITES= http://www.icculus.org/pyddr/
DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz ${SONGS}
diff --git a/games/pydance/distinfo b/games/pydance/distinfo
index f82ded4f7aef..ef1ee5159f04 100644
--- a/games/pydance/distinfo
+++ b/games/pydance/distinfo
@@ -1,13 +1,26 @@
-MD5 (pydance/pydance-0.8.4.tar.gz) = 721832828020eb66ff10347b42fb3b02
+MD5 (pydance/pydance-0.9.1.tar.gz) = 71372469c6d66bce18a74a539b4fddbe
+SIZE (pydance/pydance-0.9.1.tar.gz) = 5601735
MD5 (pydance/forkbomb.ogg) = 0ca7527a0b792fe0b597322d69e675d7
+SIZE (pydance/forkbomb.ogg) = 1418973
MD5 (pydance/forkbomb.dance) = e62aab2b2d39adf172a74d229acedb23
+SIZE (pydance/forkbomb.dance) = 2127
MD5 (pydance/forkbomb-bg.jpg) = f440c9820c5a3604f5f93be64bef7e9f
+SIZE (pydance/forkbomb-bg.jpg) = 49679
MD5 (pydance/forkbomb-banner.png) = 20d27c6cd45f2bbd4b12d8a1f211d501
+SIZE (pydance/forkbomb-banner.png) = 6898
MD5 (pydance/6jan.ogg) = 1d854704c96c9af57517390b37765627
+SIZE (pydance/6jan.ogg) = 822205
MD5 (pydance/6jan.dance) = 4bdd8d369fd5aef577a614316c0de61a
+SIZE (pydance/6jan.dance) = 2687
MD5 (pydance/6jan-bg.jpg) = a290e913ece03317a46ff77cb7986a1d
+SIZE (pydance/6jan-bg.jpg) = 91526
MD5 (pydance/6jan-banner.png) = 8293cc45536dcad3e6e0ccf15974527f
+SIZE (pydance/6jan-banner.png) = 2004
MD5 (pydance/synrg.ogg) = 66df8b9049aad5bb3a1689a7943e9108
+SIZE (pydance/synrg.ogg) = 1236743
MD5 (pydance/synrg.dance) = 70156d4215aa26ad2a823a36a12a7627
+SIZE (pydance/synrg.dance) = 5282
MD5 (pydance/synrg-bg.png) = 89baa4d0af462938256222269412df33
+SIZE (pydance/synrg-bg.png) = 170240
MD5 (pydance/pydance-cdtitle.png) = 11196f938f06fa7b82ef064c921bd895
+SIZE (pydance/pydance-cdtitle.png) = 2593
diff --git a/games/pydance/files/patch-constants.py b/games/pydance/files/patch-constants.py
new file mode 100644
index 000000000000..8f3e23a5aafd
--- /dev/null
+++ b/games/pydance/files/patch-constants.py
@@ -0,0 +1,11 @@
+--- constants.py.orig Wed Feb 25 20:18:19 2004
++++ constants.py Wed Feb 25 23:21:46 2004
+@@ -13,7 +13,7 @@
+ from pygame.locals import *
+
+ VERSION = "0.9.1"
+-locale.setlocale(locale.LC_ALL, '')
++locale.setlocale(locale.LC_ALL, 'C')
+
+ # Detect the name of the OS - Mac OS X is not really UNIX.
+ osname = None
diff --git a/games/pydance/files/patch-dance.py b/games/pydance/files/patch-dance.py
index 8eecffc49dcb..bb7b1d2cb474 100644
--- a/games/pydance/files/patch-dance.py
+++ b/games/pydance/files/patch-dance.py
@@ -1,16 +1,14 @@
---- /tmp/pydance/share/games/pydance/dance.py Sat Oct 25 18:50:56 2003
-+++ dance.py Sun Oct 26 18:44:40 2003
-@@ -11,6 +11,9 @@
-
- import random, sys, os, copy
+--- dance.py.orig Sat Jan 31 23:12:01 2004
++++ dance.py Sun Feb 8 16:35:46 2004
+@@ -22,6 +22,7 @@
+ import records
+ import os
+import time
-+# see comment about FreeBSD below. A better solution would be appreciated.
-+
- class BGmovie(pygame.sprite.Sprite):
- def __init__ (self, filename):
- pygame.sprite.Sprite.__init__(self)
-@@ -314,6 +317,10 @@
+
+ # A simple movie-playing sprite. It can only do MPEG1 though.
+ class BGMovie(pygame.sprite.Sprite):
+@@ -331,6 +332,10 @@
break
if songFailed:
song.kill()
diff --git a/games/pydance/pkg-message b/games/pydance/pkg-message
index ca087a43d7fb..8cdf7092445a 100644
--- a/games/pydance/pkg-message
+++ b/games/pydance/pkg-message
@@ -7,7 +7,8 @@ NB: A sample configuration file has been installed to %%PREFIX%%/etc as
to suit the requirements of a particular site (for example in order
to add song directories).
-If you get performance problems, install devel/py-psyco, the "Python
-Specializing Compiler". It should make pydance a lot faster.
+For some reason, MP3 playback seems to be broken here or in
+devel/py-game. Please inform me if you get it working. OggVorbis
+files however should work fine.
--------------------------------------------------------------------------
diff --git a/games/pydance/pkg-plist b/games/pydance/pkg-plist
index 885e058dc5b0..4bfda8c3f022 100644
--- a/games/pydance/pkg-plist
+++ b/games/pydance/pkg-plist
@@ -1,3 +1,4 @@
+@unexec rm -f %%PREFIX%%/share/games/pydance/*.pyc
bin/findbpm
bin/pydance
etc/pydance.cfg.sample
@@ -55,8 +56,7 @@ share/games/pydance/themes/gfx/32x32/default/arr_s_c_4.png
share/games/pydance/themes/gfx/32x32/default/arr_s_k_4.png
share/games/pydance/themes/gfx/32x32/default/arr_s_l_4.png
share/games/pydance/themes/gfx/32x32/default/is-theme
-share/games/pydance/themes/gfx/32x32/default/lifebar-empty.png
-share/games/pydance/themes/gfx/32x32/default/lifebar-full.png
+share/games/pydance/themes/gfx/32x32/default/lifebar.png
share/games/pydance/themes/gfx/32x32/default/oni-bar.png
share/games/pydance/themes/gfx/32x32/default/oni-empty.png
share/games/pydance/themes/gfx/32x32/dmxesque/arr_c_k_0.png
@@ -70,8 +70,7 @@ share/games/pydance/themes/gfx/32x32/dmxesque/arr_s_k_4.png
share/games/pydance/themes/gfx/32x32/dmxesque/arr_s_l_4.png
share/games/pydance/themes/gfx/32x32/dmxesque/arr_s_z_4.png
share/games/pydance/themes/gfx/32x32/dmxesque/is-theme
-share/games/pydance/themes/gfx/32x32/dmxesque/lifebar-empty.png
-share/games/pydance/themes/gfx/32x32/dmxesque/lifebar-full.png
+share/games/pydance/themes/gfx/32x32/dmxesque/lifebar.png
share/games/pydance/themes/gfx/32x32/dmxesque/oni-bar.png
share/games/pydance/themes/gfx/32x32/dmxesque/oni-empty.png
share/games/pydance/themes/gfx/32x32/ez2/arr_c_d_0.png
@@ -96,8 +95,7 @@ share/games/pydance/themes/gfx/32x32/ez2/arr_s_r_4.png
share/games/pydance/themes/gfx/32x32/ez2/arr_s_w_4.png
share/games/pydance/themes/gfx/32x32/ez2/arr_s_z_4.png
share/games/pydance/themes/gfx/32x32/ez2/is-theme
-share/games/pydance/themes/gfx/32x32/ez2/lifebar-empty.png
-share/games/pydance/themes/gfx/32x32/ez2/lifebar-full.png
+share/games/pydance/themes/gfx/32x32/ez2/lifebar.png
share/games/pydance/themes/gfx/32x32/ez2/oni-bar.png
share/games/pydance/themes/gfx/32x32/ez2/oni-empty.png
share/games/pydance/themes/gfx/32x32/ddresque.zip
@@ -117,8 +115,7 @@ share/games/pydance/themes/gfx/48x48/default/arr_s_c_4.png
share/games/pydance/themes/gfx/48x48/default/arr_s_k_4.png
share/games/pydance/themes/gfx/48x48/default/arr_s_l_4.png
share/games/pydance/themes/gfx/48x48/default/is-theme
-share/games/pydance/themes/gfx/48x48/default/lifebar-empty.png
-share/games/pydance/themes/gfx/48x48/default/lifebar-full.png
+share/games/pydance/themes/gfx/48x48/default/lifebar.png
share/games/pydance/themes/gfx/48x48/default/oni-bar.png
share/games/pydance/themes/gfx/48x48/default/oni-empty.png
share/games/pydance/themes/gfx/48x48/ddresque.zip
@@ -133,8 +130,7 @@ share/games/pydance/themes/gfx/56x56/default/arr_n_k_0.png
share/games/pydance/themes/gfx/56x56/default/arr_s_c_4.png
share/games/pydance/themes/gfx/56x56/default/arr_s_k_4.png
share/games/pydance/themes/gfx/56x56/default/is-theme
-share/games/pydance/themes/gfx/56x56/default/lifebar-empty.png
-share/games/pydance/themes/gfx/56x56/default/lifebar-full.png
+share/games/pydance/themes/gfx/56x56/default/lifebar.png
share/games/pydance/themes/gfx/56x56/default/oni-bar.png
share/games/pydance/themes/gfx/56x56/default/oni-empty.png
share/games/pydance/themes/gfx/56x56/ez2/arr_c_d_0.png
@@ -159,8 +155,7 @@ share/games/pydance/themes/gfx/56x56/ez2/arr_s_r_4.png
share/games/pydance/themes/gfx/56x56/ez2/arr_s_w_4.png
share/games/pydance/themes/gfx/56x56/ez2/arr_s_z_4.png
share/games/pydance/themes/gfx/56x56/ez2/is-theme
-share/games/pydance/themes/gfx/56x56/ez2/lifebar-empty.png
-share/games/pydance/themes/gfx/56x56/ez2/lifebar-full.png
+share/games/pydance/themes/gfx/56x56/ez2/lifebar.png
share/games/pydance/themes/gfx/56x56/ez2/oni-bar.png
share/games/pydance/themes/gfx/56x56/ez2/oni-empty.png
share/games/pydance/themes/gfx/56x56/pumpesque.zip
@@ -183,8 +178,7 @@ share/games/pydance/themes/gfx/64x64/default/arr_s_l_4.png
share/games/pydance/themes/gfx/64x64/default/arr_s_r_4.png
share/games/pydance/themes/gfx/64x64/default/arr_s_u_4.png
share/games/pydance/themes/gfx/64x64/default/is-theme
-share/games/pydance/themes/gfx/64x64/default/lifebar-empty.png
-share/games/pydance/themes/gfx/64x64/default/lifebar-full.png
+share/games/pydance/themes/gfx/64x64/default/lifebar.png
share/games/pydance/themes/gfx/64x64/default/oni-bar.png
share/games/pydance/themes/gfx/64x64/default/oni-empty.png
share/games/pydance/themes/gfx/64x64/oldschool/arr_c_d_0.png
@@ -260,8 +254,7 @@ share/games/pydance/themes/gfx/64x64/oldschool/arr_s_u_5.png
share/games/pydance/themes/gfx/64x64/oldschool/arr_s_u_6.png
share/games/pydance/themes/gfx/64x64/oldschool/arr_s_u_7.png
share/games/pydance/themes/gfx/64x64/oldschool/is-theme
-share/games/pydance/themes/gfx/64x64/oldschool/lifebar-empty.png
-share/games/pydance/themes/gfx/64x64/oldschool/lifebar-full.png
+share/games/pydance/themes/gfx/64x64/oldschool/lifebar.png
share/games/pydance/themes/gfx/64x64/oldschool/oni-bar.png
share/games/pydance/themes/gfx/64x64/oldschool/oni-empty.png
share/games/pydance/themes/gfx/64x64/bryan.zip
@@ -275,11 +268,20 @@ share/games/pydance/images/endless-bg.png
share/games/pydance/images/error-bg.png
share/games/pydance/images/gameselect-bg.png
share/games/pydance/images/go.png
+share/games/pydance/images/grade-bg.png
share/games/pydance/images/indicator.png
share/games/pydance/images/menu-bg.png
share/games/pydance/images/newss-bg.png
share/games/pydance/images/no-banner.png
share/games/pydance/images/option-bg.png
+share/games/pydance/images/rating-a.png
+share/games/pydance/images/rating-aa.png
+share/games/pydance/images/rating-aaa.png
+share/games/pydance/images/rating-b.png
+share/games/pydance/images/rating-c.png
+share/games/pydance/images/rating-d.png
+share/games/pydance/images/rating-ee.png
+share/games/pydance/images/rating-f.png
share/games/pydance/images/ready.png
share/games/pydance/images/select-3p.png
share/games/pydance/images/select-4p.png
@@ -287,20 +289,13 @@ share/games/pydance/images/select-5p.png
share/games/pydance/images/select-6p.png
share/games/pydance/images/select-8p.png
share/games/pydance/images/select-9p.png
-share/games/pydance/images/select-base.png
-share/games/pydance/images/select-couple.png
share/games/pydance/images/select-dmx.png
-share/games/pydance/images/select-double.png
share/games/pydance/images/select-endless.png
share/games/pydance/images/select-ez2.png
share/games/pydance/images/select-ez2real.png
share/games/pydance/images/select-nonstop.png
-share/games/pydance/images/select-normal.png
share/games/pydance/images/select-panel.png
share/games/pydance/images/select-para.png
-share/games/pydance/images/select-single.png
-share/games/pydance/images/select-testing.png
-share/games/pydance/images/select-versus.png
share/games/pydance/sound/assist-d.ogg
share/games/pydance/sound/assist-l.ogg
share/games/pydance/sound/assist-r.ogg
@@ -322,38 +317,24 @@ share/games/pydance/sound/move.ogg
%%SONGS%%share/games/pydance/songs/synrg.dance
%%SONGS%%share/games/pydance/songs/synrg-bg.png
%%SONGS%%share/games/pydance/songs/pydance.png
+@dirrm share/games/pydance/sound
+@dirrm share/games/pydance/images
@dirrm share/games/pydance/themes/gfx/64x64/oldschool
-@dirrm share/games/pydance/themes/gfx/64x64/animated-ddr
-@dirrm share/games/pydance/themes/gfx/64x64/blue
-@dirrm share/games/pydance/themes/gfx/64x64/bryan
@dirrm share/games/pydance/themes/gfx/64x64/default
@dirrm share/games/pydance/themes/gfx/64x64
-@dirrm share/games/pydance/themes/gfx/56x56/pumpesque
@dirrm share/games/pydance/themes/gfx/56x56/ez2
@dirrm share/games/pydance/themes/gfx/56x56/default
@dirrm share/games/pydance/themes/gfx/56x56
@dirrm share/games/pydance/themes/gfx/48x48/default
-@dirrm share/games/pydance/themes/gfx/48x48/ddresque
@dirrm share/games/pydance/themes/gfx/48x48
+@dirrm share/games/pydance/themes/gfx/32x32/ez2
@dirrm share/games/pydance/themes/gfx/32x32/dmxesque
@dirrm share/games/pydance/themes/gfx/32x32/default
-@dirrm share/games/pydance/themes/gfx/32x32/ddresque
-@dirrm share/games/pydance/themes/gfx/32x32/ez2
@dirrm share/games/pydance/themes/gfx/32x32
-@dirrm share/games/pydance/themes/gfx/classic/56x56
-@dirrm share/games/pydance/themes/gfx/classic/64x64
-@dirrm share/games/pydance/themes/gfx/classic/ppp
-@dirrm share/games/pydance/themes/gfx/classic
-@dirrm share/games/pydance/themes/gfx/blue
-@dirrm share/games/pydance/themes/gfx/bryan
-@dirrm share/games/pydance/themes/gfx/oldschool
@dirrm share/games/pydance/themes/gfx
-@dirrm share/games/pydance/themes/dj/mrt
@dirrm share/games/pydance/themes/dj/none
@dirrm share/games/pydance/themes/dj
@dirrm share/games/pydance/themes
-@dirrm share/games/pydance/images
-@dirrm share/games/pydance/sound
@dirrm share/games/pydance/songs
@dirrm share/games/pydance
@unexec rmdir %D/share/games 2>/dev/null || true