aboutsummaryrefslogtreecommitdiff
path: root/games/pysol-cardsets/Makefile
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2000-09-22 12:25:44 +0000
committerThomas Gellekum <tg@FreeBSD.org>2000-09-22 12:25:44 +0000
commita4bf123afec3fbe5349ec996dedd2a5fe89f4eff (patch)
tree091e81c6dedc8dde191d7b72ba4f147472c5b6dd /games/pysol-cardsets/Makefile
parent48b84bde850fbf2b823814415808d1ca61ac92be (diff)
Notes
Diffstat (limited to 'games/pysol-cardsets/Makefile')
-rw-r--r--games/pysol-cardsets/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/games/pysol-cardsets/Makefile b/games/pysol-cardsets/Makefile
new file mode 100644
index 000000000000..72a39355322c
--- /dev/null
+++ b/games/pysol-cardsets/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: PySol Cardsets
+# Date created: 18 Sep 2000
+# Whom: Thomas Gellekum <tg@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pysol-cardsets
+PORTVERSION= 4.40
+CATEGORIES= games
+MASTER_SITES= http://wildsau.idv.uni-linz.ac.at/mfx/download/pysol/
+MASTER_SITE_SUBDIR= pysol
+
+MAINTAINER= ports@FreeBSD.org
+
+RUN_DEPENDS= pysol:${PORTSDIR}/games/pysol
+
+NO_BUILD= yes
+
+CARDSETS= 1567 1750 1815 1880-delarue 1880-tarot 1890-grimaud aisleriot \
+ briscola culemann-1850a culemann-1850b dashavatara-ganjifa \
+ denizens dondorf-whist-a dondorf-whist-b fantasy \
+ gdkcard-bonded get-a-round gortz-1841 gortz-1842 gpl hamburg-a \
+ hamburg-b hegewald-1770 houbigant hungarian-tarokk jacoby \
+ joan-darc kabale kintengu-small liege little-sorcerer \
+ maritimes melange migeon-costume mughal-ganjifa naylor \
+ nickel-ante ovale-salon oxymoron oxymoron-small penguins \
+ prince-charles rangoon-d rangoon-e rangoon-r revolution-1 \
+ revolution-2 revolution-3 rivers-banks spaced spider \
+ spin-dist tensho tksol transformation traugott-1800 \
+ traugott-1834 ukiyoe-fuji ukiyoe-sharaku vienna-2k-small \
+ vienna-tarock wilhelmtell xpat2 xpat2-nox-large \
+ xpat2-nox-medium xpat2-nox-small xpat2-nox-tiny xskat-french \
+ xskat-french-large xskat-german
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/pysol
+.for set in ${CARDSETS}
+ (cd ${WRKSRC}/data; tar cf - cardset-${set}) | \
+ (cd ${PREFIX}/share/pysol; tar xf -)
+.endfor
+
+.include <bsd.port.mk>