aboutsummaryrefslogtreecommitdiff
path: root/games/pysol/Makefile
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2001-05-08 11:53:55 +0000
committerThomas Gellekum <tg@FreeBSD.org>2001-05-08 11:53:55 +0000
commite9e51c195b6809f6ec5d0b4c450e609ac087cc9c (patch)
treef2819161d4bab76054335a9af129722c67d32318 /games/pysol/Makefile
parent56e64a303bb31be47ff04b08eb7dcfcdce9e80b9 (diff)
downloadports-e9e51c195b6809f6ec5d0b4c450e609ac087cc9c.tar.gz
ports-e9e51c195b6809f6ec5d0b4c450e609ac087cc9c.zip
Notes
Diffstat (limited to 'games/pysol/Makefile')
-rw-r--r--games/pysol/Makefile28
1 files changed, 9 insertions, 19 deletions
diff --git a/games/pysol/Makefile b/games/pysol/Makefile
index 38dc086101e3..50e0d042e2d8 100644
--- a/games/pysol/Makefile
+++ b/games/pysol/Makefile
@@ -6,39 +6,29 @@
#
PORTNAME= pysol
-PORTVERSION= 4.60
+PORTVERSION= 4.71
CATEGORIES= games
-MASTER_SITES= http://wildsau.idv.uni-linz.ac.at/mfx/download/pysol/ \
- ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= tg
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} pysol.py.bz2
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+MASTER_SITES= http://wildsau.idv.uni-linz.ac.at/mfx/download/pysol/
MAINTAINER= tg@FreeBSD.org
-BUILD_DEPENDS= bunzip2:${PORTSDIR}/archivers/bzip2
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
+USE_BZIP2= yes
USE_PYTHON= yes
-MAN6= pysol.6
-
-post-extract:
- ${LOCALBASE}/bin/bunzip2 -c ${DISTDIR}/pysol.py.bz2 \
- > ${WRKSRC}/pysol.py
+NO_BUILD= yes
-do-build:
- ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py -l ${WRKSRC}
+MAN6= pysol.6
do-install:
${SED} -e "s|@pkgdatadir@|${PREFIX}/share/pysol|" \
-e "s|^exec python|exec ${PYTHON_CMD}|" \
- < ${WRKSRC}/pysol > ${PREFIX}/bin/pysol
- ${CHMOD} +x ${PREFIX}/bin/pysol
+ < ${WRKSRC}/pysol > ${WRKDIR}/pysol
+ ${INSTALL_SCRIPT} ${WRKDIR}/pysol ${PREFIX}/bin/pysol
${INSTALL_DATA} ${WRKSRC}/pysol.6 ${PREFIX}/man/man6
@${MKDIR} ${PREFIX}/share/pysol
- (cd ${WRKSRC}/data; tar cf - *) | \
- (cd ${PREFIX}/share/pysol; tar xf -)
- ${INSTALL_DATA} ${WRKSRC}/pysol.pyc ${PREFIX}/share/pysol
+ (cd ${WRKSRC}/data; tar -cf - .) | \
+ (cd ${PREFIX}/share/pysol; tar --unlink -xf -)
.include <bsd.port.mk>