aboutsummaryrefslogtreecommitdiff
path: root/games/pysolfc/Makefile
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2009-03-14 17:20:35 +0000
committerMarcus von Appen <mva@FreeBSD.org>2009-03-14 17:20:35 +0000
commitad20054d1afecd67d78df2df4074c3ffe7397806 (patch)
tree27e8f99715c9db3c427b71844d388dec87158eff /games/pysolfc/Makefile
parentb834f4cfed01515a2c4d2e15d78115f19d67ecbd (diff)
Notes
Diffstat (limited to 'games/pysolfc/Makefile')
-rw-r--r--games/pysolfc/Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/games/pysolfc/Makefile b/games/pysolfc/Makefile
new file mode 100644
index 000000000000..68ee351cc134
--- /dev/null
+++ b/games/pysolfc/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: pysolfc
+# Date created: 2009-03-13
+# Whom: Marcus von Appen
+#
+# $FreeBSD$
+#
+
+PORTNAME= pysolfc
+PORTVERSION= 1.1
+CATEGORIES= games
+MASTER_SITES= SF/pysolfc
+DISTNAME= PySolFC-${PORTVERSION}
+
+MAINTAINER= mva@FreeBSD.org
+COMMENT= Solitaire game, written in Python and the sucessor of PySol
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
+
+USE_BZIP2= yes
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+PYDISTUTILS_PKGNAME= PySolFC
+
+DATADIR= ${PREFIX}/share/PySolFC
+WRKSRC= ${WRKDIR}/${DISTNAME}
+PORTDOCS= README
+
+OPTIONS= NLS "Native language support" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+PLIST_SUB+= NLS="@comment "
+.endif
+
+post-patch:
+ @${MV} ${WRKSRC}/pysol.py ${WRKSRC}/pysolfc
+ @${REINPLACE_CMD} -e 's|pysol.py|pysolfc|' ${WRKSRC}/setup.py
+.if defined(WITHOUT_NLS)
+ @${REINPLACE_CMD} -e "s|for l in ('ru', 'ru_RU')|for l in ()|" ${WRKSRC}/setup.py
+.endif
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${INSTALL} -d ${DOCSDIR}/
+ @cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
+.endif
+
+.include <bsd.port.post.mk>