aboutsummaryrefslogtreecommitdiff
path: root/games/pyspacewar/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2018-11-12 09:30:23 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2018-11-12 09:30:23 +0000
commit2f32b2b9a7f1ed5c8bbc1ea1dc3a7804e0494e8b (patch)
treef0479ae109efcd3c21a3fe6073c9df542a83fd42 /games/pyspacewar/Makefile
parent1ac8d84807116dfe0cf1dbc1fb5b79834cbd3b57 (diff)
downloadports-2f32b2b9a7f1ed5c8bbc1ea1dc3a7804e0494e8b.tar.gz
ports-2f32b2b9a7f1ed5c8bbc1ea1dc3a7804e0494e8b.zip
Notes
Diffstat (limited to 'games/pyspacewar/Makefile')
-rw-r--r--games/pyspacewar/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/games/pyspacewar/Makefile b/games/pyspacewar/Makefile
index 7533995b1d30..7364a3301634 100644
--- a/games/pyspacewar/Makefile
+++ b/games/pyspacewar/Makefile
@@ -10,7 +10,7 @@ DIST_SUBDIR= python
MAINTAINER= ports@FreeBSD.org
COMMENT= Game loosely based on the original Spacewar!
-LICENSE= GPLv2
+LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/GPL.txt
RUN_DEPENDS= ${PYGAME}
@@ -21,15 +21,17 @@ GH_TAGNAME= f872564
USES= python:2.7
USE_PYTHON= distutils autoplist
+NO_ARCH= yes
PORTDOCS= *.rst
-OPTIONS_DEFINE= DOCS
INSTALLS_ICONS= yes
DESKTOP_ENTRIES="PySpaceWar" "" ${PORTNAME} \
"${PORTNAME}" "Game;ArcadeGame;" ""
+OPTIONS_DEFINE= DOCS
+
post-install:
.for i in 16 22 32 48
@${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${i}x${i}/apps
@@ -40,6 +42,7 @@ post-install:
${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps/${PORTNAME}${i}.svg
.endfor
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}