aboutsummaryrefslogtreecommitdiff
path: root/games/q2p
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-03-17 16:54:51 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-03-17 16:54:51 +0000
commitc860a1dda66189db12127bd529c037fb7845d316 (patch)
tree1ee77192df78c8fcda22ff7fe6cc79f50f3f16d8 /games/q2p
parentdc2d449ce02ee0249a0c7637e77c950162061a7b (diff)
downloadports-c860a1dda66189db12127bd529c037fb7845d316.tar.gz
ports-c860a1dda66189db12127bd529c037fb7845d316.zip
Notes
Diffstat (limited to 'games/q2p')
-rw-r--r--games/q2p/Makefile81
-rw-r--r--games/q2p/pkg-descr2
-rw-r--r--games/q2p/pkg-plist3
3 files changed, 41 insertions, 45 deletions
diff --git a/games/q2p/Makefile b/games/q2p/Makefile
index bfe9665af27b..eb2b9e87e78b 100644
--- a/games/q2p/Makefile
+++ b/games/q2p/Makefile
@@ -1,55 +1,53 @@
-# New ports collection makefile for: q2p
-# Date created: 2007-01-05
-# Whom: Alejandro Pulver <alepulver@FreeBSD.org>
-#
+# Created by: Alejandro Pulver <alepulver@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= q2p
PORTVERSION= 0.2.20061231
PORTREVISION= 12
CATEGORIES= games
-MASTER_SITES= http://qudos.quakedev.com/linux/quake2/engines/Q2P/
+MASTER_SITES= http://bfeared.com/library/quake/archive/quakedev/qudos/quake2/engines/Q2P/
DISTNAME= Q2P-0.2-2006-12-31
MAINTAINER= danfe@FreeBSD.org
-COMMENT= Enhanced OpenGL only Quake II engine
+COMMENT= Enhanced OpenGL-only Quake II engine
USE_BZIP2= yes
USE_XORG= xxf86dga xext xxf86vm x11
USE_GMAKE= yes
ALL_TARGET= release
-OPTIONS= CLIENT "Build client" on \
- CTF "Build CTF (Capture The Flag) modification" off \
- DEDICATED "Build dedicated server" on \
- GAME "Build a main game .so modification" off \
- GLX "Build OpenGL renderer" on \
- OPTIMIZED_CFLAGS "Enable compilation optimizations" on \
- OSS "Enable Open Sound System sound support" on \
- SDL "Enable SDL sound support" on \
- SDLGL "Build SDL OpenGL renderer" on
-
MAKE_ENV= DATADIR="${Q2DIR}" LIBDIR="${LIBDIR}"
PLIST_SUB= LIBDIR="${LIBDIR:S/${PREFIX}\///}"
LIBDIR= ${PREFIX}/lib/${PORTNAME}
-.include "${.CURDIR}/../quake2-data/Makefile.include"
+PORTDOCS= Q2P_readme.txt Ogg_readme.txt
+
+OPTIONS_DEFINE= CLIENT CTF DEDICATED GAME GLX OPTIMIZED_CFLAGS OSS \
+ SDL SDLGL DOCS
+OPTIONS_DEFAULT= CLIENT DEDICATED GLX OPTIMIZED_CFLAGS OSS SDL SDLGL
-.include <bsd.port.pre.mk>
+CLIENT_DESC= Build client
+CTF_DESC= Build CTF (Capture The Flag) mod
+DEDICATED_DESC= Build dedicated server
+GAME_DESC= Build main game (default mod)
+GLX_DESC= Build OpenGL renderer
+SDL_DESC= Sound support via SDL
+SDLGL_DESC= Build SDL OpenGL renderer
-.if !defined(WITHOUT_GLX) || !defined(WITHOUT_SDLGL)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MGLX} || ${PORT_OPTIONS:MSDLGL}
USE_GL= glu
-LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg \
+LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg \
png15:${PORTSDIR}/graphics/png
.endif
-.if !defined(WITHOUT_SDL) || !defined(WITHOUT_SDLGL)
+.if ${PORT_OPTIONS:MSDL} || ${PORT_OPTIONS:MSDLGL}
USE_SDL= sdl
.endif
-.if !defined(WITHOUT_CLIENT)
-LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
+.if ${PORT_OPTIONS:MCLIENT}
+LIB_DEPENDS+= vorbis:${PORTSDIR}/audio/libvorbis
MAKE_ENV+= BUILD_Q2P=YES
PLIST_SUB+= CLIENT=""
Q2BIN+= ${PORTNAME}
@@ -57,14 +55,14 @@ Q2BIN+= ${PORTNAME}
PLIST_SUB+= CLIENT="@comment "
.endif
-.if defined(WITH_CTF)
+.if ${PORT_OPTIONS:MCTF}
MAKE_ENV+= BUILD_CTF=YES
PLIST_SUB+= CTF=""
.else
PLIST_SUB+= CTF="@comment "
.endif
-.if !defined(WITHOUT_DEDICATED)
+.if ${PORT_OPTIONS:MDEDICATED}
MAKE_ENV+= BUILD_DEDICATED=YES
PLIST_SUB+= DEDICATED=""
Q2BIN+= ${PORTNAME}-ded
@@ -72,7 +70,7 @@ Q2BIN+= ${PORTNAME}-ded
PLIST_SUB+= DEDICATED="@comment "
.endif
-.if defined(WITH_GAME)
+.if ${PORT_OPTIONS:MGAME}
MAKE_ENV+= BUILD_GAME=YES
PLIST_SUB+= GAME=""
.else
@@ -80,20 +78,20 @@ PLIST_SUB+= GAME="@comment "
.endif
.for opt in GLX SDLGL
-. if !defined(WITHOUT_${opt})
+. if ${PORT_OPTIONS:M${opt}}
MAKE_ENV+= BUILD_${opt}=YES
PLIST_SUB+= ${opt}=""
Q2REF+= ${opt:L:S/glx/gl/:S/sdlgl/sdl/}
-. else
+. else
PLIST_SUB+= ${opt}="@comment "
-. endif
+. endif
.endfor
-.if !defined(WITH_OPTIMIZED_CFLAGS)
+.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
MAKE_ENV+= OPTIMIZE=YES
.endif
-.if !defined(WITHOUT_OSS)
+.if ${PORT_OPTIONS:MOSS}
MAKE_ENV+= BUILD_OSS_SND=YES
PLIST_SUB+= OSS=""
Q2SND+= oss
@@ -101,7 +99,7 @@ Q2SND+= oss
PLIST_SUB+= OSS="@comment "
.endif
-.if !defined(WITHOUT_SDL)
+.if ${PORT_OPTIONS:MSDL}
MAKE_ENV+= BUILD_SDL_SND=YES
PLIST_SUB+= SDL=""
Q2SND+= sdl
@@ -118,24 +116,25 @@ do-install:
.for bin in ${Q2BIN}
${INSTALL_PROGRAM} ${WRKSRC}/quake2/${bin} ${PREFIX}/bin
.endfor
- ${MKDIR} ${LIBDIR}/baseq2
+ @${MKDIR} ${LIBDIR}/baseq2
.for ref in ${Q2REF}
${INSTALL_PROGRAM} ${WRKSRC}/quake2/vid_${ref}.so ${LIBDIR}
.endfor
.for snd in ${Q2SND}
${INSTALL_PROGRAM} ${WRKSRC}/quake2/snd_${snd}.so ${LIBDIR}
.endfor
-.if defined(WITH_CTF)
- ${MKDIR} ${LIBDIR}/ctf
+.if ${PORT_OPTIONS:MCTF}
+ @${MKDIR} ${LIBDIR}/ctf
${INSTALL_PROGRAM} ${WRKSRC}/quake2/ctf/game.so ${LIBDIR}/ctf
.endif
-.if defined(WITH_GAME)
+.if ${PORT_OPTIONS:MGAME}
${INSTALL_PROGRAM} ${WRKSRC}/quake2/baseq2/game.so ${LIBDIR}/baseq2
.endif
${INSTALL_DATA} ${WRKSRC}/data/baseq2/* ${LIBDIR}/baseq2
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} Q2P_readme.txt Ogg_readme.txt ${DOCSDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include "${.CURDIR}/../quake2-data/Makefile.include"
+.include <bsd.port.mk>
diff --git a/games/q2p/pkg-descr b/games/q2p/pkg-descr
index f67f16bef572..58c4832b7c0f 100644
--- a/games/q2p/pkg-descr
+++ b/games/q2p/pkg-descr
@@ -1 +1 @@
-Enhanced OpenGL only Quake II engine.
+Enhanced, OpenGL-only Quake II engine.
diff --git a/games/q2p/pkg-plist b/games/q2p/pkg-plist
index 767d678b94ef..88cc6e871387 100644
--- a/games/q2p/pkg-plist
+++ b/games/q2p/pkg-plist
@@ -8,9 +8,6 @@
%%SDL%%%%LIBDIR%%/snd_sdl.so
%%GLX%%%%LIBDIR%%/vid_gl.so
%%SDLGL%%%%LIBDIR%%/vid_sdl.so
-%%PORTDOCS%%%%DOCSDIR%%/Ogg_readme.txt
-%%PORTDOCS%%%%DOCSDIR%%/Q2P_readme.txt
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%LIBDIR%%/baseq2
%%CTF%%@dirrm %%LIBDIR%%/ctf
@dirrm %%LIBDIR%%