aboutsummaryrefslogtreecommitdiff
path: root/games/q3base
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-06-15 15:32:10 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-06-15 15:32:10 +0000
commitfa94f8db2a215c288c25e644ac2f183e06c5b43e (patch)
treeff722637aec39acb487bbb751270a5b43d95db6a /games/q3base
parent61d18decdafc5cd97ee4e6d06019b3aa387a7a9e (diff)
downloadports-fa94f8db2a215c288c25e644ac2f183e06c5b43e.tar.gz
ports-fa94f8db2a215c288c25e644ac2f183e06c5b43e.zip
Notes
Diffstat (limited to 'games/q3base')
-rw-r--r--games/q3base/Makefile24
-rw-r--r--games/q3base/files/patch-src__game__q_shared.h31
-rw-r--r--games/q3base/files/patch-src__qcommon__common.c (renamed from games/q3base/files/patch-netinet.diff)6
-rw-r--r--games/q3base/files/pkg-message.in8
4 files changed, 41 insertions, 28 deletions
diff --git a/games/q3base/Makefile b/games/q3base/Makefile
index e16c2bb3a5b6..21e5f4ad6ff2 100644
--- a/games/q3base/Makefile
+++ b/games/q3base/Makefile
@@ -19,22 +19,19 @@ USE_SDL= sdl net
GNU_CONFIGURE= yes
CONFIGURE_TARGET=
-.if defined(WITHOUT_X11)
-CONFIGURE_ARGS= --disable-client
-.else
-USE_GL= yes
-USE_SDL+= image
-.endif
+OPTIONS= X11 "Build OpenGL client" on
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"
-BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
+BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
.endif
-.if ${ARCH} != "i386"
-NO_PACkAGE= we don't know if this port works on ${ARCH}
-SUB_FILES+= pkg-message
+.if defined(WITHOUT_X11)
+CONFIGURE_ARGS= --disable-client
+.else
+USE_GL= yes
+USE_SDL+= image
.endif
post-patch:
@@ -43,12 +40,5 @@ post-patch:
@${REINPLACE_CMD} -e 's|botlib\.log|/dev/null|' \
${WRKSRC}/src/botlib/be_interface.c
-.if ${ARCH} != "i386"
-post-install:
- @${ECHO_CMD}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_CMD}
-.endif
-
.include "${.CURDIR}/../quake3-data/Makefile.include"
.include <bsd.port.post.mk>
diff --git a/games/q3base/files/patch-src__game__q_shared.h b/games/q3base/files/patch-src__game__q_shared.h
new file mode 100644
index 000000000000..00ec0067d064
--- /dev/null
+++ b/games/q3base/files/patch-src__game__q_shared.h
@@ -0,0 +1,31 @@
+--- ./src/game/q_shared.h.orig Wed Oct 5 19:51:28 2005
++++ ./src/game/q_shared.h Thu Jun 15 12:03:49 2006
+@@ -140,7 +140,9 @@
+ int LongSwap (int l);
+ float FloatSwap (const float *f);
+
+-#if defined (__i386__) || defined (__MIPSEL__) || defined (__amd64__)
++#include <machine/endian.h>
++
++#if BYTE_ORDER == LITTLE_ENDIAN
+ /* Little Endian */
+ #define BigShort ShortSwap
+ #define LittleShort
+@@ -148,7 +150,7 @@
+ #define LittleLong
+ #define BigFloat(l) FloatSwap(&l)
+ #define LittleFloat
+-#elif defined (__mips__) || defined (__ppc__) || defined (__sparc__)
++#elif BYTE_ORDER == BIG_ENDIAN
+ /* Big Endian */
+ #define BigShort
+ #define LittleShort ShortSwap
+@@ -199,7 +201,7 @@
+ #elif defined (__axp__)
+ #define CPUSTRING "alpha"
+ #else
+-#error "Unknown processor family"
++#define CPUSTRING "unknown"
+ #endif
+
+ /*
diff --git a/games/q3base/files/patch-netinet.diff b/games/q3base/files/patch-src__qcommon__common.c
index ce72a52312b7..7a9bd1bb170a 100644
--- a/games/q3base/files/patch-netinet.diff
+++ b/games/q3base/files/patch-src__qcommon__common.c
@@ -1,5 +1,5 @@
---- src/qcommon/common.c Thu Oct 6 00:51:26 2005
-+++ src/qcommon/common.c Sun Jan 1 22:13:57 2006
+--- ./src/qcommon/common.c.orig Wed Oct 5 19:51:26 2005
++++ ./src/qcommon/common.c Thu Jun 15 12:03:49 2006
@@ -27,6 +27,7 @@
#ifdef _WIN32
#include <winsock.h>
@@ -7,4 +7,4 @@
+#include <sys/types.h>
#include <netinet/in.h>
#endif
-
+
diff --git a/games/q3base/files/pkg-message.in b/games/q3base/files/pkg-message.in
deleted file mode 100644
index 9f4d8f47e777..000000000000
--- a/games/q3base/files/pkg-message.in
+++ /dev/null
@@ -1,8 +0,0 @@
-==============================================================================
-
-This port has not been tested on this architecture.
-
-Please give feedback to the maintainer about whether it works or not, so it
-can be marked as it should.
-
-==============================================================================