aboutsummaryrefslogtreecommitdiff
path: root/games/q3cellshading/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-11-23 12:00:47 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-11-23 12:00:47 +0000
commit6db26ba974644717e439058b4c65ca3a69ac9882 (patch)
treedc91268ea2582590643753822db59bfa6e46aa4e /games/q3cellshading/Makefile
parent3305e65662631fdb15ce4e5cd641295636735f87 (diff)
downloadports-6db26ba974644717e439058b4c65ca3a69ac9882.tar.gz
ports-6db26ba974644717e439058b4c65ca3a69ac9882.zip
Notes
Diffstat (limited to 'games/q3cellshading/Makefile')
-rw-r--r--games/q3cellshading/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/games/q3cellshading/Makefile b/games/q3cellshading/Makefile
index 41846d782d2f..00dad03d14da 100644
--- a/games/q3cellshading/Makefile
+++ b/games/q3cellshading/Makefile
@@ -7,7 +7,7 @@
PORTNAME= quake3
PORTVERSION= 1.32b
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= ftp://ftp.idsoftware.com/idstuff/source/ \
http://www.proarena.com/p/ftpx/x8524/quake_3_arena/ \
@@ -27,9 +27,16 @@ USE_GMAKE= yes
USE_REINPLACE= yes
USE_PERL5_BUILD=yes
USE_GL= yes
+USE_GCC= 3.2+
PLIST_FILES= bin/q3ded bin/quake3
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|%%Q3DIR%%|"${Q3DIR}"|' \
${WRKSRC}/code/unix/unix_shared.c
@@ -38,7 +45,7 @@ pre-build:
${MKDIR} ${WRKSRC}/lcc/build
do-build:
- cd ${WRKSRC}/code && ${PERL} unix/cons
+ cd ${WRKSRC}/code && ${MAKE_ENV} ${PERL} unix/cons
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/code/install/linuxq3ded \
@@ -47,4 +54,4 @@ do-install:
${PREFIX}/bin/quake3
.include "${.CURDIR}/../quake3-data/Makefile.include"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>