aboutsummaryrefslogtreecommitdiff
path: root/games/q3cellshading
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 16:35:45 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 16:35:45 +0000
commit3a283e24f296371e9b753c09e3e62a92ef3d8703 (patch)
tree88e0a2bbddafb5c9bdc18e8e02c5e59fb9f9d471 /games/q3cellshading
parent7a0a8929bea1c510b4f30261d294a78b556b49d7 (diff)
downloadports-3a283e24f296371e9b753c09e3e62a92ef3d8703.tar.gz
ports-3a283e24f296371e9b753c09e3e62a92ef3d8703.zip
Notes
Diffstat (limited to 'games/q3cellshading')
-rw-r--r--games/q3cellshading/Makefile32
1 files changed, 15 insertions, 17 deletions
diff --git a/games/q3cellshading/Makefile b/games/q3cellshading/Makefile
index e111eee0f396..653bcc76be49 100644
--- a/games/q3cellshading/Makefile
+++ b/games/q3cellshading/Makefile
@@ -23,11 +23,14 @@ USE_GMAKE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
BUILD_WRKSRC= ${WRKSRC}/code/unix
-OPTIONS= CLIENT "Build client" on \
- DEDICATED "Build dedicated server" on \
- GAMELIBS "Build game libraries (when not mandatory)" off \
- OPTIMIZED_CFLAGS "Enable compilation optimizations" on \
- SMP "Build SMP (threaded) client" on
+OPTIONS_MULTI= EXE
+OPTIONS_MULTI_EXE= CLIENT DEDICATED SMP
+OPTIONS_DEFINE= GAMELIBS OPTIMIZED_CFLAGS
+OPTIONS_DEFAULT= CLIETN DEDICATED OPTIMIZED_CFLAGS SMP
+CLIENT_DESC= Build client
+DEDICATED_DESC= Build dedicated server
+GAMELIBS_DESC= Build game libraries (when not mandatory)
+SMP_DESC= Build SMP (threaded) client
MAKE_ENV= LIBDIR="${LIBDIR}"
PLIST_SUB= LIBDIR="${LIBDIR:S/${PREFIX}\///}"
@@ -37,11 +40,6 @@ VM_ARCHS= i386 powerpc
.include <bsd.port.pre.mk>
-.if defined(WITHOUT_CLIENT) && defined(WITHOUT_DEDICATED) && \
- defined(WITHOUT_SMP)
-IGNORE= needs at least one of CLIENT, DEDICATED and SMP options
-.endif
-
.if ${ARCH} == "i386"
BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
.endif
@@ -56,12 +54,12 @@ HAVE_VM_COMPILED= yes
MAKE_ENV+= DLL_ONLY=true
.endif
-.if !defined(WITHOUT_CLIENT) || !defined(WITHOUT_SMP)
+.if ${PORT_OPTIONS:MCLIENT} || !empty(PORT_OPTIONS:MSMP)
USE_GL= yes
USE_XORG= xxf86dga
.endif
-.if !defined(WITHOUT_CLIENT)
+.if ${PORT_OPTIONS:MCLIENT}
MAKE_ENV+= CLIENT=YES
PLIST_SUB+= CLIENT=""
Q3BIN+= quake3
@@ -69,7 +67,7 @@ Q3BIN+= quake3
PLIST_SUB+= CLIENT="@comment "
.endif
-.if !defined(WITHOUT_DEDICATED)
+.if ${PORT_OPTIONS:MDEDICATED}
MAKE_ENV+= DEDICATED=YES
PLIST_SUB+= DEDICATED=""
Q3BIN+= q3ded
@@ -77,18 +75,18 @@ Q3BIN+= q3ded
PLIST_SUB+= DEDICATED="@comment "
.endif
-.if defined(WITH_GAMELIBS) || !defined(HAVE_VM_COMPILED)
+.if ${PORT_OPTIONS:MGAMELIBS} || !defined(HAVE_VM_COMPILED)
MAKE_ENV+= GAMELIBS=YES
PLIST_SUB+= GAMELIBS=""
.else
PLIST_SUB+= GAMELIBS="@comment "
.endif
-.if !defined(WITHOUT_OPTIMIZED_CFLAGS)
+.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
MAKE_ENV+= OPTIMIZED_CFLAGS=YES
.endif
-.if !defined(WITHOUT_SMP)
+.if ${PORT_OPTIONS:MSMP}
MAKE_ENV+= SMP=YES \
PTHREAD_LIBS="${PTHREAD_LIBS}"
PLIST_SUB+= SMP=""
@@ -110,7 +108,7 @@ do-install:
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/release/${bin} \
${PREFIX}/bin/${bin:C/(quake3|q3)/\1cel/}
.endfor
-.if defined(WITH_GAMELIBS) || !defined(HAVE_VM_COMPILED)
+.if ${PORT_OPTIONS:MGAMELIBS} || !defined(HAVE_VM_COMPILED)
.for dir in baseq3 missionpack
${MKDIR} ${LIBDIR}/${dir}
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/release/${dir}/*.so ${LIBDIR}/${dir}