aboutsummaryrefslogtreecommitdiff
path: root/games/q3cellshading
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-11-22 05:20:37 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-11-22 05:20:37 +0000
commit1e53364329090f5759a144db2c9d2e4a1b0d5b7d (patch)
tree95081fcfac9474fb6c6a8fc06618bdca0b860a88 /games/q3cellshading
parente81f50450df30da640f9005cf3455755b5b5ac2f (diff)
downloadports-1e53364329090f5759a144db2c9d2e4a1b0d5b7d.tar.gz
ports-1e53364329090f5759a144db2c9d2e4a1b0d5b7d.zip
Notes
Diffstat (limited to 'games/q3cellshading')
-rw-r--r--games/q3cellshading/Makefile56
-rw-r--r--games/q3cellshading/files/patch-code-unix-Makefile4
-rw-r--r--games/q3cellshading/files/patch-code-unix-unix_shared.c6
-rw-r--r--games/q3cellshading/pkg-message7
-rw-r--r--games/q3cellshading/pkg-plist19
5 files changed, 22 insertions, 70 deletions
diff --git a/games/q3cellshading/Makefile b/games/q3cellshading/Makefile
index 3343fa517211..41846d782d2f 100644
--- a/games/q3cellshading/Makefile
+++ b/games/q3cellshading/Makefile
@@ -15,58 +15,36 @@ MASTER_SITES= ftp://ftp.idsoftware.com/idstuff/source/ \
http://www.teamdarkside.net/ \
http://0day.icculus.org/mirrors/quake3/ \
http://www.olpainless.net/files/
-EXTRACT_SUFX= -source.zip
-EXTRACT_ONLY=
+DISTFILES= ${DISTNAME}-source${EXTRACT_SUFX}
MAINTAINER= shirshegsm@gmail.com
COMMENT= Quake III Arena -- first person shooter (native build)
-EXTRACT_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
-BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
+BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
-USE_GMAKE= yes
-USE_PERL5_BUILD= yes
-USE_GL= yes
-USE_REINPLACE= yes
-CONFLICTS= q3server-1.32*
+USE_ZIP= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_PERL5_BUILD=yes
+USE_GL= yes
-# We need that -a flag
-do-extract:
- ${MKDIR} ${WRKDIR} && \
- cd ${WRKDIR} && \
- ${UNZIP_CMD} -aqx ${DISTDIR}/${PORTNAME}-${PORTVERSION}-source.zip
+PLIST_FILES= bin/q3ded bin/quake3
post-patch:
- @${REINPLACE_CMD} -e 's|##PREFIX##|${PREFIX}|g' ${WRKSRC}/code/unix/unix_shared.c
+ @${REINPLACE_CMD} -e 's|%%Q3DIR%%|"${Q3DIR}"|' \
+ ${WRKSRC}/code/unix/unix_shared.c
pre-build:
- ${MKDIR} ${WRKSRC}/lcc/build
+ ${MKDIR} ${WRKSRC}/lcc/build
do-build:
- cd ${WRKSRC}/code && \
- ${PERL} unix/cons
- ${MV} ${WRKSRC}/code/install/linuxq3ded ${WRKSRC}/code/install/q3ded
- ${MV} ${WRKSRC}/code/install/linuxquake3 ${WRKSRC}/code/install/quake3
+ cd ${WRKSRC}/code && ${PERL} unix/cons
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/code/install/q3ded ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/code/install/quake3 ${PREFIX}/bin
- ${MKDIR} ${PREFIX}/lib/quake3/baseq3/vm
- ${CP} ${WRKSRC}/code/install/baseq3/cgamei386.so ${PREFIX}/lib/quake3/baseq3
- ${CP} ${WRKSRC}/code/install/baseq3/qagamei386.so ${PREFIX}/lib/quake3/baseq3
- ${CP} ${WRKSRC}/code/install/baseq3/uii386.so ${PREFIX}/lib/quake3/baseq3
- ${CP} ${WRKSRC}/code/install/baseq3/vm/cgame.qvm ${PREFIX}/lib/quake3/baseq3/vm
- ${CP} ${WRKSRC}/code/install/baseq3/vm/qagame.qvm ${PREFIX}/lib/quake3/baseq3/vm
- ${CP} ${WRKSRC}/code/install/baseq3/vm/ui.qvm ${PREFIX}/lib/quake3/baseq3/vm
- ${MKDIR} ${PREFIX}/lib/quake3/missionpack/vm
- ${CP} ${WRKSRC}/code/install/missionpack/cgamei386.so ${PREFIX}/lib/quake3/missionpack
- ${CP} ${WRKSRC}/code/install/missionpack/qagamei386.so ${PREFIX}/lib/quake3/missionpack
- ${CP} ${WRKSRC}/code/install/missionpack/uii386.so ${PREFIX}/lib/quake3/missionpack
- ${CP} ${WRKSRC}/code/install/missionpack/vm/cgame.qvm ${PREFIX}/lib/quake3/missionpack/vm
- ${CP} ${WRKSRC}/code/install/missionpack/vm/qagame.qvm ${PREFIX}/lib/quake3/missionpack/vm
- ${CP} ${WRKSRC}/code/install/missionpack/vm/ui.qvm ${PREFIX}/lib/quake3/missionpack/vm
-
-post-install:
- ${CAT} pkg-message
+ ${INSTALL_PROGRAM} ${WRKSRC}/code/install/linuxq3ded \
+ ${PREFIX}/bin/q3ded
+ ${INSTALL_PROGRAM} ${WRKSRC}/code/install/linuxquake3 \
+ ${PREFIX}/bin/quake3
+.include "${.CURDIR}/../quake3-data/Makefile.include"
.include <bsd.port.mk>
diff --git a/games/q3cellshading/files/patch-code-unix-Makefile b/games/q3cellshading/files/patch-code-unix-Makefile
index 2e5555444b17..415a976544fc 100644
--- a/games/q3cellshading/files/patch-code-unix-Makefile
+++ b/games/q3cellshading/files/patch-code-unix-Makefile
@@ -1,5 +1,5 @@
---- code/unix/Makefile Sun May 5 12:21:10 2002
-+++ ../../work/quake3-1.32b/code/unix/Makefile Sun Aug 28 23:16:03 2005
+--- code/unix/Makefile.orig Sun May 5 07:21:10 2002
++++ code/unix/Makefile Sun Nov 20 18:48:48 2005
@@ -136,7 +136,7 @@
ifeq ($(ARCH),ppc)
NEWPGCC=/loki/global/ppc/bin/gcc
diff --git a/games/q3cellshading/files/patch-code-unix-unix_shared.c b/games/q3cellshading/files/patch-code-unix-unix_shared.c
index 27492d29bbbb..013c39f2bc13 100644
--- a/games/q3cellshading/files/patch-code-unix-unix_shared.c
+++ b/games/q3cellshading/files/patch-code-unix-unix_shared.c
@@ -1,11 +1,11 @@
---- code/unix/unix_shared.c Tue Aug 16 02:10:07 2005
-+++ ../../work/quake3-1.32b/code/unix/unix_shared.c Mon Aug 29 00:37:41 2005
+--- code/unix/unix_shared.c.orig Mon Aug 15 20:10:07 2005
++++ code/unix/unix_shared.c Sun Nov 20 18:41:22 2005
@@ -38,7 +38,7 @@
static char cdPath[MAX_OSPATH];
// Used to determine local installation path
-static char installPath[MAX_OSPATH];
-+static char installPath[MAX_OSPATH] = "##PREFIX##/lib/quake3"; // FreeBSD
++static char installPath[MAX_OSPATH] = %%Q3DIR%%;
// Used to determine where to store user-specific files
static char homePath[MAX_OSPATH];
diff --git a/games/q3cellshading/pkg-message b/games/q3cellshading/pkg-message
deleted file mode 100644
index 3ad5ccdfa8a5..000000000000
--- a/games/q3cellshading/pkg-message
+++ /dev/null
@@ -1,7 +0,0 @@
------
-Quake III client is installed in bin/quake3 and
-Quake III dedicated server in bin/q3ded.
-
-No .pak3's are installed, you need to copy/link them to
-~/.q3a/baseq3
------
diff --git a/games/q3cellshading/pkg-plist b/games/q3cellshading/pkg-plist
deleted file mode 100644
index 584f4808a57b..000000000000
--- a/games/q3cellshading/pkg-plist
+++ /dev/null
@@ -1,19 +0,0 @@
-bin/q3ded
-bin/quake3
-lib/quake3/baseq3/cgamei386.so
-lib/quake3/baseq3/qagamei386.so
-lib/quake3/baseq3/uii386.so
-lib/quake3/baseq3/vm/cgame.qvm
-lib/quake3/baseq3/vm/qagame.qvm
-lib/quake3/baseq3/vm/ui.qvm
-lib/quake3/missionpack/cgamei386.so
-lib/quake3/missionpack/qagamei386.so
-lib/quake3/missionpack/uii386.so
-lib/quake3/missionpack/vm/cgame.qvm
-lib/quake3/missionpack/vm/qagame.qvm
-lib/quake3/missionpack/vm/ui.qvm
-@dirrm lib/quake3/baseq3/vm
-@dirrm lib/quake3/baseq3
-@dirrm lib/quake3/missionpack/vm
-@dirrm lib/quake3/missionpack
-@dirrm lib/quake3