aboutsummaryrefslogtreecommitdiff
path: root/games/q3cellshading
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-03-16 17:34:10 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-03-16 17:34:10 +0000
commitabba8af75eb5138b9fd1871cc9178ab7e0284c5c (patch)
tree5aa01506173c1c950ab51024bb944776bfe8d4ab /games/q3cellshading
parent5e82fd8b7e190b467a20ede1eb1d97d98dde7d68 (diff)
downloadports-abba8af75eb5138b9fd1871cc9178ab7e0284c5c.tar.gz
ports-abba8af75eb5138b9fd1871cc9178ab7e0284c5c.zip
Notes
Diffstat (limited to 'games/q3cellshading')
-rw-r--r--games/q3cellshading/Makefile46
-rw-r--r--games/q3cellshading/pkg-descr18
2 files changed, 31 insertions, 33 deletions
diff --git a/games/q3cellshading/Makefile b/games/q3cellshading/Makefile
index 653bcc76be49..e7b6646fffe3 100644
--- a/games/q3cellshading/Makefile
+++ b/games/q3cellshading/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: q3cellshading
-# Date created: 8 Aug 2006
-# Whom: alepulver
-#
+# Created by: Alejandro Pulver <alepulver@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= q3cellshading
PORTVERSION= 1.0
@@ -17,44 +13,46 @@ COMMENT= Quake III engine with Cell Shading capabilities
ONLY_FOR_ARCHS= i386
ONLY_FOR_ARCHS_REASON= does not run properly; try games/ioquake3 with option
+
USE_ZIP= yes
USE_DOS2UNIX= yes
USE_GMAKE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
BUILD_WRKSRC= ${WRKSRC}/code/unix
-OPTIONS_MULTI= EXE
-OPTIONS_MULTI_EXE= CLIENT DEDICATED SMP
-OPTIONS_DEFINE= GAMELIBS OPTIMIZED_CFLAGS
-OPTIONS_DEFAULT= CLIETN DEDICATED OPTIMIZED_CFLAGS SMP
-CLIENT_DESC= Build client
-DEDICATED_DESC= Build dedicated server
-GAMELIBS_DESC= Build game libraries (when not mandatory)
-SMP_DESC= Build SMP (threaded) client
-
+LIBDIR= ${PREFIX}/lib/${PORTNAME}
MAKE_ENV= LIBDIR="${LIBDIR}"
PLIST_SUB= LIBDIR="${LIBDIR:S/${PREFIX}\///}"
-LIBDIR= ${PREFIX}/lib/${PORTNAME}
VM_ARCHS= i386 powerpc
+OPTIONS_DEFINE= GAMELIBS OPTIMIZED_CFLAGS
+OPTIONS_MULTI= FLAVOR
+OPTIONS_MULTI_FLAVOR= CLIENT DEDICATED SMP_CLIENT
+OPTIONS_DEFAULT= CLIENT DEDICATED OPTIMIZED_CFLAGS SMP_CLIENT
+
+CLIENT_DESC= Build client
+DEDICATED_DESC= Build dedicated server
+GAMELIBS_DESC= Force building game libraries
+SMP_CLIENT_DESC= Build SMP (threaded) client
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"
-BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
+BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
.endif
-.for i in ${ARCH}
-. if ${VM_ARCHS:M${i}} != ""
+.for arch in ${ARCH}
+. if ${VM_ARCHS:M${arch}} != ""
HAVE_VM_COMPILED= yes
-. endif
+. endif
.endfor
.if !defined(HAVE_VM_COMPILED)
MAKE_ENV+= DLL_ONLY=true
.endif
-.if ${PORT_OPTIONS:MCLIENT} || !empty(PORT_OPTIONS:MSMP)
+.if ${PORT_OPTIONS:MCLIENT} || ${PORT_OPTIONS:MSMP_CLIENT}
USE_GL= yes
USE_XORG= xxf86dga
.endif
@@ -86,9 +84,8 @@ PLIST_SUB+= GAMELIBS="@comment "
MAKE_ENV+= OPTIMIZED_CFLAGS=YES
.endif
-.if ${PORT_OPTIONS:MSMP}
-MAKE_ENV+= SMP=YES \
- PTHREAD_LIBS="${PTHREAD_LIBS}"
+.if ${PORT_OPTIONS:MSMP_CLIENT}
+MAKE_ENV+= SMP=YES PTHREAD_LIBS="${PTHREAD_LIBS}"
PLIST_SUB+= SMP=""
Q3BIN+= quake3-smp
.else
@@ -105,12 +102,13 @@ post-patch:
do-install:
.for bin in ${Q3BIN}
+# Adjust program names to avoid conflicts with other Quake3 ports
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/release/${bin} \
${PREFIX}/bin/${bin:C/(quake3|q3)/\1cel/}
.endfor
.if ${PORT_OPTIONS:MGAMELIBS} || !defined(HAVE_VM_COMPILED)
.for dir in baseq3 missionpack
- ${MKDIR} ${LIBDIR}/${dir}
+ @${MKDIR} ${LIBDIR}/${dir}
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/release/${dir}/*.so ${LIBDIR}/${dir}
.endfor
.endif
diff --git a/games/q3cellshading/pkg-descr b/games/q3cellshading/pkg-descr
index f6f34468c19d..72c96888fd1d 100644
--- a/games/q3cellshading/pkg-descr
+++ b/games/q3cellshading/pkg-descr
@@ -1,8 +1,8 @@
The goal of this project is to add Cell Shading capabilities to the Quake III
-engine with Real-time performance.
+engine with real-time performance.
-In order to provide such feature we have decided to use Kuwahara filter.
-Kuwahara filter is a noise-reduction filter that preserves edges.
+In order to provide such feature we have decided to use Kuwahara filter, a
+noise-reduction filter that preserves edges.
It uses four subquadrants to calculate the mean and variance and chooses the
mean value for the region with the smallest variance.
@@ -11,13 +11,13 @@ To increase the hand-painted effect we have decided to apply a simple blur
filter to reduce hard-edges on textures and increase the flatness effect.
To produce the cell shading effect we use no graphics card shaders, so our
-implementation could run with almost any gfx card. The edge effect is produced
-by painting backface polygons with a thick wireframe without textures and
-repaint all the scene, but this time, with textures.
+implementation could run with almost any graphics card. The edge effect is
+produced by painting backface polygons with a thick wireframe without
+textures and repaint all the scene, but this time, with textures.
We have also implemented a different algorithm (we call it White Texture),
-which uses white textures. It looks like this and this, you can set the
-console variable r_celshadalgo to 2, and load another map, or run using the
-appropiate link that came with the release.
+which uses white textures. You can set the console variable r_celshadalgo
+to 2, and load another map, or run using the appropriate link that came
+with the release.
WWW: http://q3cellshading.sourceforge.net/