aboutsummaryrefslogtreecommitdiff
path: root/games/qccx/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2005-01-18 12:41:46 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2005-01-18 12:41:46 +0000
commit8aea93eedb903608f59d51c0424949c5277646b3 (patch)
tree17e872c6ec7d36ab199490289393c120950f3140 /games/qccx/Makefile
parentf927c7994da5f4fc219df683b081db0a0c5d13e2 (diff)
downloadports-8aea93eedb903608f59d51c0424949c5277646b3.tar.gz
ports-8aea93eedb903608f59d51c0424949c5277646b3.zip
Notes
Diffstat (limited to 'games/qccx/Makefile')
-rw-r--r--games/qccx/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/games/qccx/Makefile b/games/qccx/Makefile
new file mode 100644
index 000000000000..900dc8a0f766
--- /dev/null
+++ b/games/qccx/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: QCCX
+# Date created: 18 Jan 2005
+# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qccx
+PORTVERSION= 1.0.0
+CATEGORIES= games devel
+MASTER_SITES= http://www.planetquake.com/qccx/ \
+ http://freebsd.nsu.ru/distfiles/
+DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= A very fast optimizing QuakeC compiler
+
+USE_ZIP= yes
+USE_REINPLACE= yes
+
+MAKEFILE= ${FILESDIR}/Makefile
+WRKSRC= ${WRKDIR}
+
+post-extract:
+ @${FIND} ${WRKDIR} -type f -name "*.[^deo]*" -print0 | \
+ ${XARGS} -0 ${REINPLACE_CMD} -e 's/[[:cntrl:]]*$$//'
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.qc ${WRKSRC}/progs.src ${DATADIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/[^g]*.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>