aboutsummaryrefslogtreecommitdiff
path: root/games/qgo/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-04-13 06:57:45 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-04-13 06:57:45 +0000
commit198345a8b8dc7cef33dc2de22a12ec5517c9592e (patch)
tree67186d2787f4fc6da5104f427ff533ea7926760f /games/qgo/Makefile
parent11ec8fb1bce08b2a69c4cf0c2b8e4966d5d0f0ce (diff)
downloadports-198345a8b8dc7cef33dc2de22a12ec5517c9592e.tar.gz
ports-198345a8b8dc7cef33dc2de22a12ec5517c9592e.zip
Notes
Diffstat (limited to 'games/qgo/Makefile')
-rw-r--r--games/qgo/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/games/qgo/Makefile b/games/qgo/Makefile
new file mode 100644
index 000000000000..3b345f8c5b9e
--- /dev/null
+++ b/games/qgo/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8
+# Ports collection makefile for: qgo
+# Date created: Mar 22, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= qgo
+PORTVERSION= 0.0.8
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
+
+USE_QT_VER= 2
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= QTDIR=${X11BASE} LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+USE_GMAKE= yes
+
+post-patch:
+ @${PERL} -pi -e "s,qt.so,qt2.so,g ; \
+ s,/moc,/moc2,g" ${WRKSRC}/configure
+ @${PERL} -pi -e "s,-lqt,-lqt2,g" ${WRKSRC}/src/Makefile.in
+
+.include <bsd.port.mk>