aboutsummaryrefslogtreecommitdiff
path: root/games/qgo
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2019-03-16 21:55:51 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2019-03-16 21:55:51 +0000
commit369eb054b0edf196641e8706f3f6fcd77788f690 (patch)
treed44bab2e528ec5663705a59ae511ea0a4e027206 /games/qgo
parent0905a6eadceddc6507f0dffa4fbb18f40feda17c (diff)
Notes
Diffstat (limited to 'games/qgo')
-rw-r--r--games/qgo/Makefile40
-rw-r--r--games/qgo/distinfo2
-rw-r--r--games/qgo/files/patch-src__listviews.cpp11
-rw-r--r--games/qgo/files/patch-src__mainwindow_settings.cpp17
-rw-r--r--games/qgo/pkg-descr5
5 files changed, 0 insertions, 75 deletions
diff --git a/games/qgo/Makefile b/games/qgo/Makefile
deleted file mode 100644
index 0f3c3e240b97..000000000000
--- a/games/qgo/Makefile
+++ /dev/null
@@ -1,40 +0,0 @@
-# Created by: ijliao
-# $FreeBSD$
-
-PORTNAME= qgo
-PORTVERSION= 2.s764
-CATEGORIES= games
-MASTER_SITES= DEBIAN
-DISTNAME= ${PORTNAME}_2~svn764.orig
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Go board and SGF editor written with the Qt library
-
-DEPRECATED= Qt4 has been EOL since december 2015
-EXPIRATION_DATE= 2019-03-15
-
-BROKEN= fails to build
-
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
-USES= desktop-file-utils qmake qt:4 tar:bzip2
-USE_QT= gui network qtestlib moc_build rcc_build uic_build
-
-PLIST_FILES= bin/qgo share/applications/qgo.desktop share/pixmaps/qgo.png
-
-post-patch:
- @${REINPLACE_CMD} -e \
- '/Icon/s|=.*|=${PREFIX}/share/pixmaps/qgo.png| ; \
- /^MimeType/s|=.*|=text/sgf|' ${WRKSRC}/src/qgo.desktop
- @${REINPLACE_CMD} -e \
- 's|debug|release|' ${WRKSRC}/src/src.pro
- @${REINPLACE_CMD} -e \
- 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/src/mainwindow_settings.cpp
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/qgo ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/src/qgo.desktop ${STAGEDIR}${DESKTOPDIR}
- ${INSTALL_DATA} ${WRKSRC}/src/ressources/pics/qgo.png \
- ${STAGEDIR}${PREFIX}/share/pixmaps
-
-.include <bsd.port.mk>
diff --git a/games/qgo/distinfo b/games/qgo/distinfo
deleted file mode 100644
index 28ed2058ab4e..000000000000
--- a/games/qgo/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (qgo_2~svn764.orig.tar.bz2) = 07620bf2d08def7630aab69338ce345451d36e1c19acde649ec44be500102205
-SIZE (qgo_2~svn764.orig.tar.bz2) = 2491726
diff --git a/games/qgo/files/patch-src__listviews.cpp b/games/qgo/files/patch-src__listviews.cpp
deleted file mode 100644
index 216799bad5cd..000000000000
--- a/games/qgo/files/patch-src__listviews.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/listviews.cpp.orig
-+++ src/listviews.cpp
-@@ -342,7 +342,7 @@
- {
- for(int i = 0; i < items.count(); i++)
- {
-- GamesListItem * const item = static_cast<const GamesListItem *>(items[i]);
-+ const GamesListItem * item = static_cast<const GamesListItem *>(items[i]);
- if(item->getListing() == l)
- {
- /* Really this is supposed to be not QModelIndex() but the
diff --git a/games/qgo/files/patch-src__mainwindow_settings.cpp b/games/qgo/files/patch-src__mainwindow_settings.cpp
deleted file mode 100644
index 4d955d784579..000000000000
--- a/games/qgo/files/patch-src__mainwindow_settings.cpp
+++ /dev/null
@@ -1,17 +0,0 @@
---- src/mainwindow_settings.cpp.orig
-+++ src/mainwindow_settings.cpp
-@@ -269,7 +269,13 @@
- QVariant var;
-
- ui.comboBox_language->setCurrentIndex (settings.value("LANGUAGE").toInt());
-- ui.LineEdit_computer->setText(settings.value("COMPUTER_PATH").toString());
-+ QString computer_path = settings.value("COMPUTER_PATH").toString();
-+ qDebug() << "COMPUTER_PATH" << computer_path;
-+ if (computer_path == "") {
-+ computer_path = "%%LOCALBASE%%/bin/gnugo";
-+ settings.setValue("COMPUTER_PATH", computer_path);
-+ }
-+ ui.LineEdit_computer->setText(computer_path);
- if(settings.value("COMPUTER_PLAYS_WHITE").toBool())
- ui.computerPlaysWhite->setChecked(TRUE);
- else
diff --git a/games/qgo/pkg-descr b/games/qgo/pkg-descr
deleted file mode 100644
index c470f44e6d77..000000000000
--- a/games/qgo/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-qGo is a Go board and full featured SGF editor written with the Qt library,
-available for Linux and Windows. Go is an ancient boardgame, very common in
-Japan, China and Korea.
-
-WWW: http://qgo.sourceforge.net/