aboutsummaryrefslogtreecommitdiff
path: root/games/qgo
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-12-18 18:46:04 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-12-18 18:46:04 +0000
commitdd89cf7e4e91f312f48f7b344c3bfe8705a9134c (patch)
tree0f45fb01a82aa3884a98309dd2ec1dba8d32fade /games/qgo
parent2dbcfc55e1ff4e556e1d904680f870d382f81fd3 (diff)
downloadports-dd89cf7e4e91f312f48f7b344c3bfe8705a9134c.tar.gz
ports-dd89cf7e4e91f312f48f7b344c3bfe8705a9134c.zip
Notes
Diffstat (limited to 'games/qgo')
-rw-r--r--games/qgo/Makefile21
-rw-r--r--games/qgo/distinfo4
-rw-r--r--games/qgo/files/patch-qgo::Makefile.in23
-rw-r--r--games/qgo/files/patch-qgo::src::wavfile.c28
-rw-r--r--games/qgo/files/patch-qgo::src::wavplay.c16
-rw-r--r--games/qgo/files/patch-src::mainwin.cpp (renamed from games/qgo/files/patch-qgo::src::mainwin.cpp)6
-rw-r--r--games/qgo/files/patch-src::wavfile.c60
-rw-r--r--games/qgo/files/patch-src::wavplay.c30
-rw-r--r--games/qgo/pkg-plist4
9 files changed, 108 insertions, 84 deletions
diff --git a/games/qgo/Makefile b/games/qgo/Makefile
index 3f09abcef689..92e7c1583c93 100644
--- a/games/qgo/Makefile
+++ b/games/qgo/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= qgo
-PORTVERSION= 0.2.2
+PORTVERSION= 1.0.0
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,19 +19,16 @@ USE_QT_VER= 3
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= QTDIR=${QT_PREFIX}
-MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
- AUTOHEADER="${TRUE}"
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= QTDIR="${QT_PREFIX}"
CONFIGURE_ARGS= --x-libraries=${X11BASE}/lib --x-includes=${X11BASE}/include
post-patch:
- @${REINPLACE_CMD} -e 's|-pedantic||g ; \
- s|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
- @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|/usr/share|$${prefix}/share|g'
-
-pre-build:
- -@${RM} ${WRKSRC}/qgo/src/*_gui.cpp
- -@${RM} ${WRKSRC}/qgo/src/*_gui.h
+ @${REINPLACE_CMD} -e \
+ 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's|src templates|src|g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e \
+ 's|: install-includeHEADERS|:|g' ${WRKSRC}/src/Makefile.in
.include <bsd.port.mk>
diff --git a/games/qgo/distinfo b/games/qgo/distinfo
index 4ee904d2ec1a..7381492a5e26 100644
--- a/games/qgo/distinfo
+++ b/games/qgo/distinfo
@@ -1,2 +1,2 @@
-MD5 (qgo-0.2.2.tar.gz) = 4483bebd46ceda203b0cbad35da0a624
-SIZE (qgo-0.2.2.tar.gz) = 1751040
+MD5 (qgo-1.0.0.tar.gz) = a455fb3a850e340c9d07bb5e514026ef
+SIZE (qgo-1.0.0.tar.gz) = 1420181
diff --git a/games/qgo/files/patch-qgo::Makefile.in b/games/qgo/files/patch-qgo::Makefile.in
deleted file mode 100644
index fd65750fdfeb..000000000000
--- a/games/qgo/files/patch-qgo::Makefile.in
+++ /dev/null
@@ -1,23 +0,0 @@
---- qgo/Makefile.in.orig Mon May 10 18:33:38 2004
-+++ qgo/Makefile.in Mon May 10 18:34:44 2004
-@@ -235,7 +235,7 @@
- KDE_OPTIONS = qtonly
- qgo_LDADD = ./src/libsrc.a $(LIB_QPE) $(LIB_QT) $(LIBSOCKET)
-
--SUBDIRS = src templates
-+SUBDIRS = src
-
- EXTRA_DIST = filenew.xpm filesave.xpm fileopen.xpm ChangeLog
-
-@@ -266,6 +266,11 @@
- #>+ 1
- qgo_OBJECTS =
- qgo_DEPENDENCIES = ./src/libsrc.a
-+CFLAGS = @CFLAGS@
-+COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
-+LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
-+CCLD = $(CC)
-+LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(LDFLAGS) -o $@
- DIST_COMMON = README ChangeLog Makefile.am Makefile.in TODO
-
-
diff --git a/games/qgo/files/patch-qgo::src::wavfile.c b/games/qgo/files/patch-qgo::src::wavfile.c
deleted file mode 100644
index 958abb399585..000000000000
--- a/games/qgo/files/patch-qgo::src::wavfile.c
+++ /dev/null
@@ -1,28 +0,0 @@
---- qgo/src/wavfile.c.orig Mon Jun 23 23:57:08 2003
-+++ qgo/src/wavfile.c Fri Aug 20 23:10:57 2004
-@@ -53,7 +53,6 @@
- #include <unistd.h>
- #include <errno.h>
- #include <fcntl.h>
--#include <malloc.h>
- #include <string.h>
- #include <memory.h>
- #include <signal.h>
-@@ -61,7 +60,7 @@
- #include <sys/ipc.h>
- #include <sys/ioctl.h>
- #include <assert.h>
--#include <linux/soundcard.h>
-+#include <sys/soundcard.h>
-
-
- // stop
-@@ -133,7 +132,7 @@
- //static ErrFunc _v_erf; /* This module's error reporting function */
- static char emsg[2048];
-
--
-+static void _v_erf(const char *format,va_list ap);
-
- /*
- * Error reporting function for this source module:
diff --git a/games/qgo/files/patch-qgo::src::wavplay.c b/games/qgo/files/patch-qgo::src::wavplay.c
deleted file mode 100644
index a8a97afff099..000000000000
--- a/games/qgo/files/patch-qgo::src::wavplay.c
+++ /dev/null
@@ -1,16 +0,0 @@
---- qgo/src/wavplay.c.orig Tue Jun 24 06:57:09 2003
-+++ qgo/src/wavplay.c Mon Nov 3 00:50:02 2003
-@@ -55,12 +55,11 @@
- #include <stdio.h>
- #include <stdarg.h>
- #include <stdlib.h>
--#include <malloc.h>
- #include <string.h>
- #include <fcntl.h>
- #include <errno.h>
- #include <sys/stat.h>
--#include <linux/soundcard.h>
-+#include <sys/soundcard.h>
- #include "wavplay.h"
- //#include "server.h"
-
diff --git a/games/qgo/files/patch-qgo::src::mainwin.cpp b/games/qgo/files/patch-src::mainwin.cpp
index ec5047338faa..389c041e1d8c 100644
--- a/games/qgo/files/patch-qgo::src::mainwin.cpp
+++ b/games/qgo/files/patch-src::mainwin.cpp
@@ -1,6 +1,6 @@
---- qgo/src/mainwin.cpp.orig Sat Jun 19 07:38:43 2004
-+++ qgo/src/mainwin.cpp Sun Aug 22 15:55:59 2004
-@@ -1604,10 +1604,10 @@
+--- src/mainwin.cpp.orig Mon Nov 29 15:42:39 2004
++++ src/mainwin.cpp Tue Dec 14 19:37:16 2004
+@@ -1571,10 +1571,10 @@
//set the params of "who command"
if ((whoBox1->currentItem() >1) || (whoBox2->currentItem() >1))
{
diff --git a/games/qgo/files/patch-src::wavfile.c b/games/qgo/files/patch-src::wavfile.c
new file mode 100644
index 000000000000..e319f43557d3
--- /dev/null
+++ b/games/qgo/files/patch-src::wavfile.c
@@ -0,0 +1,60 @@
+--- src/wavfile.c.orig Sun Oct 31 08:36:45 2004
++++ src/wavfile.c Thu Dec 16 01:18:54 2004
+@@ -41,7 +41,7 @@
+ * wavplay project.
+ */
+
+-#ifdef __linux__
++#if defined(__linux__) || defined(__FreeBSD__)
+
+ static const char rcsid[] = "@(#)wavfile.c $Revision: 1.6 $";
+
+@@ -52,7 +52,9 @@
+ #include <unistd.h>
+ #include <errno.h>
+ #include <fcntl.h>
++#if defined(__linux__)
+ #include <malloc.h>
++#endif
+ #include <string.h>
+ #include <memory.h>
+ #include <signal.h>
+@@ -60,7 +62,12 @@
+ #include <sys/ipc.h>
+ #include <sys/ioctl.h>
+ #include <assert.h>
++#if defined(__linux__)
+ #include <linux/soundcard.h>
++#endif
++#if defined(__FreeBSD__)
++#include <sys/soundcard.h>
++#endif
+
+
+
+@@ -138,6 +145,12 @@
+ * Error reporting function for this source module:
+ */
+ static void
++_v_erf(const char *format,va_list ap) {
++ vsprintf(emsg,format,ap); /* Capture message into emsg[] */
++}
++
++
++static void
+ err(const char *format,...) {
+ va_list ap;
+ fprintf(stdout, "error : %s \n",format);
+@@ -146,12 +159,6 @@
+ va_start(ap,format);
+ _v_erf(format,ap); /* Use caller's supplied function */
+ va_end(ap);
+-}
+-
+-
+-static void
+-_v_erf(const char *format,va_list ap) {
+- vsprintf(emsg,format,ap); /* Capture message into emsg[] */
+ }
+
+
diff --git a/games/qgo/files/patch-src::wavplay.c b/games/qgo/files/patch-src::wavplay.c
new file mode 100644
index 000000000000..18f8e2ae5cc4
--- /dev/null
+++ b/games/qgo/files/patch-src::wavplay.c
@@ -0,0 +1,30 @@
+--- src/wavplay.c.orig Sun Oct 31 08:35:00 2004
++++ src/wavplay.c Tue Dec 14 19:32:31 2004
+@@ -54,19 +54,26 @@
+ *
+ */
+
+-#ifdef __linux__
++#if defined(__linux__) || defined(__FreeBSD__)
+
+ static const char rcsid[] = "@(#)recplay.c $Revision: 1.8 $";
+
+ #include <stdio.h>
+ #include <stdarg.h>
+ #include <stdlib.h>
++#if defined(__linux__)
+ #include <malloc.h>
++#endif
+ #include <string.h>
+ #include <fcntl.h>
+ #include <errno.h>
+ #include <sys/stat.h>
++#if defined(__linux__)
+ #include <linux/soundcard.h>
++#endif
++#if defined(__linux__)
++#include <sys/soundcard.h>
++#endif
+ #include "wavplay.h"
+ /*/#include "server.h"*/
+
diff --git a/games/qgo/pkg-plist b/games/qgo/pkg-plist
index 1b4ddbf97f85..9903549af735 100644
--- a/games/qgo/pkg-plist
+++ b/games/qgo/pkg-plist
@@ -2,6 +2,7 @@ bin/qgo
share/qGo/pics/Bowl.png
share/qGo/sounds/click.wav
share/qGo/sounds/connect.wav
+share/qGo/sounds/connect2.wav
share/qGo/sounds/enter.wav
share/qGo/sounds/gameend.wav
share/qGo/sounds/leave.wav
@@ -9,12 +10,15 @@ share/qGo/sounds/match.wav
share/qGo/sounds/pass.wav
share/qGo/sounds/say.wav
share/qGo/sounds/stone.wav
+share/qGo/sounds/stone2.wav
share/qGo/sounds/talk.wav
share/qGo/sounds/tictoc.wav
+share/qGo/translations/qgo_cz.qm
share/qGo/translations/qgo_de.qm
share/qGo/translations/qgo_fr.qm
share/qGo/translations/qgo_it.qm
share/qGo/translations/qgo_nl.qm
+share/qGo/translations/qgo_zh.qm
@dirrm share/qGo/translations
@dirrm share/qGo/sounds
@dirrm share/qGo/pics