aboutsummaryrefslogtreecommitdiff
path: root/games/qstat/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-07 19:21:30 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-07 19:21:30 +0000
commit515bb651d654428f0c64d9a55da81ddd45f95a8f (patch)
tree446cdb9ac4ed04d79df2e4eaaac52c3d97f5a07f /games/qstat/Makefile
parent790a7cb6fd2b70303f404e4b405658b51fd00f67 (diff)
Notes
Diffstat (limited to 'games/qstat/Makefile')
-rw-r--r--games/qstat/Makefile22
1 files changed, 17 insertions, 5 deletions
diff --git a/games/qstat/Makefile b/games/qstat/Makefile
index 4359f7093d4c..6d20c92aefea 100644
--- a/games/qstat/Makefile
+++ b/games/qstat/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= qstat
-PORTVERSION= 2.6
+PORTVERSION= 2.8
CATEGORIES= games net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,8 +14,17 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= pat@FreeBSD.org
COMMENT= A command line program to query game servers on the net
-do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/qstat ${PREFIX}/bin
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+
+post-extract:
+ @${MV} ${WRKSRC}/qstat.cfg ${WRKSRC}/qstat.cfg.default
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|\(qstat\.cfg\)|\1\.default|' \
+ ${WRKSRC}/Makefile.in
+
+post-install:
.if !defined(NOPORTDOCS)
@${ECHO_MSG} ""
@${ECHO_MSG} "Installing documents and templates in: \
@@ -23,8 +32,11 @@ do-install:
@${ECHO_MSG} ""
@${MKDIR} ${DOCSDIR}/info ${DOCSDIR}/template
@${INSTALL_DATA} ${WRKSRC}/qstatdoc.html ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/template/* ${DOCSDIR}/template
- @${INSTALL_DATA} ${WRKSRC}/info/* ${DOCSDIR}/info
+ @${INSTALL_DATA} ${WRKSRC}/template/*.html ${WRKSRC}/template/*.txt \
+ ${DOCSDIR}/template
+ @${INSTALL_DATA} ${WRKSRC}/info/*.txt ${DOCSDIR}/info
.endif
+ @[ -f ${PREFIX}/etc/qstat.cfg ] || \
+ ${CP} ${PREFIX}/etc/qstat.cfg.default ${PREFIX}/etc/qstat.cfg
.include <bsd.port.mk>