aboutsummaryrefslogtreecommitdiff
path: root/games/quackle
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-04-25 17:22:39 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-04-25 17:22:39 +0000
commitca36574a48d019c5c22af20d853a994fad32072a (patch)
tree316681ec6dd7ccab4270fdf20c471ec7683af1e8 /games/quackle
parentfbae377ae8287ff38b979e0bf257c26932991874 (diff)
downloadports-ca36574a48d019c5c22af20d853a994fad32072a.tar.gz
ports-ca36574a48d019c5c22af20d853a994fad32072a.zip
Notes
Diffstat (limited to 'games/quackle')
-rw-r--r--games/quackle/Makefile34
-rw-r--r--games/quackle/distinfo3
-rw-r--r--games/quackle/files/patch-fixedstring.h10
-rw-r--r--games/quackle/pkg-descr9
-rw-r--r--games/quackle/pkg-plist47
5 files changed, 103 insertions, 0 deletions
diff --git a/games/quackle/Makefile b/games/quackle/Makefile
new file mode 100644
index 000000000000..9d53b4071c78
--- /dev/null
+++ b/games/quackle/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: quackle
+# Date created: 15 Feb 2008
+# Whom: shoemaker@bluebottle.com (Jonathan Shoemaker)
+#
+# $FreeBSD$
+#
+
+PORTNAME= quackle
+PORTVERSION= 0.95
+CATEGORIES= games
+MASTER_SITES= http://web.mit.edu/jasonkb/www/quackle/downloads/${PORTNAME}-${PORTVERSION}/
+DISTFILES= ${PORTNAME}-${PORTVERSION}-source.tar.gz
+
+MAINTAINER= shoemaker@bluebottle.com
+COMMENT= A scrabble-like word game utilizing qt4
+
+USE_SCONS= yes
+USE_QT_VER= 4
+USE_GMAKE= yes
+
+pre-patch:
+ @${REINPLACE_CMD} -e 's|if (QFile::exists("data"))|if (QFile::exists("${PREFIX}/lib/quackle"))|' ${WRKSRC}/quacker/settings.cpp
+ @${REINPLACE_CMD} -e 's|QUACKLE_DATAMANAGER->setDataDirectory("data");|QUACKLE_DATAMANAGER->setDataDirectory("${PREFIX}/lib/quackle");|' ${WRKSRC}/quacker/settings.cpp
+
+post-build:
+ @(cd ${WRKSRC}/quackleio && qmake-qt4 -unix -spec freebsd-g++ -o Makefile quackleio.pro && ${GMAKE} && cd ${WRKSRC}/quacker && qmake-qt4 -unix -spec freebsd-g++ -o Makefile quacker.pro && ${GMAKE})
+
+do-install:
+ @(${MKDIR} -m 555 ${PREFIX}/lib/quackle; cd ${WRKSRC}/data && ${PAX} -rw ./ ${PREFIX}/lib/quackle)
+ @${FIND} ${PREFIX}/lib/quackle -type directory -exec ${CHMOD} 555 {} \;
+ @${FIND} ${PREFIX}/lib/quackle -type file -exec ${CHMOD} 444 {} \;
+ @${INSTALL} -m 0555 ${WRKSRC}/quacker/quacker ${PREFIX}/bin/quackle
+
+.include <bsd.port.mk>
diff --git a/games/quackle/distinfo b/games/quackle/distinfo
new file mode 100644
index 000000000000..3cfe2b92d8dc
--- /dev/null
+++ b/games/quackle/distinfo
@@ -0,0 +1,3 @@
+MD5 (quackle-0.95-source.tar.gz) = a9dafb5823a96a70971741f030914910
+SHA256 (quackle-0.95-source.tar.gz) = 21544c41f465818f7c33a514eae3d725108b2992532b6db6ded269aa69de3e4c
+SIZE (quackle-0.95-source.tar.gz) = 49800462
diff --git a/games/quackle/files/patch-fixedstring.h b/games/quackle/files/patch-fixedstring.h
new file mode 100644
index 000000000000..12c5c5faa76c
--- /dev/null
+++ b/games/quackle/files/patch-fixedstring.h
@@ -0,0 +1,10 @@
+--- fixedstring.h.orig 2008-04-15 20:02:38.000000000 -0600
++++ fixedstring.h 2008-04-15 20:02:55.000000000 -0600
+@@ -18,6 +18,7 @@
+ * 02110-1301 USA
+ */
+
++#include <cassert>
+ #ifndef QUACKLE_FIXEDSTRING_H
+ #define QUACKLE_FIXEDSTRING_H
+
diff --git a/games/quackle/pkg-descr b/games/quackle/pkg-descr
new file mode 100644
index 000000000000..f5268b1bfce8
--- /dev/null
+++ b/games/quackle/pkg-descr
@@ -0,0 +1,9 @@
+Free crossword game artificial intelligence and analysis tool that
+rivals the best players in the world!
+
+You will need to set up a game board with the bonus squares scrabble has.
+See http://web.mit.edu/jasonkb/www/quackle/example_report.html for a
+reminder of which squares are which, and recreate this board to have
+exactly the same rules as Scrabble (TM)
+
+WWW: http://web.mit.edu/jasonkb/www/quackle/
diff --git a/games/quackle/pkg-plist b/games/quackle/pkg-plist
new file mode 100644
index 000000000000..254737f02ab0
--- /dev/null
+++ b/games/quackle/pkg-plist
@@ -0,0 +1,47 @@
+bin/quackle
+lib/quackle/alphabets/english.quackle_alphabet
+lib/quackle/alphabets/english_super.quackle_alphabet
+lib/quackle/alphabets/english_wild.quackle_alphabet
+lib/quackle/alphabets/french.quackle_alphabet
+lib/quackle/alphabets/korean.quackle_alphabet
+lib/quackle/alphabets/russian.quackle_alphabet
+lib/quackle/alphabets/tuvan.quackle_alphabet
+lib/quackle/lexica/cswfeb07.gaddag
+lib/quackle/lexica/korean.dawg
+lib/quackle/lexica/ods4.gaddag
+lib/quackle/lexica/russian.dawg
+lib/quackle/lexica/sowpods.gaddag
+lib/quackle/lexica/tuvan.dawg
+lib/quackle/lexica/twl06.gaddag
+lib/quackle/lexica/twl06_wild.dawg
+lib/quackle/lexica/twl98.dawg
+lib/quackle/strategy/cswfeb07/superleaves
+lib/quackle/strategy/korean/superleaves
+lib/quackle/strategy/korean/syn2
+lib/quackle/strategy/korean/worths
+lib/quackle/strategy/ods4/superleaves
+lib/quackle/strategy/ods4/worths
+lib/quackle/strategy/russian/superleaves
+lib/quackle/strategy/russian/syn2
+lib/quackle/strategy/russian/worths
+lib/quackle/strategy/tuvan/superleaves
+lib/quackle/strategy/tuvan/syn2
+lib/quackle/strategy/tuvan/worths
+lib/quackle/strategy/twl06/bogowin
+lib/quackle/strategy/twl06/superleaves
+lib/quackle/strategy/twl06/syn2
+lib/quackle/strategy/twl06/vcplace
+lib/quackle/strategy/twl06/worths
+lib/quackle/strategy/twl98/worths
+@dirrm lib/quackle/alphabets
+@dirrm lib/quackle/lexica
+@dirrm lib/quackle/strategy/cswfeb07/
+@dirrm lib/quackle/strategy/korean/
+@dirrm lib/quackle/strategy/ods4/
+@dirrm lib/quackle/strategy/russian/
+@dirrm lib/quackle/strategy/sowpods/
+@dirrm lib/quackle/strategy/tuvan/
+@dirrm lib/quackle/strategy/twl06/
+@dirrm lib/quackle/strategy/twl98/
+@dirrm lib/quackle/strategy/
+@dirrm lib/quackle