aboutsummaryrefslogtreecommitdiff
path: root/games/quackle
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-07-18 12:42:45 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-07-18 12:42:45 +0000
commite3e8237db5425272eee33e3f4b5ccfa43ecb16dd (patch)
tree417a119e574f1cd3667b141280e1fbcca6a1b881 /games/quackle
parent40bfde3f15ed5efea4b5d37aaf41e7e429b2df62 (diff)
downloadports-e3e8237db5425272eee33e3f4b5ccfa43ecb16dd.tar.gz
ports-e3e8237db5425272eee33e3f4b5ccfa43ecb16dd.zip
Notes
Diffstat (limited to 'games/quackle')
-rw-r--r--games/quackle/Makefile16
-rw-r--r--games/quackle/pkg-plist92
2 files changed, 54 insertions, 54 deletions
diff --git a/games/quackle/Makefile b/games/quackle/Makefile
index 14b8c23a0a26..dac6abda0dde 100644
--- a/games/quackle/Makefile
+++ b/games/quackle/Makefile
@@ -7,7 +7,7 @@
PORTNAME= quackle
PORTVERSION= 0.95
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= http://web.mit.edu/jasonkb/www/quackle/downloads/${PORTNAME}-${PORTVERSION}/
DISTFILES= ${PORTNAME}-${PORTVERSION}-source.tar.gz
@@ -17,19 +17,19 @@ COMMENT= A scrabble-like word game utilizing qt4
USE_SCONS= yes
USE_QT_VER= 4
+QT_COMPONENTS= qmake_build moc_build gui
USE_GMAKE= yes
+QMAKE_ARGS= -unix -spec ${QMAKESPEC}
pre-patch:
- @${REINPLACE_CMD} -e 's|if (QFile::exists("data"))|if (QFile::exists("${PREFIX}/lib/quackle"))|' ${WRKSRC}/quacker/settings.cpp
- @${REINPLACE_CMD} -e 's|QUACKLE_DATAMANAGER->setDataDirectory("data");|QUACKLE_DATAMANAGER->setDataDirectory("${PREFIX}/lib/quackle");|' ${WRKSRC}/quacker/settings.cpp
+ @${REINPLACE_CMD} -e 's|if (QFile::exists("data"))|if (QFile::exists("${DATADIR}"))|' ${WRKSRC}/quacker/settings.cpp
+ @${REINPLACE_CMD} -e 's|QUACKLE_DATAMANAGER->setDataDirectory("data");|QUACKLE_DATAMANAGER->setDataDirectory("${DATADIR}");|' ${WRKSRC}/quacker/settings.cpp
post-build:
- @(cd ${WRKSRC}/quackleio && qmake-qt4 -unix -spec freebsd-g++ -o Makefile quackleio.pro && ${GMAKE} && cd ${WRKSRC}/quacker && qmake-qt4 -unix -spec freebsd-g++ -o Makefile quacker.pro && ${GMAKE})
+ @(cd ${WRKSRC}/quackleio && ${QMAKE} ${QMAKE_ARGS} -o Makefile quackleio.pro && ${SETENV} ${MAKE_ENV} ${GMAKE} && cd ${WRKSRC}/quacker && ${QMAKE} ${QMAKE_ARGS} -o Makefile quacker.pro && ${SETENV} ${MAKE_ENV} ${GMAKE})
do-install:
- @(${MKDIR} -m 555 ${PREFIX}/lib/quackle; cd ${WRKSRC}/data && ${PAX} -rw ./ ${PREFIX}/lib/quackle)
- @${FIND} ${PREFIX}/lib/quackle -type directory -exec ${CHMOD} 555 {} \;
- @${FIND} ${PREFIX}/lib/quackle -type file -exec ${CHMOD} 444 {} \;
- @${INSTALL} -m 0555 ${WRKSRC}/quacker/quacker ${PREFIX}/bin/quackle
+ @${INSTALL_PROGRAM} ${WRKSRC}/quacker/quacker ${PREFIX}/bin/quackle
+ @(cd ${WRKSRC}/data && ${COPYTREE_SHARE} . ${DATADIR})
.include <bsd.port.mk>
diff --git a/games/quackle/pkg-plist b/games/quackle/pkg-plist
index 254737f02ab0..2a0ba3972858 100644
--- a/games/quackle/pkg-plist
+++ b/games/quackle/pkg-plist
@@ -1,47 +1,47 @@
bin/quackle
-lib/quackle/alphabets/english.quackle_alphabet
-lib/quackle/alphabets/english_super.quackle_alphabet
-lib/quackle/alphabets/english_wild.quackle_alphabet
-lib/quackle/alphabets/french.quackle_alphabet
-lib/quackle/alphabets/korean.quackle_alphabet
-lib/quackle/alphabets/russian.quackle_alphabet
-lib/quackle/alphabets/tuvan.quackle_alphabet
-lib/quackle/lexica/cswfeb07.gaddag
-lib/quackle/lexica/korean.dawg
-lib/quackle/lexica/ods4.gaddag
-lib/quackle/lexica/russian.dawg
-lib/quackle/lexica/sowpods.gaddag
-lib/quackle/lexica/tuvan.dawg
-lib/quackle/lexica/twl06.gaddag
-lib/quackle/lexica/twl06_wild.dawg
-lib/quackle/lexica/twl98.dawg
-lib/quackle/strategy/cswfeb07/superleaves
-lib/quackle/strategy/korean/superleaves
-lib/quackle/strategy/korean/syn2
-lib/quackle/strategy/korean/worths
-lib/quackle/strategy/ods4/superleaves
-lib/quackle/strategy/ods4/worths
-lib/quackle/strategy/russian/superleaves
-lib/quackle/strategy/russian/syn2
-lib/quackle/strategy/russian/worths
-lib/quackle/strategy/tuvan/superleaves
-lib/quackle/strategy/tuvan/syn2
-lib/quackle/strategy/tuvan/worths
-lib/quackle/strategy/twl06/bogowin
-lib/quackle/strategy/twl06/superleaves
-lib/quackle/strategy/twl06/syn2
-lib/quackle/strategy/twl06/vcplace
-lib/quackle/strategy/twl06/worths
-lib/quackle/strategy/twl98/worths
-@dirrm lib/quackle/alphabets
-@dirrm lib/quackle/lexica
-@dirrm lib/quackle/strategy/cswfeb07/
-@dirrm lib/quackle/strategy/korean/
-@dirrm lib/quackle/strategy/ods4/
-@dirrm lib/quackle/strategy/russian/
-@dirrm lib/quackle/strategy/sowpods/
-@dirrm lib/quackle/strategy/tuvan/
-@dirrm lib/quackle/strategy/twl06/
-@dirrm lib/quackle/strategy/twl98/
-@dirrm lib/quackle/strategy/
-@dirrm lib/quackle
+%%DATADIR%%/alphabets/english.quackle_alphabet
+%%DATADIR%%/alphabets/english_super.quackle_alphabet
+%%DATADIR%%/alphabets/english_wild.quackle_alphabet
+%%DATADIR%%/alphabets/french.quackle_alphabet
+%%DATADIR%%/alphabets/korean.quackle_alphabet
+%%DATADIR%%/alphabets/russian.quackle_alphabet
+%%DATADIR%%/alphabets/tuvan.quackle_alphabet
+%%DATADIR%%/lexica/cswfeb07.gaddag
+%%DATADIR%%/lexica/korean.dawg
+%%DATADIR%%/lexica/ods4.gaddag
+%%DATADIR%%/lexica/russian.dawg
+%%DATADIR%%/lexica/sowpods.gaddag
+%%DATADIR%%/lexica/tuvan.dawg
+%%DATADIR%%/lexica/twl06.gaddag
+%%DATADIR%%/lexica/twl06_wild.dawg
+%%DATADIR%%/lexica/twl98.dawg
+%%DATADIR%%/strategy/cswfeb07/superleaves
+%%DATADIR%%/strategy/korean/superleaves
+%%DATADIR%%/strategy/korean/syn2
+%%DATADIR%%/strategy/korean/worths
+%%DATADIR%%/strategy/ods4/superleaves
+%%DATADIR%%/strategy/ods4/worths
+%%DATADIR%%/strategy/russian/superleaves
+%%DATADIR%%/strategy/russian/syn2
+%%DATADIR%%/strategy/russian/worths
+%%DATADIR%%/strategy/tuvan/superleaves
+%%DATADIR%%/strategy/tuvan/syn2
+%%DATADIR%%/strategy/tuvan/worths
+%%DATADIR%%/strategy/twl06/bogowin
+%%DATADIR%%/strategy/twl06/superleaves
+%%DATADIR%%/strategy/twl06/syn2
+%%DATADIR%%/strategy/twl06/vcplace
+%%DATADIR%%/strategy/twl06/worths
+%%DATADIR%%/strategy/twl98/worths
+@dirrm %%DATADIR%%/alphabets
+@dirrm %%DATADIR%%/lexica
+@dirrm %%DATADIR%%/strategy/cswfeb07/
+@dirrm %%DATADIR%%/strategy/korean/
+@dirrm %%DATADIR%%/strategy/ods4/
+@dirrm %%DATADIR%%/strategy/russian/
+@dirrm %%DATADIR%%/strategy/sowpods/
+@dirrm %%DATADIR%%/strategy/tuvan/
+@dirrm %%DATADIR%%/strategy/twl06/
+@dirrm %%DATADIR%%/strategy/twl98/
+@dirrm %%DATADIR%%/strategy/
+@dirrm %%DATADIR%%