aboutsummaryrefslogtreecommitdiff
path: root/games/quake-source
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-03-17 10:11:03 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-03-17 10:11:03 +0000
commit8e236553e72b37154092708a09b20e72dd5406ef (patch)
tree5345e519b0c18cc1ea512fff7723f1e8bef79338 /games/quake-source
parent301100dd5b3ee21e70ab2414f5cc6161fae056f0 (diff)
downloadports-8e236553e72b37154092708a09b20e72dd5406ef.tar.gz
ports-8e236553e72b37154092708a09b20e72dd5406ef.zip
Notes
Diffstat (limited to 'games/quake-source')
-rw-r--r--games/quake-source/Makefile45
-rw-r--r--games/quake-source/files/patch-send_v101qc_progs.src8
-rw-r--r--games/quake-source/pkg-descr7
3 files changed, 26 insertions, 34 deletions
diff --git a/games/quake-source/Makefile b/games/quake-source/Makefile
index 7839f5ea2931..519cda1afa60 100644
--- a/games/quake-source/Makefile
+++ b/games/quake-source/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: quake-source
-# Date created: 15 Sep 2005
-# Whom: Alejandro Pulver <alejandro@varnet.biz>
-#
+# Created by: Alejandro Pulver <alejandro@varnet.biz>
# $FreeBSD$
-#
PORTNAME= source
PORTVERSION= 1.01
@@ -15,45 +11,50 @@ PKGNAMEPREFIX= quake-
DISTNAME= qcc
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
-MAINTAINER= danfe@FreeBSD.org
-COMMENT= Quake and QuakeWorld source
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Quake game source code
NO_BUILD= yes
NO_WRKSUBDIR= yes
-OPTIONS= QUAKEWORLD "Install QuakeWorld source" on
-
LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}
-.include "Makefile.include"
+OPTIONS_DEFINE= QUAKEWORLD
+OPTIONS_DEFAULT= QUAKEWORLD
-.include <bsd.port.pre.mk>
+QUAKEWORLD_DESC= Install QuakeWorld game source
-.if !defined(WITHOUT_QUAKEWORLD)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MQUAKEWORLD}
MASTER_SITES+= ${MASTER_SITE_IDSOFTWARE:S|$|quakeworld/unix/:qw|}
DISTFILES+= qwsv-2.30-glibc-i386-unknown-linux2.0${EXTRACT_SUFX}:qw
+COMMENT:= ${COMMENT:S/Quake/& and QuakeWorld/}
PLIST_SUB+= QUAKEWORLD=""
.else
PLIST_SUB+= QUAKEWORLD="@comment "
.endif
pre-patch:
+# CRLF -> LF conversion (XXX why not USE_DOS2UNIX?)
@${FIND} ${WRKSRC} -type f | ${XARGS} ${FILE} | \
- ${GREP} 'CRLF' | ${SED} -e 's/:.*//' | \
- ${XARGS} ${REINPLACE_CMD} -i "" -e "s/`${PRINTF} '\r'`$$//"
+ ${GREP} 'CRLF' | ${SED} -e 's/:.*//' | ${XARGS} \
+ ${REINPLACE_CMD} -i "" -e "s/`${PRINTF} '\r'`$$//"
post-patch:
- @${RM} ${WRKSRC}/send/v101qc/progs.src.orig
+ @${REINPLACE_CMD} -e 's,^\.\.,.,' ${WRKSRC}/send/v101qc/progs.src
+ @${RM} ${WRKSRC}/send/v101qc/progs.src.bak
do-install:
- ${MKDIR} ${DATADIR}
- ${CP} -R ${WRKSRC}/send/v101qc ${DATADIR}
-.if !defined(WITHOUT_QUAKEWORLD)
- ${MKDIR} ${DATADIR}/qw
-. for f in *.h *.qc *.src
+ @${MKDIR} ${DATADIR}
+ ${CP} -a ${WRKSRC}/send/v101qc ${DATADIR}
+.if ${PORT_OPTIONS:MQUAKEWORLD}
+ @${MKDIR} ${DATADIR}/qw
+. for f in *.h *.qc *.src
@${REINPLACE_CMD} -e "s|`${ECHO_CMD} -e '\r'`$$||" ${WRKSRC}/qw/${f}
${INSTALL_DATA} ${WRKSRC}/qw/${f} ${DATADIR}/qw
-. endfor
+. endfor
.endif
-.include <bsd.port.post.mk>
+.include "Makefile.include"
+.include <bsd.port.mk>
diff --git a/games/quake-source/files/patch-send_v101qc_progs.src b/games/quake-source/files/patch-send_v101qc_progs.src
deleted file mode 100644
index 7457b20d96df..000000000000
--- a/games/quake-source/files/patch-send_v101qc_progs.src
+++ /dev/null
@@ -1,8 +0,0 @@
---- send/v101qc/progs.src.orig Thu Jul 25 03:51:28 1996
-+++ send/v101qc/progs.src Thu Dec 8 17:57:20 2005
-@@ -1,4 +1,4 @@
--../progs.dat
-+./progs.dat
-
- defs.qc
- subs.qc
diff --git a/games/quake-source/pkg-descr b/games/quake-source/pkg-descr
index cb51069ce818..949fe54cb6c6 100644
--- a/games/quake-source/pkg-descr
+++ b/games/quake-source/pkg-descr
@@ -1,6 +1,5 @@
-Quake and QuakeWorld sources.
-
This port installs the Quake (and optionally QuakeWorld) game sources (in
-QuakeC) to allow the development of Quake mods.
+QuakeC) to allow the development of Quake modifications (mods).
-Note that to compile it you need a QuakeC compiler (there are many in ports).
+Note that to compile it you need a QuakeC compiler (several are available
+in the ports).