aboutsummaryrefslogtreecommitdiff
path: root/games/quake2-lights/Makefile
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-12-26 04:21:15 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-12-26 04:21:15 +0000
commit146bf7bd03f3c56a1c54b9ab5e2e48f466dc82bc (patch)
tree1832646e3ceb99f41ccd357b8b0d3f31636033ed /games/quake2-lights/Makefile
parentef424d7ea49081dfe9e4fd5e263b5251796ca2cb (diff)
downloadports-146bf7bd03f3c56a1c54b9ab5e2e48f466dc82bc.tar.gz
ports-146bf7bd03f3c56a1c54b9ab5e2e48f466dc82bc.zip
Notes
Diffstat (limited to 'games/quake2-lights/Makefile')
-rw-r--r--games/quake2-lights/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/games/quake2-lights/Makefile b/games/quake2-lights/Makefile
new file mode 100644
index 000000000000..ee0fd170571a
--- /dev/null
+++ b/games/quake2-lights/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: quake2-lights
+# Date created: 2006-12-24
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= lights
+PORTVERSION= 1
+CATEGORIES= games
+MASTER_SITES= http://qudos.quakedev.com/linux/quake2/mods/
+PKGNAMEPREFIX= ${Q2PKGNAMEPREFIX}
+DISTNAME= Lights.v${PORTVERSION}.Linux
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ Lights-Bots${EXTRACT_SUFX}
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= Lights modification for Quake II
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+NO_WRKSUBDIR= yes
+BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}/src
+ALL_TARGET= release
+
+DOCSDIR= ${PREFIX}/share/doc/${LATEST_LINK}
+
+.include "${.CURDIR}/../quake2-data/Makefile.include"
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/__linux__/__unix__/' ${BUILD_WRKSRC}/q_shared.c
+ @${REINPLACE_CMD} -e 's/<malloc\.h>/<stdlib.h>/' \
+ ${BUILD_WRKSRC}/ace/acebot_compress.c
+
+do-install:
+ ${MKDIR} ${Q2DIR}/${PORTNAME}
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/release/lights/game.so \
+ ${Q2DIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/lights/pak99.pak ${Q2DIR}/${PORTNAME}
+ cd ${WRKSRC}/quake2/lights && \
+ ${CP} -R autoexec.cfg demos pics sprites ${Q2DIR}/${PORTNAME}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/quake2/lights/Readme. ${DOCSDIR}/readme.txt
+.endif
+
+.include <bsd.port.post.mk>