aboutsummaryrefslogtreecommitdiff
path: root/games/quake2-lights
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-06-06 15:39:00 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-06-06 15:39:00 +0000
commitc421264d034dbc0e2a0e809f755fa7d5ba9da899 (patch)
tree40c6fcc899e8c00eb868d609f3bdf8377e24e000 /games/quake2-lights
parent8c3cb83adcba7a6e5458efd4da25e7668190ac40 (diff)
downloadports-c421264d034dbc0e2a0e809f755fa7d5ba9da899.tar.gz
ports-c421264d034dbc0e2a0e809f755fa7d5ba9da899.zip
Notes
Diffstat (limited to 'games/quake2-lights')
-rw-r--r--games/quake2-lights/Makefile33
-rw-r--r--games/quake2-lights/files/patch-lights-src-Makefile (renamed from games/quake2-lights/files/patch-lights__src__Makefile)10
-rw-r--r--games/quake2-lights/files/patch-lights-src-g_items.c (renamed from games/quake2-lights/files/patch-lights__src__g_items.c)0
-rw-r--r--games/quake2-lights/pkg-descr12
4 files changed, 30 insertions, 25 deletions
diff --git a/games/quake2-lights/Makefile b/games/quake2-lights/Makefile
index b44fd8177367..f2f2acda133e 100644
--- a/games/quake2-lights/Makefile
+++ b/games/quake2-lights/Makefile
@@ -1,12 +1,11 @@
-# Created by: alepulver
+# Created by: Alejandro Pulver <alepulver@FreeBSD.org>
# $FreeBSD$
PORTNAME= lights
PORTVERSION= 1
CATEGORIES= games
-MASTER_SITES= http://qudos.quakedev.com/linux/quake2/mods/:data \
- ${MASTER_SITE_LOCAL:S|$|:src|}
-MASTER_SITE_SUBDIR= alepulver/:src
+MASTER_SITES= http://bfeared.com/library/quake/archive/quakedev/qudos/quake2/mods/:data \
+ LOCAL/alepulver/:src
PKGNAMEPREFIX= ${Q2PKGNAMEPREFIX}
DISTNAME= Lights.v${PORTVERSION}.Linux
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:data,src \
@@ -22,26 +21,22 @@ ALL_TARGET= release
DOCSDIR= ${PREFIX}/share/doc/${LATEST_LINK}
-NO_STAGE= yes
-.include "${.CURDIR}/../quake2-data/Makefile.include"
-
-.include <bsd.port.pre.mk>
-
post-patch:
@${REINPLACE_CMD} -e 's/__linux__/__unix__/' ${BUILD_WRKSRC}/q_shared.c
@${REINPLACE_CMD} -e 's/<malloc\.h>/<stdlib.h>/' \
${BUILD_WRKSRC}/ace/acebot_compress.c
do-install:
- ${MKDIR} ${Q2DIR}/${PORTNAME}
+ @${MKDIR} ${STAGEDIR}${Q2DIR}/${PORTNAME}
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/release/lights/game.so \
- ${Q2DIR}/${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/lights/pak99.pak ${Q2DIR}/${PORTNAME}
- cd ${WRKSRC}/quake2/lights && \
- ${CP} -R autoexec.cfg demos pics sprites ${Q2DIR}/${PORTNAME}
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/quake2/lights/Readme. ${DOCSDIR}/readme.txt
-.endif
+ ${STAGEDIR}${Q2DIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/lights/pak99.pak \
+ ${STAGEDIR}${Q2DIR}/${PORTNAME}
+ cd ${WRKSRC}/quake2/lights && ${CP} -a autoexec.cfg demos pics \
+ sprites ${STAGEDIR}${Q2DIR}/${PORTNAME}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/quake2/lights/Readme. \
+ ${STAGEDIR}${DOCSDIR}/readme.txt
-.include <bsd.port.post.mk>
+.include "${.CURDIR}/../quake2-data/Makefile.include"
+.include <bsd.port.mk>
diff --git a/games/quake2-lights/files/patch-lights__src__Makefile b/games/quake2-lights/files/patch-lights-src-Makefile
index 6b3b3435f2a4..a291df7fe9a2 100644
--- a/games/quake2-lights/files/patch-lights__src__Makefile
+++ b/games/quake2-lights/files/patch-lights-src-Makefile
@@ -28,7 +28,7 @@
- -falign-jumps=2 -falign-functions=2
+ -fexpensive-optimizations
+ifeq ($(ARCH),i386)
-+RELEASE_CFLAGS+=-falign-loops=2 -falign-jumps=2 -falign-functions=2
++RELEASE_CFLAGS+=-falign-functions=2
+endif
DEBUG_CFLAGS=$(BASE_CFLAGS) -g
-LDFLAGS=-ldl -lm
@@ -36,7 +36,7 @@
SHLIBEXT=so
-@@ -31,7 +23,7 @@
+@@ -31,7 +23,7 @@ SHLIBLDFLAGS=-shared
DO_CC=$(CC) $(CFLAGS) -o $@ -c $<
DO_SHLIB_CC=$(CC) $(CFLAGS) $(SHLIBCFLAGS) -o $@ -c $<
@@ -45,7 +45,7 @@
all:
@echo
-@@ -43,11 +35,11 @@
+@@ -43,11 +35,11 @@ all:
debug:
@-mkdir -p $(BUILD_DEBUG_DIR)/lights/nav
@@ -59,7 +59,7 @@
targets: $(TARGETS)
-@@ -116,7 +108,7 @@
+@@ -116,7 +108,7 @@ LIGHTS_OBJS = \
$(BUILDDIR)/scanner.o \
$(BUILDDIR)/q_shared.o
@@ -68,7 +68,7 @@
$(CC) $(CFLAGS) $(SHLIBLDFLAGS) -o $@ $(LIGHTS_OBJS)
$(BUILDDIR)/acebot_ai.o : ace/acebot_ai.c
-@@ -310,10 +302,10 @@
+@@ -310,10 +302,10 @@ $(BUILDDIR)/q_shared.o : q_shared.c
clean: clean-debug clean-release
clean-debug:
diff --git a/games/quake2-lights/files/patch-lights__src__g_items.c b/games/quake2-lights/files/patch-lights-src-g_items.c
index 0c3da62dac16..0c3da62dac16 100644
--- a/games/quake2-lights/files/patch-lights__src__g_items.c
+++ b/games/quake2-lights/files/patch-lights-src-g_items.c
diff --git a/games/quake2-lights/pkg-descr b/games/quake2-lights/pkg-descr
index 2b6da8c27ac9..9dacadcbc635 100644
--- a/games/quake2-lights/pkg-descr
+++ b/games/quake2-lights/pkg-descr
@@ -1 +1,11 @@
-Lights modification for Quake II.
+This is a modification for Quake II which adds lights and lots of effects
+for the weapons shots.
+
+This mod is intended to play it with Quake2Max supported binaries because
+the lights and effects are better saw compared to original Quake2 binaries.
+
+There are already a lot of new commands, scanner, flashlight, decoys,
+defense laser, chasecam, hook, etc. Some keys in the autoexec.cfg are set
+by default.
+
+Single player game is also playable with this mod.