aboutsummaryrefslogtreecommitdiff
path: root/games/quake2-matrix/Makefile
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-12-26 04:23:35 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-12-26 04:23:35 +0000
commitebc1071c88e5eecb86c5762aba725c6d17f77304 (patch)
tree76f0e158f292fd7d76c093ddb74696f2b6faa0ad /games/quake2-matrix/Makefile
parent146bf7bd03f3c56a1c54b9ab5e2e48f466dc82bc (diff)
downloadports-ebc1071c88e5eecb86c5762aba725c6d17f77304.tar.gz
ports-ebc1071c88e5eecb86c5762aba725c6d17f77304.zip
Notes
Diffstat (limited to 'games/quake2-matrix/Makefile')
-rw-r--r--games/quake2-matrix/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/games/quake2-matrix/Makefile b/games/quake2-matrix/Makefile
new file mode 100644
index 000000000000..8bb78bdaa146
--- /dev/null
+++ b/games/quake2-matrix/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: quake2-matrix
+# Date created: 2006-12-24
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= matrix
+PORTVERSION= 1
+CATEGORIES= games
+MASTER_SITES= http://qudos.quakedev.com/linux/quake2/mods/
+PKGNAMEPREFIX= ${Q2PKGNAMEPREFIX}
+DISTNAME= Matrix-v${PORTVERSION}.fixed.Linux
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= Matrix modification for Quake II
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+BUILD_WRKSRC= ${WRKSRC}/MatrixFixSource
+ALL_TARGET= release
+
+DOCSDIR= ${PREFIX}/share/doc/${LATEST_LINK}
+
+.include "${.CURDIR}/../quake2-data/Makefile.include"
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/__linux__/__unix__/' \
+ ${BUILD_WRKSRC}/q_shared.[ch]
+
+do-install:
+ ${MKDIR} ${Q2DIR}/${PORTNAME}
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/release/matrix/game.so \
+ ${Q2DIR}/${PORTNAME}
+ cd ${WRKSRC} && ${INSTALL_DATA} *.cfg *.ini *.pak ${Q2DIR}/${PORTNAME}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>