aboutsummaryrefslogtreecommitdiff
path: root/games/quake2-rogue/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-03-17 13:30:38 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-03-17 13:30:38 +0000
commit2cbb736eaa63eb58932fa88b2b87fb6325c77426 (patch)
treef8307bf49a3c4efaf5a07c2b50b650cdc31e5897 /games/quake2-rogue/Makefile
parentad3fcfd5ec0e6dd937f1992c9e727d97556103fd (diff)
downloadports-2cbb736eaa63eb58932fa88b2b87fb6325c77426.tar.gz
ports-2cbb736eaa63eb58932fa88b2b87fb6325c77426.zip
Notes
Diffstat (limited to 'games/quake2-rogue/Makefile')
-rw-r--r--games/quake2-rogue/Makefile27
1 files changed, 8 insertions, 19 deletions
diff --git a/games/quake2-rogue/Makefile b/games/quake2-rogue/Makefile
index 6f735af1f554..c7853fa4daab 100644
--- a/games/quake2-rogue/Makefile
+++ b/games/quake2-rogue/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: quake2-rogue
-# Date created: 26 Jul 2006
-# Whom: alepulver
-#
+# Created by: Alejandro Pulver <alepulver@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= rogue
PORTVERSION= 3.20
@@ -15,36 +11,28 @@ DISTNAME= ${PORTNAME}src${PORTVERSION:S/.//}
EXTRACT_SUFX= .shar.Z
MAINTAINER= danfe@FreeBSD.org
-COMMENT= Quake II Ground Zero (Rogue) Mission Pack
+COMMENT= Quake II: Ground Zero (Rogue) official mission pack
NO_WRKSUBDIR= yes
-
-LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}
+SUB_FILES= pkg-message
PLIST_FILES= %%Q2DIR%%/${PORTNAME}/game.so
PLIST_DIRS= %%Q2DIR%%/${PORTNAME}
-SUB_FILES= pkg-message
-
-.include "${.CURDIR}/../quake2-data/Makefile.include"
-
-.include <bsd.port.pre.mk>
-
do-extract:
@${MKDIR} ${WRKDIR}
- @cd ${WRKDIR} && \
- uncompress -c ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} | \
+ @cd ${WRKDIR} && uncompress -c ${DISTDIR}/${DISTFILES} | \
${TAIL} +454 | ${SH}
post-extract:
@${CP} ${FILESDIR}/${MAKEFILE} ${WRKSRC}
post-patch:
- @${REINPLACE_CMD} -e '/#include <nan.h>/d' ${WRKSRC}/g_local.h
+ @${REINPLACE_CMD} -e '/#include <nan\.h>/d' ${WRKSRC}/g_local.h
@${REINPLACE_CMD} -e 's/__linux__/__unix__/' ${WRKSRC}/q_shared.[ch]
do-install:
- ${MKDIR} ${Q2DIR}/${PORTNAME}
+ @${MKDIR} ${Q2DIR}/${PORTNAME}
${INSTALL_PROGRAM} ${WRKSRC}/game.so ${Q2DIR}/${PORTNAME}
post-install:
@@ -52,4 +40,5 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO_CMD}
-.include <bsd.port.post.mk>
+.include "${.CURDIR}/../quake2-data/Makefile.include"
+.include <bsd.port.mk>