aboutsummaryrefslogtreecommitdiff
path: root/games/quake2forge
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-04-12 21:56:09 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-04-12 21:56:09 +0000
commitd81a3b6040914bcb7c1d76bf39cb60eceeaa4234 (patch)
tree4d6d437e56546a5e4097bbc042e9f22eb16298fc /games/quake2forge
parente17e2532b977bde598c15eadc1d5821159239054 (diff)
downloadports-d81a3b6040914bcb7c1d76bf39cb60eceeaa4234.tar.gz
ports-d81a3b6040914bcb7c1d76bf39cb60eceeaa4234.zip
Notes
Diffstat (limited to 'games/quake2forge')
-rw-r--r--games/quake2forge/Makefile17
-rw-r--r--games/quake2forge/files/patch-src__gl_fxmesa.c11
-rw-r--r--games/quake2forge/files/patch-src__gl_glx.c11
-rw-r--r--games/quake2forge/pkg-message18
-rw-r--r--games/quake2forge/pkg-plist2
5 files changed, 43 insertions, 16 deletions
diff --git a/games/quake2forge/Makefile b/games/quake2forge/Makefile
index 6538926c87cd..0985607ae66e 100644
--- a/games/quake2forge/Makefile
+++ b/games/quake2forge/Makefile
@@ -19,12 +19,11 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= alepulver@FreeBSD.org
COMMENT= First Person Shooter with many addons available
-USE_BZIP2= yes
USE_AUTOTOOLS= autoconf:259 libtool:15
-USE_REINPLACE= yes
+USE_BZIP2= yes
WANT_SDL= yes
-CONFIGURE_ARGS= --program-transform-name='s/^quake2$$/q2f/'
+CONFIGURE_ARGS= --program-transform-name='s/^quake2$$/${PORTNAME}/'
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
OPTIONS= AO "Enable libao support" off \
@@ -41,7 +40,7 @@ LIBDIR= ${PREFIX}/lib/${PORTNAME}
.include <bsd.port.pre.mk>
-.if defined(WITH_AO) || exists(${LOCALBASE}/lib/libao.so.3)
+.if defined(WITH_AO)
LIB_DEPENDS+= ao.3:${PORTSDIR}/audio/libao
CONFIGURE_ARGS+=--with-ao=${LOCALBASE}
PLIST_SUB+= AO=""
@@ -50,7 +49,7 @@ CONFIGURE_ARGS+=--without-ao
PLIST_SUB+= AO="@comment "
.endif
-.if defined(WITH_GL) || exists(${X11BASE}/lib/libGL.so.1)
+.if !defined(WITHOUT_GL)
USE_GL= yes
CONFIGURE_ARGS+=--with-opengl=${X11BASE}
PLIST_SUB+= GL=""
@@ -70,7 +69,7 @@ PLIST_SUB+= ROGUE=""
PLIST_SUB+= ROGUE="@comment "
.endif
-.if defined(WITH_SDL) || ${HAVE_SDL:Msdl}!=""
+.if defined(WITH_SDL)
USE_SDL= yes
CONFIGURE_ARGS+=--with-sdl=${LOCALBASE}
PLIST_SUB+= SDL=""
@@ -79,13 +78,13 @@ CONFIGURE_ARGS+=--disable-sdl --disable-sdltest
PLIST_SUB+= SDL="@comment "
.endif
-.if defined(WITH_GL) && (defined(WITH_SDL) || ${HAVE_SDL:Msdl}!="")
+.if !defined(WITHOUT_GL) && (defined(WITH_SDL)
PLIST_SUB+= SDLGL=""
.else
PLIST_SUB+= SDLGL="@comment "
.endif
-.if defined(WITH_SVGA) || exists(${LOCALBASE}/lib/libvga.so.1)
+.if defined(WITH_SVGA)
LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
CONFIGURE_ARGS+=--with-svgalib=${LOCALBASE}
PLIST_SUB+= SVGA=""
@@ -94,7 +93,7 @@ CONFIGURE_ARGS+=--with-svgalib=no
PLIST_SUB+= SVGA="@comment "
.endif
-.if defined(WITH_X11) || exists(${X11BASE}/lib/libX11.so.6)
+.if !defined(WITHOUT_X11)
USE_XLIB= yes
CONFIGURE_ARGS+=--with-x
PLIST_SUB+= X11=""
diff --git a/games/quake2forge/files/patch-src__gl_fxmesa.c b/games/quake2forge/files/patch-src__gl_fxmesa.c
new file mode 100644
index 000000000000..3487f933ac2d
--- /dev/null
+++ b/games/quake2forge/files/patch-src__gl_fxmesa.c
@@ -0,0 +1,11 @@
+--- src/gl_fxmesa.c.orig Sat Jul 20 01:30:46 2002
++++ src/gl_fxmesa.c Wed Feb 22 20:24:51 2006
+@@ -72,8 +72,6 @@
+ extern cvar_t *vid_fullscreen;
+ extern cvar_t *vid_ref;
+
+-#define GLAPI extern
+-#define GLAPIENTRY
+
+ #define FXMESA_NONE 0 // to terminate attribList
+ #define FXMESA_DOUBLEBUFFER 10
diff --git a/games/quake2forge/files/patch-src__gl_glx.c b/games/quake2forge/files/patch-src__gl_glx.c
new file mode 100644
index 000000000000..08c18af39eaf
--- /dev/null
+++ b/games/quake2forge/files/patch-src__gl_glx.c
@@ -0,0 +1,11 @@
+--- src/gl_glx.c.orig Sun Mar 14 23:25:43 2004
++++ src/gl_glx.c Wed Feb 22 20:20:51 2006
+@@ -797,8 +797,6 @@
+ {
+ mx += ((int)event.xmotion.x - mwx) * 2;
+ my += ((int)event.xmotion.y - mwy) * 2;
+- mwx = event.xmotion.x;
+- mwy = event.xmotion.y;
+
+ if (mx || my)
+ dowarp = true;
diff --git a/games/quake2forge/pkg-message b/games/quake2forge/pkg-message
index 710a12bf61a6..5920b446ea37 100644
--- a/games/quake2forge/pkg-message
+++ b/games/quake2forge/pkg-message
@@ -1,9 +1,15 @@
-============================================================
+==============================================================================
-If you experience problems with mouse movements when running
-in GLX-Mode, try setting in_dgamouse to 1.
+Quake2Forge has been installed.
-ATTENTION: The Quake2Forge binary now gets installed as q2f
-instead of quake2 to avoid conflicting with games/quake2lnx
+The Quake2Forge binary now gets installed as "quake2forge" instead of "quake2"
+to avoid conflicting with "games/quake2lnx".
-============================================================
+If you experience problems with mouse movements when running in GLX-Mode, try
+setting in_dgamouse to 1 (this is actually for people that use the DGA X11
+extension).
+
+You can not change the gamma in SDL-Mode, but you can use "xgamma" to adjust
+the gamma before and after running Quake2Forge.
+
+==============================================================================
diff --git a/games/quake2forge/pkg-plist b/games/quake2forge/pkg-plist
index e9a098b8cd1a..2ce0912e6f5f 100644
--- a/games/quake2forge/pkg-plist
+++ b/games/quake2forge/pkg-plist
@@ -1,4 +1,4 @@
-bin/q2f
+bin/quake2forge
lib/quake2forge/baseq2/game.a
lib/quake2forge/baseq2/game.la
lib/quake2forge/baseq2/game.so