aboutsummaryrefslogtreecommitdiff
path: root/games/quake2lnx
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-03-08 01:01:31 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-03-08 01:01:31 +0000
commit672c044e2eee3598f19a0f5e618e0c2fe8aea68d (patch)
tree771bbdda8fc0a17d5351cfa925732955ccc44706 /games/quake2lnx
parent86240c80e62c10278c8b2c49d61a2198db15e6ed (diff)
downloadports-672c044e2eee3598f19a0f5e618e0c2fe8aea68d.tar.gz
ports-672c044e2eee3598f19a0f5e618e0c2fe8aea68d.zip
Notes
Diffstat (limited to 'games/quake2lnx')
-rw-r--r--games/quake2lnx/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/games/quake2lnx/Makefile b/games/quake2lnx/Makefile
index 91044d01b52d..4982b94019a3 100644
--- a/games/quake2lnx/Makefile
+++ b/games/quake2lnx/Makefile
@@ -27,6 +27,7 @@ COMMENT= Cleaned up copy of the original Quake II source code
USE_GMAKE= yes
USE_REINPLACE= yes
+WANT_SDL= yes
.include <bsd.port.pre.mk>
@@ -45,10 +46,10 @@ PLIST_SUB+= SVGA="@comment "
.endif
.if defined(WITH_SDLCLIENT) || defined(WITH_SDL) || defined(WITH_SDLGL) \
- || exists(${LOCALBASE}/lib/libSDL-1.1.so.5)
+ || ${HAVE_SDL:Msdl}!=""
. if !(defined(WITHOUT_SDLCLIENT) && defined(WITHOUT_SDL) \
&& defined(WITHOUT_SDLGL))
-USE_SDL= yes
+USE_SDL= sdl
. endif
. if !defined(WITHOUT_SDLCLIENT)
MAKE_ARGS+= BUILD_SDLQUAKE2=YES
@@ -188,13 +189,13 @@ pre-everything::
.if ${ARCH} == "i386" && !(defined(WITH_SVGA) || exists(${LOCALBASE}/lib/libvga.so.1))
@${ECHO_MSG} "Define WITH_SVGA to build SVGA driver"
.endif
-.if !(defined(WITH_SDL) || exists(${LOCALBASE}/lib/libSDL-1.1.so.5))
+.if !(defined(WITH_SDL) || ${HAVE_SDL:Msdl}!="")
@${ECHO_MSG} "Define WITH_SDL to build SDL software driver"
.endif
-.if !(defined(WITH_SDLGL) || exists(${LOCALBASE}/lib/libSDL-1.1.so.5))
+.if !(defined(WITH_SDLGL) || ${HAVE_SDL:Msdl}!="")
@${ECHO_MSG} "Define WITH_SDLGL to build SDL OpenGL driver"
.endif
-.if !(defined(WITH_SDLCLIENT) || exists(${LOCALBASE}/lib/libSDL-1.1.so.5))
+.if !(defined(WITH_SDLCLIENT) || ${HAVE_SDL:Msdl}!="")
@${ECHO_MSG} "Define WITH_SDLCLIENT to build executable that uses SDL for cdrom and sound"
.endif
.if !(defined(WITH_AA) || exists(${LOCALBASE}/lib/libaa.so.1))