aboutsummaryrefslogtreecommitdiff
path: root/games/quake3-wfa/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-11-22 07:22:14 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-11-22 07:22:14 +0000
commit9085c8d000ce93a8bc191136bc83bdf1f77911c4 (patch)
treecdf00a06ba0698e22c89956d34bbc401d33753a3 /games/quake3-wfa/Makefile
parent3ad0691868c73464d055d52d65105c9fd5cf8776 (diff)
Notes
Diffstat (limited to 'games/quake3-wfa/Makefile')
-rw-r--r--games/quake3-wfa/Makefile41
1 files changed, 27 insertions, 14 deletions
diff --git a/games/quake3-wfa/Makefile b/games/quake3-wfa/Makefile
index 88c11b695a04..5eac5149b912 100644
--- a/games/quake3-wfa/Makefile
+++ b/games/quake3-wfa/Makefile
@@ -6,22 +6,35 @@
#
PORTNAME= wfa
-PORTVERSION= 3.3
-MASTER_SITES= ftp://ftp.ogl.org/pub/q3/wfa/ \
- ftp://urgentfury.org/pub/quake3/ \
- http://wfa.themelon.net/wfa/ \
- ftp://mirror1.planetice.net/pub/wfa/ \
- ftp://mirror2.planetice.net/pub/wfa/ \
- http://www.quakeshit.com/files/ \
- ftp://ftp2.extreme-players.de/q3/mod/wfa/
-DISTFILES= WFA_Media_v33.zip WFA_MapPack1_v33.zip \
- WFA_MapPack2_v33.zip
+PORTVERSION= 3.5b
+CATEGORIES= games
+MASTER_SITES= http://www.ijs.si/~lesi/distfiles/
+DISTFILES= WFA35Engine.zip WFA35MapPack1.zip WFA35MapPack2.zip \
+ WFA_v35b.zip 35b_mappack1.zip
+DIST_SUBDIR= ${PORTNAME}
-COMMENT= Quake III Arena Mod: Weapons Factory Arena for Linux
+MAINTAINER= pat@FreeBSD.org
+COMMENT= Quake III Arena Mod: Weapons Factory Arena
-EXTRACT_BEFORE_ARGS= -o -qq
+USE_ZIP= yes
+NO_BUILD= yes
NO_WRKSUBDIR= yes
-Q3_MOD_MASTER= ${.CURDIR}/../q3server-ra3
+post-extract:
+ @${RM} ${WRKSRC}/help/BobWFACfgV236.exe
-.include "${Q3_MOD_MASTER}/Makefile"
+do-install:
+ @${MKDIR} ${DATADIR}
+.for f in *.cfg *.pk3
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DATADIR}
+.endfor
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in EnglishRadioHelp help
+ @${CP} -R ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include "${.CURDIR}/../quake3-data/Makefile.include"
+
+.include <bsd.port.mk>