aboutsummaryrefslogtreecommitdiff
path: root/games/quakeforge/Makefile
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2019-11-05 22:21:16 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2019-11-05 22:21:16 +0000
commita3c56e68df3a7bf6713f80ab7c2e99f961e98a80 (patch)
tree831a3c893bea5650066440c5b2854bd428d2cc44 /games/quakeforge/Makefile
parent680550419d6ab5747243411408ef3f63ee7d4b77 (diff)
downloadports-a3c56e68df3a7bf6713f80ab7c2e99f961e98a80.tar.gz
ports-a3c56e68df3a7bf6713f80ab7c2e99f961e98a80.zip
Notes
Diffstat (limited to 'games/quakeforge/Makefile')
-rw-r--r--games/quakeforge/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/games/quakeforge/Makefile b/games/quakeforge/Makefile
index 0e010fa8ec3a..705d69ae2aff 100644
--- a/games/quakeforge/Makefile
+++ b/games/quakeforge/Makefile
@@ -48,6 +48,7 @@ CLIENTS_BUILD_DEPENDS= icotool:graphics/icoutils
CLIENTS_LIB_DEPENDS= libsamplerate.so:audio/libsamplerate \
libcurl.so:ftp/curl
CLIENTS_USES= pkgconfig
+CLIENTS_USES= gl xorg
CLIENTS_USE= gl=glu xorg=xext
CLIENTS_CONFIGURE_OFF= --with-clients=""
CLIENTS_VERS= INSTALLS_ICONS=yes
@@ -76,10 +77,12 @@ VORBIS_CONFIGURE_ON= --with-ogg=${LOCALBASE} --with-vorbis=${LOCALBASE}
VORBIS_CONFIGURE_OFF= --disable-vorbis
VORBIS_IMPLIES= CLIENTS
XXF86DGA_DESC= XFree86 DGA Extension support
+XXF86DGA_USES= xorg
XXF86DGA_USE= xorg=xxf86dga
XXF86DGA_CONFIGURE_OFF= --disable-dga
XXF86DGA_IMPLIES= CLIENTS
XXF86VM_DESC= XFree86 Vidmode Extension support
+XXF86VM_USES= xorg
XXF86VM_USE= xorg=xxf86vm
XXF86VM_CONFIGURE_OFF= --disable-vidmode
XXF86VM_IMPLIES= CLIENTS