aboutsummaryrefslogtreecommitdiff
path: root/games/quakeforge
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2003-08-08 13:23:08 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2003-08-08 13:23:08 +0000
commit4e00dbebbe8675f4356208e10188f1f5611e5969 (patch)
tree0e18be756d6d85ac6ce2584ee59fd6118faf90b2 /games/quakeforge
parent40f439aa7fe45b0cd9c2e42c4310ca277178f30c (diff)
downloadports-4e00dbebbe8675f4356208e10188f1f5611e5969.tar.gz
ports-4e00dbebbe8675f4356208e10188f1f5611e5969.zip
Notes
Diffstat (limited to 'games/quakeforge')
-rw-r--r--games/quakeforge/Makefile26
-rw-r--r--games/quakeforge/distinfo2
-rw-r--r--games/quakeforge/files/patch-aa11
-rw-r--r--games/quakeforge/files/patch-ab19
-rw-r--r--games/quakeforge/files/patch-ac10
-rw-r--r--games/quakeforge/files/patch-ad11
-rw-r--r--games/quakeforge/files/patch-ae13
-rw-r--r--games/quakeforge/files/patch-af11
-rw-r--r--games/quakeforge/files/patch-ag11
-rw-r--r--games/quakeforge/files/patch-configure26
-rw-r--r--games/quakeforge/files/patch-ltmain.sh11
-rw-r--r--games/quakeforge/files/patch-qfbsp27
-rw-r--r--games/quakeforge/files/patch-zpak18
-rw-r--r--games/quakeforge/pkg-plist81
14 files changed, 98 insertions, 179 deletions
diff --git a/games/quakeforge/Makefile b/games/quakeforge/Makefile
index 229c0049bc9c..ed4d18564a6d 100644
--- a/games/quakeforge/Makefile
+++ b/games/quakeforge/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= QuakeForge
-PORTVERSION= 0.5.2
-PORTREVISION= 1
+PORTVERSION= 0.5.4
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:S/$/:qf/} \
ftp://ftp.idsoftware.com/idstuff/quakeworld/unix/:qw
@@ -41,12 +40,21 @@ INSTALLS_SHLIB= yes
CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL} \
--with-global-cfg=${PREFIX}/etc/quakeforge.conf \
- --with-sharepath=${PREFIX}/share/quakeforge
+ --with-sharepath=${PREFIX}/share/quakeforge \
+ --disable-optimize
CONFIGURE_TARGET=
BUILD_DEPENDS= bison:${PORTSDIR}/devel/bison
+.if defined(WITH_OPTIMIZED_CFLAGS) && !defined(WITHOUT_OPTIMIZED_CFLAGS)
+CFLAGS+= -O3 -funroll-loops -fomit-frame-pointer -fno-common \
+ -fexpensive-optimizations -fstrict-aliasing
+.if ${ARCH} != "alpha"
+CFLAGS+= -ffast-math
+.endif
+.endif
+
.if exists(${LOCALBASE}/lib/libSDL-1.1.so.5)
WITH_SDL= yes
.endif
@@ -147,6 +155,12 @@ pre-everything::
.if !defined(NO_SKINS)
@${ECHO_MSG} "Define NO_SKINS to stop from installing skins"
.endif
+.if !defined(WITH_OPTIMIZED_CFLAGS)
+ @${ECHO_MSG} "Define WITH_OPTIMIZED_CFLAGS to opimize for speed"
+.endif
+.if !defined(WITH_OPTIMIZED_CFLAGS)
+ @${ECHO_MSG} "Define WITH_OPTIMIZED_CFLAGS to opimize for speed"
+.endif
.if !defined(WITH_SVGALIB)
@${ECHO_MSG} "Define WITH_SVGALIB to use svgalib"
.endif
@@ -170,9 +184,7 @@ pre-everything::
.endif
post-patch:
-.if (${ARCH} == "alpha")
- @${REINPLACE_CMD} -e 's/-ffast-math//' ${WRKSRC}/configure
-.endif
+ @${REINPLACE_CMD} -e 's/-lpthread/${PTHREAD_LIBS}/g' ${WRKSRC}/configure
do-install:
@(cd ${INSTALL_WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
@@ -203,6 +215,6 @@ do-install:
.endif
post-install:
- @${SED} -e 's#$${PREFIX}#${PREFIX}#g' ${PKGMESSAGE}
+ @${SED} -e 's#$${PREFIX}#${PREFIX}#g' ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/games/quakeforge/distinfo b/games/quakeforge/distinfo
index 336e08b9501a..9fb7d46a4760 100644
--- a/games/quakeforge/distinfo
+++ b/games/quakeforge/distinfo
@@ -1,4 +1,4 @@
-MD5 (quakeforge-0.5.2.tar.gz) = 6a47e7b3f886fb0624c8cd5e2830e0a9
+MD5 (quakeforge-0.5.4.tar.gz) = 45688b3d2eb8ccf3284e59e8c34a4d35
MD5 (qwsv-2.30-glibc-i386-unknown-linux2.0.tar.gz) = 75333c66edd156a1695452d3971169d7
MD5 (quakesw-1.0.6.tar.gz) = 663b749612d55de29f74966ec3168918
MD5 (skinbase.zip) = 12f3956955c25aa0d508a4d10e7e0532
diff --git a/games/quakeforge/files/patch-aa b/games/quakeforge/files/patch-aa
deleted file mode 100644
index 0d8d5e12344a..000000000000
--- a/games/quakeforge/files/patch-aa
+++ /dev/null
@@ -1,11 +0,0 @@
---- libs/audio/renderer/Makefile.in.orig Wed Nov 13 20:21:33 2002
-+++ libs/audio/renderer/Makefile.in Wed Nov 13 20:22:16 2002
-@@ -206,7 +206,7 @@
- AUTOMAKE_OPTIONS = foreign
-
- AM_CFLAGS = @PREFER_PIC@
--INCLUDES = -I$(top_srcdir)/include
-+INCLUDES = -I$(top_srcdir)/include $(VORBIS_CFLAGS) $(OGG_CFLAGS)
- plugin_version = 1:0:0
-
- plugin_PROGRAMS = @SND_REND_TARGETS@
diff --git a/games/quakeforge/files/patch-ab b/games/quakeforge/files/patch-ab
deleted file mode 100644
index 57a656c45c55..000000000000
--- a/games/quakeforge/files/patch-ab
+++ /dev/null
@@ -1,19 +0,0 @@
---- libs/util/quakeio.c.orig 16 Oct 2002 04:59:34 -0000 1.18
-+++ libs/util/quakeio.c 24 Oct 2002 22:36:15 -0000 1.19
-@@ -425,8 +425,14 @@
- res = fseek (file->file, offset, whence);
- break;
- case SEEK_END:
-- res = fseek (file->file,
-- file->start + file->size - offset, SEEK_SET);
-+ if (file->size == -1) {
-+ // we don't know the size (due to writing) so punt and
-+ // pass on the request as-is
-+ res = fseek (file->file, offset, SEEK_END);
-+ } else {
-+ res = fseek (file->file,
-+ file->start + file->size - offset, SEEK_SET);
-+ }
- break;
- default:
- errno = EINVAL;
diff --git a/games/quakeforge/files/patch-ac b/games/quakeforge/files/patch-ac
deleted file mode 100644
index 42773123b4e4..000000000000
--- a/games/quakeforge/files/patch-ac
+++ /dev/null
@@ -1,10 +0,0 @@
---- libs/audio/renderer/Makefile.am.orig Wed Nov 13 21:30:38 2002
-+++ libs/audio/renderer/Makefile.am Wed Nov 13 21:30:47 2002
-@@ -1,6 +1,6 @@
- AUTOMAKE_OPTIONS= foreign
-
--AM_CFLAGS= @PREFER_PIC@
-+AM_CFLAGS= @PREFER_PIC@ @VORBIS_CFLAGS@
- INCLUDES= -I$(top_srcdir)/include
- plugin_version= 1:0:0
- plugin_ldflags= @plugin_ldflags@
diff --git a/games/quakeforge/files/patch-ad b/games/quakeforge/files/patch-ad
deleted file mode 100644
index 83da6b11792a..000000000000
--- a/games/quakeforge/files/patch-ad
+++ /dev/null
@@ -1,11 +0,0 @@
---- libs/audio/targets/snd_oss.c.orig Wed Nov 13 22:21:14 2002
-+++ libs/audio/targets/snd_oss.c Wed Nov 13 22:19:08 2002
-@@ -252,7 +252,7 @@
- if (mmaped_io) { // memory map the dma buffer
- shm->buffer = (unsigned char *) mmap
- (NULL, info.fragstotal * info.fragsize,
--#if (defined(BSD)) // workaround for BSD OSS quirk
-+#if (defined(__FreeBSD__) && (__FreeBSD_version < 500000)) // workaround for BSD OSS quirk
- PROT_READ | PROT_WRITE,
- #else
- PROT_WRITE,
diff --git a/games/quakeforge/files/patch-ae b/games/quakeforge/files/patch-ae
deleted file mode 100644
index 3ebeacd18bb0..000000000000
--- a/games/quakeforge/files/patch-ae
+++ /dev/null
@@ -1,13 +0,0 @@
---- libs/video/targets/vid_svgalib.c.orig Mon Jan 13 20:14:39 2003
-+++ libs/video/targets/vid_svgalib.c Mon Jan 13 20:24:38 2003
-@@ -641,4 +641,10 @@
- {
- asm ("outb %b0, %w1" : :"a"(val), "d"(port));
- }
-+#elif defined(__FreeBSD__)
-+static inline void
-+outb (unsigned char value, unsigned short port)
-+{
-+ __asm__ __volatile__ ("outb %b0,%w1"::"a" (value), "d" (port));
-+}
- #endif
diff --git a/games/quakeforge/files/patch-af b/games/quakeforge/files/patch-af
deleted file mode 100644
index 2c7b93fadc46..000000000000
--- a/games/quakeforge/files/patch-af
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Mon Jan 6 17:45:41 2003
-+++ configure Mon Jan 6 17:46:42 2003
-@@ -15588,7 +15588,7 @@
- no_sdl=yes
- else
- SDL_CFLAGS=`$SDL_CONFIG $sdlconf_args --cflags`
-- SDL_LIBS=`$SDL_CONFIG $sdlconf_args --libs`
-+ SDL_LIBS=`$SDL_CONFIG $sdlconf_args --libs | sed 's/-lc_r/-pthread/'`
-
- sdl_major_version=`$SDL_CONFIG $sdl_args --version | \
- sed 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\1/'`
diff --git a/games/quakeforge/files/patch-ag b/games/quakeforge/files/patch-ag
deleted file mode 100644
index e265565c2855..000000000000
--- a/games/quakeforge/files/patch-ag
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./qw/source/teamplay.c.orig Fri Jan 31 20:27:27 2003
-+++ ./qw/source/teamplay.c Fri Jan 31 20:26:48 2003
-@@ -493,7 +493,7 @@
- {
- int i;
-
-- for (i = 0; f_replies[i].name; i++)
-+ for (i = 0; i < sizeof(f_replies) / sizeof(f_replies[0]); i++)
- f_replies[i].lasttime = realtime - cl_freply->value;
- return;
- }
diff --git a/games/quakeforge/files/patch-configure b/games/quakeforge/files/patch-configure
new file mode 100644
index 000000000000..587800682134
--- /dev/null
+++ b/games/quakeforge/files/patch-configure
@@ -0,0 +1,26 @@
+--- configure.orig Sun Jul 27 13:19:51 2003
++++ configure Sun Jul 27 13:41:57 2003
+@@ -2042,10 +2042,10 @@
+ ac_compiler_gnu=$ac_cv_c_compiler_gnu
+
+
+-if test ${CFLAGS-unset} = unset; then
++if test "${CFLAGS-unset}" = unset; then
+ CFLAGS=""
+ fi
+-if test ${AR-unset} = unset; then
++if test "${AR-unset}" = unset; then
+ AR="ar"
+ fi
+ export AR
+@@ -8333,6 +8333,9 @@
+ else
+ CPP_NAME="cpp %d -o %o %i"
+ case "$target_os" in
++ *freebsd*)
++ CPP_NAME="cpp %d %i %o"
++ ;;
+ *bsd*)
+ touch conftest.c
+ CPP_NAME="`(f=\`$CC -v -E -Dfoo conftest.c -o conftest.i 2>&1 | grep -e -Dfoo\`; set $f; echo "$1")` %d %i %o"
+
diff --git a/games/quakeforge/files/patch-ltmain.sh b/games/quakeforge/files/patch-ltmain.sh
new file mode 100644
index 000000000000..70b61a47376a
--- /dev/null
+++ b/games/quakeforge/files/patch-ltmain.sh
@@ -0,0 +1,11 @@
+--- ltmain.sh.orig Sun Jul 27 16:09:51 2003
++++ ltmain.sh Sun Jul 27 16:10:01 2003
+@@ -1052,7 +1052,7 @@
+ esac
+ elif test "X$arg" = "X-lc_r"; then
+ case $host in
+- *-*-openbsd* | *-*-freebsd*)
++ *-*-openbsd* | *-*-freebsd4*)
+ # Do not include libc_r directly, use -pthread flag.
+ continue
+ ;;
diff --git a/games/quakeforge/files/patch-qfbsp b/games/quakeforge/files/patch-qfbsp
deleted file mode 100644
index 34a84541f324..000000000000
--- a/games/quakeforge/files/patch-qfbsp
+++ /dev/null
@@ -1,27 +0,0 @@
---- tools/qfbsp/source/qfbsp.c.orig Wed Jun 25 18:33:19 2003
-+++ tools/qfbsp/source/qfbsp.c Wed Jun 25 18:45:55 2003
-@@ -30,6 +30,9 @@
- # include <strings.h>
- #endif
- #include <stdlib.h>
-+#include <sys/types.h>
-+#include <sys/wait.h>
-+#include <unistd.h>
-
- #include "QF/quakefs.h"
- #include "QF/sys.h"
-@@ -748,12 +751,12 @@
- if (!fork ()) {
- hullnum = 1;
- options.verbosity = 0;
-- drawflag = false;
-+ options.drawflag = false;
- sprintf (argv0, "HUL%i", hullnum);
- } else if (!fork ()) {
- hullnum = 2;
- options.verbosity = 0;
-- drawflag = false;
-+ options.drawflag = false;
- sprintf (argv0, "HUL%i", hullnum);
- }
- CreateSingleHull ();
diff --git a/games/quakeforge/files/patch-zpak b/games/quakeforge/files/patch-zpak
deleted file mode 100644
index cd078b0c2c47..000000000000
--- a/games/quakeforge/files/patch-zpak
+++ /dev/null
@@ -1,18 +0,0 @@
---- tools/zpak.orig Sat Mar 15 23:32:09 2003
-+++ tools/zpak Sat Mar 15 23:58:52 2003
-@@ -1,4 +1,4 @@
--#! /bin/bash
-+#!/bin/sh
- # create pak files with gzipped internals
-
- if [ $# -eq 0 ]; then
-@@ -18,7 +18,7 @@
-
- # cosmetic (gzip preserves timestamps.. could come in handy)
- find * -type f \
-- -exec touch {} -r ${pakfile} \;
-+ -exec touch -r ${pakfile} {} \;
-
- find * -type f \
- ! -name '*.gz' ! -name '*.jpg' ! -name '*.ogg' ! -name '*.png' \
-
diff --git a/games/quakeforge/pkg-plist b/games/quakeforge/pkg-plist
index 358006dea53e..692a8231d115 100644
--- a/games/quakeforge/pkg-plist
+++ b/games/quakeforge/pkg-plist
@@ -1,6 +1,7 @@
bin/zpak
%%SERVER:%%bin/qw-server
%%SERVER:%%bin/qw-master
+%%SERVER:%%bin/hw-master
%%SERVER:%%bin/nq-server
%%CLIENT:%%bin/qw-client-glx
%%CLIENT:%%bin/qw-client-x11
@@ -16,6 +17,7 @@ bin/zpak
%%CLIENT:%%%%SDL:%%bin/nq-sgl
%%CLIENT:%%%%SVGA:%%bin/nq-3dfx
%%CLIENT:%%%%SVGA:%%bin/nq-svga
+%%TOOL:%%bin/bsp2img
%%TOOL:%%bin/pak
%%TOOL:%%bin/qfbsp
%%TOOL:%%bin/qfcc
@@ -45,6 +47,9 @@ lib/libQFgamecode_builtins.so.1
lib/libQFgamecode_builtins.so
lib/libQFgamecode_builtins.la
lib/libQFgamecode_builtins.a
+lib/libQFgib.so.1
+lib/libQFgib.la
+lib/libQFgib.a
lib/libQFcsqc.so.1
lib/libQFcsqc.so
lib/libQFcsqc.la
@@ -53,6 +58,9 @@ lib/libQFmodels.so.1
lib/libQFmodels.so
lib/libQFmodels.la
lib/libQFmodels.a
+%%TOOL:%%lib/ruamoko/libr.a
+%%TOOL:%%lib/ruamoko/libgui.a
+%%TOOL:%%lib/ruamoko/libcsqc.a
%%CLIENT:%%lib/libQFmodels_sw.so.1
%%CLIENT:%%lib/libQFmodels_sw.so
%%CLIENT:%%lib/libQFmodels_sw.la
@@ -78,38 +86,31 @@ lib/libQFutil.so
lib/libQFutil.la
lib/libQFutil.a
%%WAD:%%share/quakeforge/id1/pak0.pak
-%%TOOL:%%share/quakeforge/id1/game.dat
-%%TOOL:%%share/quakeforge/id1/menu.dat.gz
-share/quakeforge/QFplugins/console_server.so
-share/quakeforge/QFplugins/console_server.la
-share/quakeforge/QFplugins/console_server.a
-share/quakeforge/QFplugins/console_client.so
-share/quakeforge/QFplugins/console_client.la
-share/quakeforge/QFplugins/console_client.a
-%%CLIENT:%%share/quakeforge/QFplugins/cd_null.so
-%%CLIENT:%%share/quakeforge/QFplugins/cd_null.la
-%%CLIENT:%%share/quakeforge/QFplugins/cd_null.a
-%%CLIENT:%%%%XMMS:%%share/quakeforge/QFplugins/cd_xmms.so
-%%CLIENT:%%%%XMMS:%%share/quakeforge/QFplugins/cd_xmms.la
-%%CLIENT:%%%%XMMS:%%share/quakeforge/QFplugins/cd_xmms.a
-%%CLIENT:%%%%SDL:%%share/quakeforge/QFplugins/cd_sdl.so
-%%CLIENT:%%%%SDL:%%share/quakeforge/QFplugins/cd_sdl.la
-%%CLIENT:%%%%SDL:%%share/quakeforge/QFplugins/cd_sdl.a
-%%CLIENT:%%share/quakeforge/QFplugins/snd_output_disk.so
-%%CLIENT:%%share/quakeforge/QFplugins/snd_output_disk.la
-%%CLIENT:%%share/quakeforge/QFplugins/snd_output_disk.a
-%%CLIENT:%%share/quakeforge/QFplugins/snd_output_null.so
-%%CLIENT:%%share/quakeforge/QFplugins/snd_output_null.la
-%%CLIENT:%%share/quakeforge/QFplugins/snd_output_null.a
-%%CLIENT:%%share/quakeforge/QFplugins/snd_output_oss.so
-%%CLIENT:%%share/quakeforge/QFplugins/snd_output_oss.la
-%%CLIENT:%%share/quakeforge/QFplugins/snd_output_oss.a
-%%CLIENT:%%%%SDL:%%share/quakeforge/QFplugins/snd_output_sdl.so
-%%CLIENT:%%%%SDL:%%share/quakeforge/QFplugins/snd_output_sdl.la
-%%CLIENT:%%%%SDL:%%share/quakeforge/QFplugins/snd_output_sdl.a
-%%CLIENT:%%share/quakeforge/QFplugins/snd_render_default.so
-%%CLIENT:%%share/quakeforge/QFplugins/snd_render_default.la
-%%CLIENT:%%share/quakeforge/QFplugins/snd_render_default.a
+%%TOOL:%%share/quakeforge/QF/menu.dat.gz
+lib/quakeforge/console_server.so
+lib/quakeforge/console_server.la
+lib/quakeforge/console_server.a
+lib/quakeforge/console_client.so
+lib/quakeforge/console_client.la
+lib/quakeforge/console_client.a
+%%CLIENT:%%%%XMMS:%%lib/quakeforge/cd_xmms.so
+%%CLIENT:%%%%XMMS:%%lib/quakeforge/cd_xmms.la
+%%CLIENT:%%%%XMMS:%%lib/quakeforge/cd_xmms.a
+%%CLIENT:%%%%SDL:%%lib/quakeforge/cd_sdl.so
+%%CLIENT:%%%%SDL:%%lib/quakeforge/cd_sdl.la
+%%CLIENT:%%%%SDL:%%lib/quakeforge/cd_sdl.a
+%%CLIENT:%%lib/quakeforge/snd_output_disk.so
+%%CLIENT:%%lib/quakeforge/snd_output_disk.la
+%%CLIENT:%%lib/quakeforge/snd_output_disk.a
+%%CLIENT:%%lib/quakeforge/snd_output_oss.so
+%%CLIENT:%%lib/quakeforge/snd_output_oss.la
+%%CLIENT:%%lib/quakeforge/snd_output_oss.a
+%%CLIENT:%%%%SDL:%%lib/quakeforge/snd_output_sdl.so
+%%CLIENT:%%%%SDL:%%lib/quakeforge/snd_output_sdl.la
+%%CLIENT:%%%%SDL:%%lib/quakeforge/snd_output_sdl.a
+%%CLIENT:%%lib/quakeforge/snd_render_default.so
+%%CLIENT:%%lib/quakeforge/snd_render_default.la
+%%CLIENT:%%lib/quakeforge/snd_render_default.a
%%SERVER:%%share/quakeforge/qw/skins/fixskins.sh
%%SERVER:%%share/quakeforge/qw/buttons.qc
%%SERVER:%%share/quakeforge/qw/client.qc
@@ -341,14 +342,7 @@ include/QF/csqc.h
include/QF/cvar.h
include/QF/dstring.h
include/QF/draw.h
-include/QF/gcc_attr.h
-include/QF/gib_buffer.h
-include/QF/gib_builtin.h
-include/QF/gib_function.h
-include/QF/gib_parse.h
-include/QF/gib_process.h
-include/QF/gib_thread.h
-include/QF/gib_vars.h
+include/QF/gib.h
include/QF/hash.h
include/QF/hl.h
include/QF/idparse.h
@@ -380,6 +374,7 @@ include/QF/qtypes.h
include/QF/quakefs.h
include/QF/quakeio.h
include/QF/render.h
+include/QF/riff.h
include/QF/screen.h
include/QF/sizebuf.h
include/QF/skin.h
@@ -393,6 +388,7 @@ include/QF/uint32.h
include/QF/va.h
include/QF/ver_check.h
include/QF/vid.h
+include/QF/view.h
include/QF/wad.h
include/QF/zone.h
include/QF/ruamoko/crudefile.h
@@ -421,6 +417,11 @@ include/QF/ruamoko/InputLine.h
include/QF/ruamoko/Point.h
include/QF/ruamoko/Rect.h
include/QF/ruamoko/Size.h
+include/QF/ruamoko/qfile.h
+include/QF/ruamoko/gib.h
+include/QF/ruamoko/hash.h
+include/QF/ruamoko/plist.h
+include/QF/ruamoko/Array.h
%%PORTDOCS%%share/doc/quakeforge/3dfx.txt
%%PORTDOCS%%share/doc/quakeforge/CodingStyle
%%PORTDOCS%%share/doc/quakeforge/config/glspeed-v1.cfg