aboutsummaryrefslogtreecommitdiff
path: root/games/qudos
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-06-21 19:07:15 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-06-21 19:07:15 +0000
commit34174703e72c5235f1d1d7c03c680e6875c79ffc (patch)
treeaa30d17979fdf7a65c6162e1fc32318c51f23333 /games/qudos
parenta633d7f6d96f667bfcc088d3db4eda04c518eae1 (diff)
downloadports-34174703e72c5235f1d1d7c03c680e6875c79ffc.tar.gz
ports-34174703e72c5235f1d1d7c03c680e6875c79ffc.zip
Notes
Diffstat (limited to 'games/qudos')
-rw-r--r--games/qudos/Makefile46
-rw-r--r--games/qudos/distinfo12
-rw-r--r--games/qudos/files/patch-src__client__snd_dma.c11
-rw-r--r--games/qudos/files/patch-src__unix__gl_glx.c6
-rw-r--r--games/qudos/pkg-plist4
5 files changed, 55 insertions, 24 deletions
diff --git a/games/qudos/Makefile b/games/qudos/Makefile
index d766fc2c5549..c1ee4b2d1606 100644
--- a/games/qudos/Makefile
+++ b/games/qudos/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= qudos
-PORTVERSION= 0.40
+PORTVERSION= 0.40.1
CATEGORIES= games
MASTER_SITES= http://qudos.quakedev.com/linux/quake2/engines/QuDos/
DISTNAME= QuDos-${PORTVERSION}-src
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
- QuDos-${PORTVERSION}-data.tar
+ QuDos.pk3
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= alepulver@FreeBSD.org
@@ -33,17 +33,18 @@ OPTIONS= 3ZB2 "Build 3zb2 modification (bots)" on \
IPV6 "Enable IPv6 support" off \
JABOT "Build JABot modification (bots)" off \
JOYSTICK "Enable joystick support" off \
+ OSS "Enable Open Sound System sound support" on \
QMAX "Enable fancier OpenGL graphics" on \
REDBLUE "Enable red-blue 3d glasses renderer" off \
RETEXTURE "Enable support for retextured graphics" off \
ROGUE "Build Ground Zero (Rogue) mission pack" off \
- SDLCLIENT "Build SDL client" on \
+ SDL "Enable SDL sound support" on \
SDLGL "Build SDL OpenGL renderer" on \
X86_ASM "Enable x86 assembly support" on \
XATRIX "Build The Reckoning (Xatrix) mission pack" off \
ZAERO "Build Zaero modification" off
-MAKE_ENV= WITH_DATADIR=YES WITH_LIBDIR=YES \
+MAKE_ENV= WITH_DATADIR=YES WITH_LIBDIR=YES WITH_XMMS=NO\
DATADIR="${Q2DIR}" LIBDIR="${LIBDIR}"
PLIST_SUB= LIBDIR="${LIBDIR:S/${PREFIX}\///}"
LIBDIR= ${PREFIX}/lib/${PORTNAME}
@@ -70,17 +71,22 @@ LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png
.endif
-.if !defined(WITHOUT_SDLCLIENT) || !defined(WITHOUT_SDLGL)
+.if !defined(WITHOUT_SDL) || !defined(WITHOUT_SDLGL)
USE_SDL= sdl
.endif
-.if !defined(WITHOUT_CLIENT) || !defined(WITHOUT_SDLCLIENT)
+.if !defined(WITHOUT_CLIENT)
LIB_DEPENDS+= vorbis.3:${PORTSDIR}/audio/libvorbis
.endif
.if defined(WITH_ARTS)
LIB_DEPENDS+= artsc.0:${PORTSDIR}/audio/arts
-MAKE_ENV+= WITH_ARTS=YES
+MAKE_ENV+= BUILD_ARTS_SND=YES
+PLIST_SUB+= ARTS=""
+Q2SND+= arts
+.else
+MAKE_ENV+= BUILD_ARTS_SND=NO
+PLIST_SUB+= ARTS="@comment "
.endif
.if !defined(WITHOUT_CLIENT)
@@ -138,6 +144,15 @@ MAKE_ENV+= WITH_JOYSTICK=YES
MAKE_ENV+= WITH_JOYSTICK=NO
.endif
+.if !defined(WITHOUT_OSS)
+MAKE_ENV+= BUILD_OSS_SND=YES
+PLIST_SUB+= OSS=""
+Q2SND+= oss
+.else
+MAKE_ENV+= BUILD_OSS_SND=NO
+PLIST_SUB+= OSS="@comment "
+.endif
+
.if !defined(WITHOUT_QMAX)
MAKE_ENV+= WITH_QMAX=YES
.else
@@ -156,13 +171,13 @@ MAKE_ENV+= WITH_RETEXTURE=YES
MAKE_ENV+= WITH_RETEXTURE=NO
.endif
-.if !defined(WITHOUT_SDLCLIENT)
-MAKE_ENV+= BUILD_SDLQUAKE2=YES
-PLIST_SUB+= SDLCLIENT=""
-Q2BIN+= ${PORTNAME}-sdl
+.if !defined(WITHOUT_SDL)
+MAKE_ENV+= BUILD_SDL_SND=YES
+PLIST_SUB+= SDL=""
+Q2SND+= sdl
.else
-MAKE_ENV+= BUILD_SDLQUAKE2=NO
-PLIST_SUB+= SDLCLIENT="@comment "
+MAKE_ENV+= BUILD_SDL_SND=NO
+PLIST_SUB+= SDL="@comment "
.endif
.if !defined(WITHOUT_X86_ASM)
@@ -184,6 +199,9 @@ do-install:
.for ref in ${Q2REF}
${INSTALL_PROGRAM} ${WRKSRC}/quake2/ref_q2${ref}.so ${LIBDIR}
.endfor
+.for snd in ${Q2SND}
+ ${INSTALL_PROGRAM} ${WRKSRC}/quake2/snd_${snd}.so ${LIBDIR}
+.endfor
.if !defined(WITHOUT_GAME)
${INSTALL_PROGRAM} ${WRKSRC}/quake2/baseq2/game.so ${LIBDIR}/baseq2
.endif
@@ -193,7 +211,7 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/quake2/${mod}/game.so ${LIBDIR}/${mod}
.endif
.endfor
- ${TAR} xf ${DISTDIR}/QuDos-${PORTVERSION}-data.tar -C ${LIBDIR}/baseq2
+ ${INSTALL_DATA} ${_DISTDIR}/QuDos.pk3 ${LIBDIR}/baseq2
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/docs/QuDos.txt ${WRKSRC}/docs/Ogg_readme.txt \
diff --git a/games/qudos/distinfo b/games/qudos/distinfo
index 72308872c9cd..99097c8b3a42 100644
--- a/games/qudos/distinfo
+++ b/games/qudos/distinfo
@@ -1,6 +1,6 @@
-MD5 (QuDos-0.40-src.tar.bz2) = 92430d56d1c57eba586481d145f1110e
-SHA256 (QuDos-0.40-src.tar.bz2) = a503cc4ce38476d935f2d7664796214790f8ff10adf096450d6cbae20099b88f
-SIZE (QuDos-0.40-src.tar.bz2) = 2046270
-MD5 (QuDos-0.40-data.tar) = 4f15fc56f85afb6bde9335214c06b807
-SHA256 (QuDos-0.40-data.tar) = 5771a531615aee97fb59bc8d83ec2a67bd410218cb9b11792ece4f89b88be4c3
-SIZE (QuDos-0.40-data.tar) = 4433920
+MD5 (QuDos-0.40.1-src.tar.bz2) = 1a9006817e0df5cde238704f75597dc1
+SHA256 (QuDos-0.40.1-src.tar.bz2) = 90d8dbbbe4e006b4233b9c8c20bc3da5c240dde8fdf17ccf43ca533d296aa21a
+SIZE (QuDos-0.40.1-src.tar.bz2) = 2031636
+MD5 (QuDos.pk3) = 698ac8420c8ab459b4302df6c4405bc8
+SHA256 (QuDos.pk3) = eb48b5f392d814223487047ccd5aa95753d408277fb323c19688d01e55efccfa
+SIZE (QuDos.pk3) = 5226359
diff --git a/games/qudos/files/patch-src__client__snd_dma.c b/games/qudos/files/patch-src__client__snd_dma.c
new file mode 100644
index 000000000000..339524ec38ae
--- /dev/null
+++ b/games/qudos/files/patch-src__client__snd_dma.c
@@ -0,0 +1,11 @@
+--- ./src/client/snd_dma.c.orig Fri Jun 9 16:42:59 2006
++++ ./src/client/snd_dma.c Sun Jun 11 15:08:02 2006
+@@ -149,7 +149,7 @@
+ snddriver = Cvar_Get("snd_driver", "oss", CVAR_ARCHIVE);
+
+ /* Com_Printf("Loading %s sound output driver", snddriver->string); */
+- snprintf(fn, MAX_OSPATH, "./snd_%s.so", snddriver->string);
++ snprintf(fn, MAX_OSPATH, LIBDIR "/snd_%s.so", snddriver->string);
+ if (stat(fn, &st) == -1) {
+ Com_Printf("\nload %s failed: %s\n", fn, strerror(errno));
+ return;
diff --git a/games/qudos/files/patch-src__unix__gl_glx.c b/games/qudos/files/patch-src__unix__gl_glx.c
index d99e8506f763..8ea5be28242d 100644
--- a/games/qudos/files/patch-src__unix__gl_glx.c
+++ b/games/qudos/files/patch-src__unix__gl_glx.c
@@ -1,6 +1,6 @@
---- ./src/unix/gl_glx.c.orig Wed Mar 29 07:23:22 2006
-+++ ./src/unix/gl_glx.c Tue May 30 17:23:31 2006
-@@ -1271,7 +1271,7 @@
+--- ./src/unix/gl_glx.c.orig Mon Jun 5 19:35:46 2006
++++ ./src/unix/gl_glx.c Sun Jun 11 14:56:13 2006
+@@ -1239,7 +1239,7 @@
#endif
}
#ifdef __FreeBSD__
diff --git a/games/qudos/pkg-plist b/games/qudos/pkg-plist
index 9eb1bb279ec9..212a8948783e 100644
--- a/games/qudos/pkg-plist
+++ b/games/qudos/pkg-plist
@@ -1,6 +1,5 @@
%%CLIENT%%bin/qudos
%%DEDICATED%%bin/qudos-ded
-%%SDLCLIENT%%bin/qudos-sdl
%%3ZB2%%%%LIBDIR%%/3zb2/game.so
%%LIBDIR%%/baseq2/QuDos.pk3
%%GAME%%%%LIBDIR%%/baseq2/game.so
@@ -9,6 +8,9 @@
%%GLX%%%%LIBDIR%%/ref_q2glx.so
%%SDLGL%%%%LIBDIR%%/ref_q2sdlgl.so
%%ROGUE%%%%LIBDIR%%/rogue/game.so
+%%ARTS%%%%LIBDIR%%/snd_arts.so
+%%OSS%%%%LIBDIR%%/snd_oss.so
+%%SDL%%%%LIBDIR%%/snd_sdl.so
%%XATRIX%%%%LIBDIR%%/xatrix/game.so
%%ZAERO%%%%LIBDIR%%/zaero/game.so
%%PORTDOCS%%%%DOCSDIR%%/QuDos.txt