aboutsummaryrefslogtreecommitdiff
path: root/games/r1q2
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /games/r1q2
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
Notes
Diffstat (limited to 'games/r1q2')
-rw-r--r--games/r1q2/Makefile8
-rw-r--r--games/r1q2/files/patch-ref_gl__gl_image.c28
2 files changed, 31 insertions, 5 deletions
diff --git a/games/r1q2/Makefile b/games/r1q2/Makefile
index 11be16a8ed7a..22c310e989a4 100644
--- a/games/r1q2/Makefile
+++ b/games/r1q2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= r1q2
PORTVERSION= 7904
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= games
MASTER_SITES= http://www.r1ch.net/stuff/r1q2/src/
DISTNAME= ${PORTNAME}-b${PORTVERSION}-src
@@ -69,8 +69,9 @@ PLIST_SUB+= GAME="@comment "
USE_GL= yes
USE_SDL= sdl
LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg \
- png.6:${PORTSDIR}/graphics/png
+ png15:${PORTSDIR}/graphics/png
ALL_TARGET+= ref_gl
+CFLAGS+= -I${LOCALBASE}/include/libpng15
PLIST_SUB+= REF_GL=""
.else
PLIST_SUB+= REF_GL="@comment "
@@ -83,9 +84,6 @@ BROKEN= Does not compile on sparc64
post-patch:
@${REINPLACE_CMD} -e 's|game$$(ARCH)|game|g' \
${BUILD_WRKSRC}/game/Makefile
-# Resolve name collision with jpeg-8
- ${REINPLACE_CMD} -e 's|jpeg_mem_src|local_jpeg_mem_src|' \
- ${WRKSRC}/ref_gl/gl_image.c
pre-build:
@${FIND} ${BUILD_WRKSRC} -type d -depth 1 -exec ${MKDIR} {}/.depends \;
diff --git a/games/r1q2/files/patch-ref_gl__gl_image.c b/games/r1q2/files/patch-ref_gl__gl_image.c
new file mode 100644
index 000000000000..7ce3e30e3899
--- /dev/null
+++ b/games/r1q2/files/patch-ref_gl__gl_image.c
@@ -0,0 +1,28 @@
+--- ref_gl/gl_image.c.orig 2012-04-29 06:56:19.000000000 +0200
++++ ref_gl/gl_image.c 2012-04-29 06:56:40.000000000 +0200
+@@ -20,6 +20,7 @@
+
+ #include "gl_local.h"
+ #include <png.h>
++#include <pngpriv.h>
+ #include <jpeglib.h>
+
+ image_t gltextures[MAX_GLTEXTURES];
+@@ -1520,7 +1521,7 @@
+ cinfo->src->bytes_in_buffer -= (size_t) num_bytes;
+ }
+
+-void jpeg_mem_src (j_decompress_ptr cinfo, byte *mem, int len)
++void local_jpeg_mem_src (j_decompress_ptr cinfo, byte *mem, int len)
+ {
+ cinfo->src = (struct jpeg_source_mgr *)(*cinfo->mem->alloc_small)((j_common_ptr) cinfo, JPOOL_PERMANENT, sizeof(struct jpeg_source_mgr));
+ cinfo->src->init_source = jpg_null;
+@@ -1561,7 +1562,7 @@
+
+ cinfo.err = jpeg_std_error(&jerr);
+ jpeg_create_decompress(&cinfo);
+- jpeg_mem_src(&cinfo, rawdata, rawsize);
++ local_jpeg_mem_src(&cinfo, rawdata, rawsize);
+ jpeg_read_header(&cinfo, true);
+ jpeg_start_decompress(&cinfo);
+