aboutsummaryrefslogtreecommitdiff
path: root/games/r1q2
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-09-29 00:52:43 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-09-29 00:52:43 +0000
commit29633bd81b40a151e4d30c7e6f976fe6fa9a69b6 (patch)
tree51ad24a63d5f4675f10b8bc1206f4cca9db98186 /games/r1q2
parent05f58c48255752ee1c110dc66dcd7cd366bdeb46 (diff)
downloadports-29633bd81b40a151e4d30c7e6f976fe6fa9a69b6.tar.gz
ports-29633bd81b40a151e4d30c7e6f976fe6fa9a69b6.zip
Notes
Diffstat (limited to 'games/r1q2')
-rw-r--r--games/r1q2/Makefile3
-rw-r--r--games/r1q2/distinfo6
-rw-r--r--games/r1q2/files/patch-binaries__make.inc12
-rw-r--r--games/r1q2/files/patch-linux__q_shlinux.c30
4 files changed, 14 insertions, 37 deletions
diff --git a/games/r1q2/Makefile b/games/r1q2/Makefile
index 54d1082cf120..96d0f3512104 100644
--- a/games/r1q2/Makefile
+++ b/games/r1q2/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= r1q2
-PORTVERSION= 7322
-PORTREVISION= 1
+PORTVERSION= 7392
CATEGORIES= games
MASTER_SITES= http://www.r1ch.net/stuff/r1q2/src/
DISTNAME= ${PORTNAME}-b${PORTVERSION}-src
diff --git a/games/r1q2/distinfo b/games/r1q2/distinfo
index 634979975f78..37b9863a3950 100644
--- a/games/r1q2/distinfo
+++ b/games/r1q2/distinfo
@@ -1,3 +1,3 @@
-MD5 (r1q2-b7322-src.zip) = 1063441d2a99175898ee5695c5cd5f8b
-SHA256 (r1q2-b7322-src.zip) = 853d3e2392b195a64838c28cf95fd22faaef14911a353d093271fe0b347a0f45
-SIZE (r1q2-b7322-src.zip) = 1133586
+MD5 (r1q2-b7392-src.zip) = a1e0076e44d1807d3b687347371de5cf
+SHA256 (r1q2-b7392-src.zip) = af0f81e80c8922e593c68afa22d7bc2c94d99c97a9d68c3ba6a6945d853ecb45
+SIZE (r1q2-b7392-src.zip) = 1120119
diff --git a/games/r1q2/files/patch-binaries__make.inc b/games/r1q2/files/patch-binaries__make.inc
index 8bb7235b2188..7d0b61a4074c 100644
--- a/games/r1q2/files/patch-binaries__make.inc
+++ b/games/r1q2/files/patch-binaries__make.inc
@@ -1,12 +1,10 @@
---- ./binaries/make.inc.orig Sat Sep 16 16:16:38 2006
-+++ ./binaries/make.inc Sat Dec 16 17:28:37 2006
-@@ -1,7 +1,8 @@
- #turol: for some reason -ffast-math causes strange errors
- #and it's not really any faster
+--- binaries/make.inc.orig Fri Sep 28 21:36:07 2007
++++ binaries/make.inc Fri Sep 28 21:37:31 2007
+@@ -1,5 +1,6 @@
-CFLAGS+=-DNDEBUG -DLINUX -O2 -fno-strict-aliasing -Wall -ffloat-store -pipe -g -MF .depends/$*.d -MMD
-+CFLAGS+=-I$(LOCALBASE)/include -I$(X11BASE)/include -DNDEBUG -DLINUX -DDATADIR='"$(Q2DIR)"' -DLIBDIR='"$(LIBDIR)"' -O2 -fno-strict-aliasing -Wall -ffloat-store -pipe -g -MF .depends/$*.d -MMD
++CFLAGS+=-I$(LOCALBASE)/include -DNDEBUG -DLINUX -DDATADIR='"$(Q2DIR)"' -DLIBDIR='"$(LIBDIR)"' -O2 -fno-strict-aliasing -Wall -ffloat-store -pipe -g -MF .depends/$*.d -MMD
ALLOBJ:=$(ALLSRC:.c=.o)
-+LDFLAGS+=-L$(LOCALBASE)/lib -L$(X11BASE)/lib
++LDFLAGS+=-L$(LOCALBASE)/lib
.PHONY: clean distclean
diff --git a/games/r1q2/files/patch-linux__q_shlinux.c b/games/r1q2/files/patch-linux__q_shlinux.c
index e64b48cea50b..b69af4cde40c 100644
--- a/games/r1q2/files/patch-linux__q_shlinux.c
+++ b/games/r1q2/files/patch-linux__q_shlinux.c
@@ -1,6 +1,6 @@
---- linux/q_shlinux.c.orig Wed Jan 10 19:46:44 2007
-+++ linux/q_shlinux.c Wed Jan 10 19:47:36 2007
-@@ -12,25 +12,23 @@
+--- linux/q_shlinux.c.orig Fri Sep 28 21:38:18 2007
++++ linux/q_shlinux.c Fri Sep 28 21:39:42 2007
+@@ -16,6 +16,10 @@
#include "../qcommon/qcommon.h"
@@ -11,27 +11,7 @@
//===============================================================================
byte *membase;
- int maxhunksize;
- int curhunksize;
-
--#ifdef __FreeBSD__
--#define MMAP_ANON MAP_ANON
--#else
--#define MMAP_ANON MAP_ANONYMOUS
--#endif
--
- void *Hunk_Begin (int maxsize)
- {
- // reserve a huge chunk of memory, but don't commit any yet
- maxhunksize = maxsize + sizeof(int);
- curhunksize = 0;
- membase = mmap(0, maxhunksize, PROT_READ|PROT_WRITE,
-- MAP_PRIVATE|MMAP_ANON, -1, 0);
-+ MAP_PRIVATE|MAP_ANON, -1, 0);
- if (membase == NULL || membase == (byte *)-1)
- Sys_Error("unable to virtual allocate %d bytes", maxsize);
-
-@@ -54,14 +52,29 @@
+@@ -58,14 +62,29 @@
int Hunk_End (void)
{
@@ -63,7 +43,7 @@
return curhunksize;
}
-@@ -107,7 +120,9 @@
+@@ -111,7 +130,9 @@
void Sys_DebugBreak (void)
{