aboutsummaryrefslogtreecommitdiff
path: root/games/race/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-07-16 16:00:15 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-07-16 16:00:15 +0000
commita5ab53ad9867a9697b6f2694afd2d05966c2524a (patch)
tree1a1d94fc0e1d900f6a621714f885e7577e91efe2 /games/race/Makefile
parent70bc85c4aa8c6bfa6f375f0bb3f627a16cb52ed9 (diff)
downloadports-a5ab53ad9867a9697b6f2694afd2d05966c2524a.tar.gz
ports-a5ab53ad9867a9697b6f2694afd2d05966c2524a.zip
Notes
Diffstat (limited to 'games/race/Makefile')
-rw-r--r--games/race/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/games/race/Makefile b/games/race/Makefile
new file mode 100644
index 000000000000..f1fca185ad13
--- /dev/null
+++ b/games/race/Makefile
@@ -0,0 +1,39 @@
+# ex:ts=8
+# Ports collection makefile for: race
+# Date created: Jul 16, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= race
+PORTVERSION= 0.5
+CATEGORIES= games
+MASTER_SITES= ftp://users.freebsd.org.uk/pub/foobar2k/
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= SDL_mixer:${PORTSDIR}/audio/sdl_mixer \
+ SDL_image:${PORTSDIR}/graphics/sdl_image
+
+USE_BZIP2= yes
+USE_REINPLACE= yes
+USE_MESA= yes
+SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+CFLAGS+= "-I${X11BASE}/include"
+MAKE_ENV= CC="${CC} ${CFLAGS}" LDFLAGS="-L${X11BASE}/lib ${PTHREAD_LIBS}"
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|^CC|#CC|g" \
+ -e "s|sdl-config|${SDL_CONFIG}|g" ${WRKSRC}/Makefile
+.for file in game.c main.c menu.c terrain.c textures.c
+ @${REINPLACE_CMD} -e "s|%%DATADIR%%|${DATADIR}|g" ${WRKSRC}/src/${file}
+.endfor
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/race ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}/data
+ ${INSTALL_DATA} ${WRKSRC}/config ${DATADIR}
+ ${CP} -R ${WRKSRC}/data/* ${DATADIR}/data
+
+.include <bsd.port.mk>