aboutsummaryrefslogtreecommitdiff
path: root/games/retroarch
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
commit551be3c7231225ed9c26479af2b8914fb2ef0ea8 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /games/retroarch
parent02f9c9be1699251467efc027f210049dfe14f9c5 (diff)
downloadports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.tar.gz
ports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.zip
Notes
Diffstat (limited to 'games/retroarch')
-rw-r--r--games/retroarch/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/games/retroarch/Makefile b/games/retroarch/Makefile
index 488fc5e838b3..151d59f818d9 100644
--- a/games/retroarch/Makefile
+++ b/games/retroarch/Makefile
@@ -44,7 +44,7 @@ OPENAL_USES= openal:soft
OPENAL_CONFIGURE_ENABLE=al
NETPLAY_CONFIGURE_ENABLE= netplay
PYTHON_CONFIGURE_ENABLE=python
-PYTHON_USES= python:3
+PYTHON_USES= python:3.4+
V4L_LIB_DEPENDS= libv4l2.so:multimedia/libv4l
V4L_BUILD_DEPENDS= v4l_compat>0:multimedia/v4l_compat
V4L_CONFIGURE_ENABLE= v4l2
@@ -80,6 +80,10 @@ post-patch:
/^check_lib OSS_LIB/d' \
${WRKSRC}/qb/config.libs.sh
+post-patch-PYTHON-on:
+ @${REINPLACE_CMD} -e '/check_pkgconf PYTHON/s/python3/python-${PYTHON_VER}/' \
+ ${WRKSRC}/qb/config.libs.sh
+
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/retroarch
@${REINPLACE_CMD} -e 's|# libretro_directory =|libretro_directory = "${PREFIX}/libexec/libretro"|' \