aboutsummaryrefslogtreecommitdiff
path: root/games/ri-li/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-09-11 21:57:40 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-09-11 21:57:40 +0000
commit41f778ba31397ede79e70f0645c853afd439b4fb (patch)
treec8bf4ed4f92ac6e22e4da669b18ec0e12d62b125 /games/ri-li/Makefile
parent767960debff163320425110d5d4b5f6c89da4888 (diff)
downloadports-41f778ba31397ede79e70f0645c853afd439b4fb.tar.gz
ports-41f778ba31397ede79e70f0645c853afd439b4fb.zip
Notes
Diffstat (limited to 'games/ri-li/Makefile')
-rw-r--r--games/ri-li/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/games/ri-li/Makefile b/games/ri-li/Makefile
index 154b16ef22e4..a807f510c827 100644
--- a/games/ri-li/Makefile
+++ b/games/ri-li/Makefile
@@ -19,9 +19,17 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_SDL= sdl mixer
+MAKE_JOBS_SAFE= yes
CONFIGURE_ENV= CPPFLAGS="`${SDL_CONFIG} --cflags` -I${LOCALBASE}/include"
+DESKTOP_ENTRIES="Ri-li" \
+ "Drive a toy wood train in many levels - snake-like arcade game" \
+ "${DATADIR}/Ri-li-icon-48x48.png" \
+ "Ri_li" \
+ "Game;ArcadeGame;" \
+ false
+
post-patch:
@${REINPLACE_CMD} -e 's|-lSDL |`${SDL_CONFIG} --libs`|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e '/strcpy.*DefPath/ s|.*|strcpy(DefPath,"${DATADIR}/");|' ${WRKSRC}/src/main.cc