aboutsummaryrefslogtreecommitdiff
path: root/games/ri-li/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-07-25 11:56:48 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-07-25 11:56:48 +0000
commitcfa62002fae3ecf9d95b2704c5a6fb3106ed5955 (patch)
treec8cbb82bc9896d008b6a43e6c425c35cff6ee8d3 /games/ri-li/Makefile
parent9a74edf16627f0839415c57ce91636a70d3eb2bd (diff)
Ri-li is a arcade game on GPL (General Public License). You drive
a toy wood engine in many levels and you must collect all the coaches for win.You can dowload it and play indefinitely. It's Free. You can play on Linux, Mac OsX, Windows. Full-featured, 8 languages: Arabic, Chinese, English, French, German, Japanese, Russian, Spanish. Colorful animated wood engine, 40 levels in this first version and 3 beautiful musics and many sound effects. WWW: http://ri-li.sourceforge.net/ PR: ports/100394 Submitted by: Dmitry Marakasov <amdmi3(at)mail.ru> Approved by: krion (mentor)
Notes
Notes: svn path=/head/; revision=168719
Diffstat (limited to 'games/ri-li/Makefile')
-rw-r--r--games/ri-li/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/games/ri-li/Makefile b/games/ri-li/Makefile
new file mode 100644
index 000000000000..58a8a5a2dba4
--- /dev/null
+++ b/games/ri-li/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: Ri-li
+# Date created: 03 Jul 2006
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Ri-li
+PORTVERSION= 1.0.3
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ri-li
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= Drive a toy wood train in many levels - snake-like arcade game
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_SDL= sdl mixer
+
+CONFIGURE_ENV= CPPFLAGS="`${SDL_CONFIG} --cflags` -I${X11BASE}/include"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|SDL/|SDL11/|' ${WRKSRC}/src/*.cc ${WRKSRC}/src/*.h
+ @${REINPLACE_CMD} -e 's|-lSDL |`${SDL_CONFIG} --libs`|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/strcpy.*DefPath/ s|.*|strcpy(DefPath,"${DATADIR}/");|' ${WRKSRC}/src/main.cc
+
+.include <bsd.port.mk>