aboutsummaryrefslogtreecommitdiff
path: root/games/rigsofrods
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2010-01-27 23:20:35 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2010-01-27 23:20:35 +0000
commit52756d084a1e444b5d619c8aa650fd2564a85013 (patch)
treeb956dabf5363c3479c99288d150f68281805c389 /games/rigsofrods
parent4b198e97b36cb8052f1872c780d24142083be600 (diff)
downloadports-52756d084a1e444b5d619c8aa650fd2564a85013.tar.gz
ports-52756d084a1e444b5d619c8aa650fd2564a85013.zip
Notes
Diffstat (limited to 'games/rigsofrods')
-rw-r--r--games/rigsofrods/Makefile2
-rw-r--r--games/rigsofrods/files/patch-configurator-CMakeLists.txt16
2 files changed, 13 insertions, 5 deletions
diff --git a/games/rigsofrods/Makefile b/games/rigsofrods/Makefile
index 4f74acd83d0e..8d5dc0d0f5be 100644
--- a/games/rigsofrods/Makefile
+++ b/games/rigsofrods/Makefile
@@ -26,8 +26,6 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libOIS.so:${PORTSDIR}/devel/ois \
RUN_DEPENDS= ${LOCALBASE}/lib/libOIS.so:${PORTSDIR}/devel/ois \
xset:${PORTSDIR}/x11/xset
-BROKEN= does not build
-
USE_ZIP= yes
USE_OPENAL= al
USE_XORG= x11 xt xaw sm ice xext
diff --git a/games/rigsofrods/files/patch-configurator-CMakeLists.txt b/games/rigsofrods/files/patch-configurator-CMakeLists.txt
index d7aa182f214b..ef3d6269052e 100644
--- a/games/rigsofrods/files/patch-configurator-CMakeLists.txt
+++ b/games/rigsofrods/files/patch-configurator-CMakeLists.txt
@@ -1,6 +1,16 @@
--- configurator/CMakeLists.txt.orig 2009-06-25 22:30:12.000000000 +0400
-+++ configurator/CMakeLists.txt 2009-08-13 19:19:37.000000000 +0400
-@@ -27,9 +27,10 @@
++++ configurator/CMakeLists.txt 2010-01-27 22:29:11.000000000 +0300
+@@ -12,6 +12,9 @@
+
+ FIND_PACKAGE(wxWidgets COMPONENTS base core html net)
+ IF(wxWidgets_FOUND)
++ STRING(REGEX REPLACE ";" ";-D" wxWidgets_DEFINITIONS "${wxWidgets_DEFINITIONS}")
++ SET(wxWidgets_DEFINITIONS "-D${wxWidgets_DEFINITIONS}")
++
+ include_directories(${wxWidgets_INCLUDE_DIRS})
+ add_definitions(${wxWidgets_DEFINITIONS} ${wxWidgets_CXX_FLAGS})
+
+@@ -27,9 +30,10 @@
link_directories (${wxWidgets_LIB_DIR})
include_directories (${RoR_Dependencies_SOURCE_DIR}/rorserver-sf/source)
include_directories (${RoR_Dependencies_SOURCE_DIR}/ogrenew/OgreMain/include)
@@ -13,7 +23,7 @@
SET(config_source ${config_source} ${RoR_SOURCE_DIR}/main/source/InputEngine.cpp)
-@@ -48,7 +49,7 @@
+@@ -48,7 +52,7 @@
add_executable(rorconfig ${config_source} ${config_headers} ${config_res})
TARGET_LINK_LIBRARIES(rorconfig ${wxWidgets_LIBRARIES} )