aboutsummaryrefslogtreecommitdiff
path: root/games/robotfindskitten
diff options
context:
space:
mode:
authorSteven Kreuzer <skreuzer@FreeBSD.org>2013-01-13 02:11:13 +0000
committerSteven Kreuzer <skreuzer@FreeBSD.org>2013-01-13 02:11:13 +0000
commitbceca206be2d9d40577cb889725fcf92e48a7421 (patch)
tree11c082dce7125dafd95063d5f7830c989d0f1d02 /games/robotfindskitten
parentc9ce5adb2467ab20bb8005e441e002697aeebde2 (diff)
downloadports-bceca206be2d9d40577cb889725fcf92e48a7421.tar.gz
ports-bceca206be2d9d40577cb889725fcf92e48a7421.zip
Notes
Diffstat (limited to 'games/robotfindskitten')
-rw-r--r--games/robotfindskitten/Makefile26
-rw-r--r--games/robotfindskitten/distinfo4
-rw-r--r--games/robotfindskitten/files/patch-src-Makefile.in14
3 files changed, 24 insertions, 20 deletions
diff --git a/games/robotfindskitten/Makefile b/games/robotfindskitten/Makefile
index 1bcd54a99393..712d4ac96f83 100644
--- a/games/robotfindskitten/Makefile
+++ b/games/robotfindskitten/Makefile
@@ -1,13 +1,8 @@
-# Ports collection makefile for: robotfindskitten
-# Date created: Wed Dec 3, 2003
-# Whom: Ceri Davies (ceri@FreeBSD.org)
-#
+# Created by: Ceri Davies (ceri@FreeBSD.org)
# $FreeBSD$
-#
PORTNAME= robotfindskitten
-PORTVERSION= 1.7320508.406
-PORTREVISION= 1
+PORTVERSION= 2.7182818.701
PORTEPOCH= 1
CATEGORIES= games
MASTER_SITES= http://robotfindskitten.org/download/POSIX/
@@ -15,14 +10,21 @@ MASTER_SITES= http://robotfindskitten.org/download/POSIX/
MAINTAINER= skreuzer@FreeBSD.org
COMMENT= Yet another zen simulation
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
GNU_CONFIGURE= YES
-USE_GNOME= glib12
-INFO= ${PORTNAME}
-PLIST_FILES= bin/robotfindskitten
MAN6= robotfindskitten.6
-post-extract:
- ${RM} ${WRKSRC}/doc/robotfindskitten.info
+post-patch:
+ @${REINPLACE_CMD} -e 's,/usr/share/games/robotfindskitten,${DATADIR},' \
+ ${WRKSRC}/doc/robotfindskitten.6
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/robotfindskitten ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/nki/vanilla.nki ${DATADIR}
+ ${INSTALL_MAN} ${WRKSRC}/doc/robotfindskitten.6 ${MANPREFIX}/man/man6
.include <bsd.port.mk>
diff --git a/games/robotfindskitten/distinfo b/games/robotfindskitten/distinfo
index 07aca0c3f649..42a51652fc06 100644
--- a/games/robotfindskitten/distinfo
+++ b/games/robotfindskitten/distinfo
@@ -1,2 +1,2 @@
-SHA256 (robotfindskitten-1.7320508.406.tar.gz) = 08c8a826c3cf90a7f3dc1d42b087425af661971585f125b9bedca2bcc2a11852
-SIZE (robotfindskitten-1.7320508.406.tar.gz) = 406412
+SHA256 (robotfindskitten-2.7182818.701.tar.gz) = 7749a370796fd23e3b306b00de5f7fb7997a35fef30e3910ff159448c932d719
+SIZE (robotfindskitten-2.7182818.701.tar.gz) = 437810
diff --git a/games/robotfindskitten/files/patch-src-Makefile.in b/games/robotfindskitten/files/patch-src-Makefile.in
index d1f62fc6c7d2..36e31df30a7b 100644
--- a/games/robotfindskitten/files/patch-src-Makefile.in
+++ b/games/robotfindskitten/files/patch-src-Makefile.in
@@ -1,11 +1,13 @@
---- src/Makefile.in.orig 2008-07-04 00:13:35.000000000 -0400
-+++ src/Makefile.in 2008-07-04 00:13:50.000000000 -0400
-@@ -170,7 +170,7 @@
- target_alias = @target_alias@
+--- src.orig/Makefile.in 2012-12-21 14:56:49.000000000 -0500
++++ src/Makefile.in 2013-01-03 21:15:59.000000000 -0500
+@@ -199,8 +199,8 @@
+ top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
-execgamesdir = $(prefix)/games
+-AM_CPPFLAGS = -DSYSTEM_NKI_DIR=\"$(datadir)/games/robotfindskitten\"
+execgamesdir = $(prefix)/bin
- robotfindskitten_SOURCES = draw.h messages.h robotfindskitten.c
++AM_CPPFLAGS = -DSYSTEM_NKI_DIR=\"$(datadir)/robotfindskitten\"
+ robotfindskitten_SOURCES = robotfindskitten.c
+ SPLINT_SUPPRESSIONS = +charintliteral +charindex
all: all-am
-