aboutsummaryrefslogtreecommitdiff
path: root/games/rottdc/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-02-19 08:56:29 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-02-19 08:56:29 +0000
commit67676e1060716e4e1f01df7a49415050b126a921 (patch)
treedb1cba1bdd43f2467487031f7745ac37d976e076 /games/rottdc/Makefile
parenta4e6d056f176908545a48adcf77042fc9fa62c3f (diff)
downloadports-67676e1060716e4e1f01df7a49415050b126a921.tar.gz
ports-67676e1060716e4e1f01df7a49415050b126a921.zip
Notes
Diffstat (limited to 'games/rottdc/Makefile')
-rw-r--r--games/rottdc/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/games/rottdc/Makefile b/games/rottdc/Makefile
new file mode 100644
index 000000000000..34dedc08999f
--- /dev/null
+++ b/games/rottdc/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: rottdc
+# Date created: 18 Feb 2004
+# Whom: Igor Pokrovsky <tiamat@comset.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rottdc
+PORTVERSION= 1.0.2
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= sdl-dc
+DISTNAME= ${PORTNAME}-1.0-2
+
+MAINTAINER= tiamat@comset.net
+COMMENT= Apogee's Rise Of The Triad source port
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_SDL= sdl mixer
+USE_XLIB= yes
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/rott
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/rott ${PREFIX}/bin
+.ifndef (NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/README ${DOCSDIR}
+.for i in cheats cmdline
+ ${INSTALL_DATA} ${WRKSRC}/${i}.txt ${DOCSDIR}
+.endfor
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>