aboutsummaryrefslogtreecommitdiff
path: root/games/rottdc/Makefile
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2008-01-04 21:49:08 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2008-01-04 21:49:08 +0000
commit9f96b49b6371c9ac8ff0b70c9ec4e98ed93ec990 (patch)
tree9d5195b971f9903d1ad03621e2acb99be59da287 /games/rottdc/Makefile
parent30709a3f590945f3b5c44d3096faaa7bd85f919a (diff)
downloadports-9f96b49b6371c9ac8ff0b70c9ec4e98ed93ec990.tar.gz
ports-9f96b49b6371c9ac8ff0b70c9ec4e98ed93ec990.zip
Notes
Diffstat (limited to 'games/rottdc/Makefile')
-rw-r--r--games/rottdc/Makefile24
1 files changed, 13 insertions, 11 deletions
diff --git a/games/rottdc/Makefile b/games/rottdc/Makefile
index 31c267a73cba..111c3c2c71bf 100644
--- a/games/rottdc/Makefile
+++ b/games/rottdc/Makefile
@@ -7,35 +7,37 @@
PORTNAME= rottdc
DISTVERSION= 1.0-2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sdl-dc
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= alepulver@FreeBSD.org
COMMENT= Apogee's Rise Of The Triad source port
USE_BZIP2= yes
USE_GMAKE= yes
USE_SDL= sdl mixer
-USE_XLIB= yes
+PATCH_WRKSRC= ${WRKSRC}/rott
+# Crashes when compiling with -O2 or greater, so downgrade to -O1.
+CFLAGS:= ${CFLAGS:C/-O[2-9]/-O1/}
-WRKSRC= ${WRKDIR}/${DISTNAME}/rott
-
-post-patch:
- @${REINPLACE_CMD} -e '433s,^static ,,' ${WRKSRC}/rt_actor.c
+post-extract:
+ @${CP} ${FILESDIR}/${MAKEFILE} ${WRKSRC}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/rott ${PREFIX}/bin
+.for f in rott rott-sw
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f}/rott ${PREFIX}/bin/${f}
+.endfor
.ifndef (NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.for i in cheats cmdline
- ${INSTALL_DATA} ${WRKSRC}/${i}.txt ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/rott/${i}.txt ${DOCSDIR}
.endfor
.endif
post-install:
- @${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
.include <bsd.port.mk>